Loading ...
Sorry, an error occurred while loading the content.

Re: compile problems when enabling dns

Expand Messages
  • og_gimp
    I tried and got the same error. I checked sleepycat.com and the DB releases are supposedly backward compatible to 1.85. tried making a symlink in the
    Message 1 of 5 , Jan 4, 2002
    • 0 Attachment
      I tried and got the same error. I checked sleepycat.com and the DB
      releases are supposedly backward compatible to 1.85.

      tried making a symlink in the berkley/include/db.h to db_185.h which
      failed

      tried copying it as well in case it was checking for symlinks..failed

      forced config options like so , which failed

      ./configure --with-db=/usr/local/BerkeleyDB.4.0 --with-
      dblib=/usr/local/BerkeleyDB.4.0/lib --enable-dns

      heck for kicks i removed the 185 version check from the config file
      and it still will not pickup db.h

      anyone else get this working?
    • Jeanne Gold
      Whether this is an acceptable solution or not .. I have no idea. But this is what I finally did to get it to compile. First off, I found I did have Berkeley s
      Message 2 of 5 , Jan 28, 2002
      • 0 Attachment
        Whether this is an acceptable solution or not .. I have no idea. But this
        is what I finally did to get it to compile.

        First off, I found I did have Berkeley's DB installed. Infact, I had 3
        version: db1, db2 and db3.

        On my RH 7.1 system, I found them in:

        /usr/include/db1/db.h
        /usr/include/db2/db_185.h
        /usr/include/db3/db_185.h

        What I did was to hardwire the dns_resolv.c file by modifying the lines
        from this:

        #ifdef HAVE_DB_185_H
        #include <db_185.h>
        #else
        #include <db.h>
        #endif /* HAVE_DB_185_H */

        to this:

        #ifdef HAVE_DB_185_H
        #include </usr/include/db2/db_185.h>
        #else
        #include </usr/include/db1/db.h>
        #endif /* HAVE_DB_185_H */

        Whether that's the correct solution or no -- I don't know. I only know it
        compiled. I have yet to install and test.

        In the meantime, I've written to the author. Hopefully, I'll get a better
        answer and share with the rest of the group.

        JGold
      • digging4roots
        Here s the author s reply: Doesn t matter what packages you have installed.. RedHat puts their files in non-standard locations (and moves them around with each
        Message 3 of 5 , Jan 28, 2002
        • 0 Attachment
          Here's the author's reply:

          Doesn't matter what packages you have installed.. RedHat puts their
          files in non-standard locations (and moves them around with each
          release), which is a constant source of aggravation.

          Simple fix is to turn on hostname lookups on your web server, then DNS
          support is not needed. Otherwise, create a symlink in /usr/include to
          db_185.h, and after running the configure script, change the -ldb1 to
          -ldb-3.2 (or maybe -ldb-3.1 based on the above packages.. doesn't seem
          like you have libdb-3.2).

          JGold
        Your message has been successfully submitted and would be delivered to recipients shortly.