Loading ...
Sorry, an error occurred while loading the content.

Re: [webalizer] Re: ld.so.1: webalizer: fatal: libpng.so.2

Expand Messages
  • Bradford L. Barrett
    ... [...] ... Did you add /apps/lib to your LD_LIBRARY_PATH ??? ie: LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/apps/lib You can t just install a library in some
    Message 1 of 7 , Nov 14, 2001
    • 0 Attachment
      > # find / -name libpng.so.2
      > /apps/lib/libpng.so.2
      [...]
      > # echo $PATH
      > :/usr/bin:/usr/sbin:/usr/ucb:/usr/openwin/bin:/apps/bin:/usr/lib:/apps
      > /lib
      >
      > But when I run webalizer, I still get:
      > # webalizer -version
      > ld.so.1: webalizer: fatal: libpng.so.2: open failed: No such file or
      > directory
      > Killed
      >
      > What should I do next?

      Did you add /apps/lib to your LD_LIBRARY_PATH ???
      ie: LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/apps/lib

      You can't just install a library in some non-standard location and expect
      the linker to find it (And $PATH has nothing to do with it).

      In any event, I've updated the Solaris binary package on the ftp site with
      one that has libpng, libgd, libz and libdb statically linked..

      --
      Bradford L. Barrett brad@...
      A free electron in a sea of neutrons DoD#1750 KD4NAW

      Here the ways of men part: if you wish to strive for
      peace of soul and pleasure, then believe; if you wish
      to be a devotee of truth, then inquire. -- Nietzsche
    • Tim Perkins
      Thanks... I m obviously a Unix newbee. I tried adding (creating, in my case) the LD_LIBRARY_PATH, but still got the same error. I ve downloaded the new
      Message 2 of 7 , Nov 14, 2001
      • 0 Attachment
        Thanks... I'm obviously a Unix newbee. I tried adding (creating, in
        my case) the LD_LIBRARY_PATH, but still got the same error. I've
        downloaded the new binary and it ran like a champ!

        Thanks for you help and for supporting this user group,

        Tim Perkins


        --- In webalizer@y..., "Bradford L. Barrett" <brad@m...> wrote:
        > Did you add /apps/lib to your LD_LIBRARY_PATH ???
        > ie: LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/apps/lib
        >
        > You can't just install a library in some non-standard location and
        expect
        > the linker to find it (And $PATH has nothing to do with it).
        >
        > In any event, I've updated the Solaris binary package on the ftp
        site with
        > one that has libpng, libgd, libz and libdb statically linked..
      Your message has been successfully submitted and would be delivered to recipients shortly.