Loading ...
Sorry, an error occurred while loading the content.

HTMLTail displayed twice...

Expand Messages
  • glenn_gagne
    Hi, I have a weird problem that I don t understand. I added a HTMLTail option in webalizer.conf file and when I generate it, I obtain this link twice in the
    Message 1 of 4 , Jun 26, 2011
    • 0 Attachment
      Hi,

      I have a weird problem that I don't understand. I added a HTMLTail option in webalizer.conf file and when I generate it, I obtain this link twice in the webpage at the right bottom.

      Do you know if it's a knowned bug in Webalizer ?

      This is the code I added:

      # HTMLTail defines the HTML code to insert at the bottom of each
      # HTML document, usually to include a link back to your home page.
      HTMLTail <a href="index.html" target="_self">Return to site</a>
    • glenn_gagne
      NOTE: I run Webalizer on Debian 4.1.2 in the cron.daily job with the default options set. In the past (many years ago) I used Red Hat 7.3 and I never see this
      Message 2 of 4 , Jun 26, 2011
      • 0 Attachment
        NOTE: I run Webalizer on Debian 4.1.2 in the cron.daily job with the default options set.

        In the past (many years ago) I used Red Hat 7.3 and I never see this problem.
      • Bradford L. Barrett
        Sounds like you are having your config file read twice.. are you doing something like -c webalizer.conf on the command line when you run the program? If so,
        Message 3 of 4 , Jun 26, 2011
        • 0 Attachment
          Sounds like you are having your config file read twice.. are you
          doing something like "-c webalizer.conf" on the command line when
          you run the program?

          If so, don't :) See the webalizer FAQ (question #11)

          --

          On Sun, 26 Jun 2011, glenn_gagne wrote:

          > Hi,
          >
          > I have a weird problem that I don't understand. I added a HTMLTail
          > option in webalizer.conf file and when I generate it, I obtain this
          > link twice in the webpage at the right bottom.
          >
          > Do you know if it's a knowned bug in Webalizer ?
          >
          > This is the code I added:
          >
          > # HTMLTail defines the HTML code to insert at the bottom of each
          > # HTML document, usually to include a link back to your home page.
          > HTMLTail <a href="index.html" target="_self">Return to site</a>
          >
          >
          >
          >
          > ------------------------------------
          >
          > Webalizer homepage: http://www.webalizer.org
          > Yahoo! Groups Links
          >
          >
          >
        • glenn_gagne
          You re right ! I analyzed the /etc/cron.daily/webalizer file and it call something like: webalizer -c all_conf_files_in_webalizer_folder -Q Then I modified the
          Message 4 of 4 , Jun 27, 2011
          • 0 Attachment
            You're right !

            I analyzed the /etc/cron.daily/webalizer file and it call something like: webalizer -c all_conf_files_in_webalizer_folder -Q

            Then I modified the script file to call simply webalizer -Q and it work fine !!!

            Thank you

            --------------

            P.S. Weird that default Debian setting decided to call the default webalizer.conf file and scan all conf files in /etc/webalizer folder too.



            This problem is solved for me now !
          Your message has been successfully submitted and would be delivered to recipients shortly.