Loading ...
Sorry, an error occurred while loading the content.

Re: [webalizer] webalizer hangs on "History file not found..." message

Expand Messages
  • Sara Pipe
    Thank you for your descriptive message Ger, I tried: ./configure --enable-geoip --enable-bz2 --with-gd=/usr/lib/libdb-4.4.so --with-z=/usr/local/lib/libz.so.1
    Message 1 of 12 , May 21, 2010
      Thank you for your descriptive message Ger,

      I tried: ./configure --enable-geoip --enable-bz2 --with-gd=/usr/lib/libdb-4.4.so --with-z=/usr/local/lib/libz.so.1

      and it is complaining that:
      checking for main in -lm... no
      checking for main in -lz... no
      configure: error: z library not found.. please install libz

      I have zlib installed. I can not understand why. I even reinstalled zlib & it "sudo make install"ed successfully: chmod 644 /usr/local/include/zlib.h /usr/local/include/zconf.h

      Could it be the original problem that:
      When I was saying "make" to webalizer, it said:
      In file included from /usr/local/include/zlib.h:34,
                       from webalizer.c:44:
          373:6: error: token "=" is not valid in preprocessor expressions
          make: *** [webalizer.o] Error 1

      & so I looked into zconf.h and on that line it said:
      /* a little trick to accommodate both "#define _LARGEFILE64_SOURCE" and
       * "#define _LARGEFILE64_SOURCE 1" as requesting 64-bit operations, (even
       * though the former does not conform to the LFS document), but considering
       * both "#undef _LARGEFILE64_SOURCE" and "#define _LARGEFILE64_SOURCE 0" as
       * equivalently requesting no 64-bit operations
      #if -_LARGEFILE64_SOURCE - -1 == 1
      #  undef _LARGEFILE64_SOURCE

      I did not know what to do, so I commented the whole #if & #endif part out. Then the make ran fine, then I got to the gd version problem.

      Do you understand what is going on?

      --- On Mon, 5/17/10, Ger Hobbelt <ger@...> wrote:

      From: Ger Hobbelt <ger@...>
      Subject: Re: [webalizer] webalizer hangs on "History file not found..." message
      To: webalizer@yahoogroups.com
      Date: Monday, May 17, 2010, 7:56 PM



      On Mon, May 17, 2010 at 3:37 PM, Bradford L. Barrett <brad@mrunix. net> wrote:
        Recompile the Webalizer against the new version of gd..

      +1 for above.

      One reminder to add here: check the configure script to see which libs are used by webalizer. You probably need to spec --with-gd=<path> and/or --with-png=<path> ./configure args for webalizer so that the configure script 'sees' the correct gd and png libs.

      ./configure --help
      dumps a list of all options, including those --with-xyz=<path> ones.

      When you spec --with-gd=, you generally don't need to spec --with-gd-lib and --with-gd-include as those are assumed to be <path>/lib and <path>/include, which is correct 99% of the time, particularly when those libs were built from source as well.

      The next bit of trouble then would be making sure the appropriate versions of the shared libs are where they're expected to be.

      man ldd

      for ldd help about showing you which shared libs ( & their versions) are qreuired by your webalizer binary), plus

      man ldconfig

      for some info about making sure the OS 'knows' about those shared libs you just built and 'make install'ed.

      May seem like a lot the first time around, but since you've got trouble, you can either go the static lib route (webalaizer: ./configure --enable-static ) together with --with-gd/png/ ... or stick to shared libs, but juggling a bit to get the 'right' versions there. I'd opt to try the latter before falling back to the former.

      Met vriendelijke groeten / Best regards,

      Ger Hobbelt

      ------------ --------- --------- --------- --------- --
      web:    http://www.hobbelt. com/
             http://www.hebbut. net/
      mail:   ger@hobbelt. com
      mobile: +31-6-11 120 978
      ------------ --------- --------- --------- --------- --

    Your message has been successfully submitted and would be delivered to recipients shortly.