Loading ...
Sorry, an error occurred while loading the content.

Re: [webalizer] webalizer hangs on "History file not found..." message

Expand Messages
  • waldo kitty
    ... your version of webalizer is not compiled against that version of libpng... is this a binary or a source installation? you might need to do a source
    Message 1 of 12 , May 16, 2010
    • 0 Attachment
      On 5/16/2010 14:36, Sara Pipe wrote:
      > Yeah I added the logfile name in front and did
      > Webalizer logfile.log
      >
      > so it ran & now it says:
      > Generating report for March 2010
      > gd-png: fatal libpng error: Incompatible libpng version in application
      > and library
      > Segmentation fault
      >
      > I had just installed the latest libpng....what could be wrong?

      your version of webalizer is not compiled against that version of libpng... is
      this a binary or a source installation?

      you might need to do a source install and recompile webalizer with the libs
      needed... this means that you may have to also install the compilation tools and
      libs... i haven't looked in the webalizer sources in years so i do not recall if
      there is/was a "top limit" on the versions of the libs...

      if this is a binary install, hopefully there are two flavors... one flavor being
      compiled dynamic so that the libs are picked up and the other flavor being
      static so your installed libs don't matter... static binaries will be larger
      since they compile all the libs into the binary... the major plus for this is
      that you don't have to futz around with the installed libs...

      what OS are you running on? how did you install webalizer?

      > Thank you again,
      > Sara
      >
      > ------------------------------------------------------------------------
      > *From:* waldo kitty <wkitty42@...>
      > *To:* webalizer@yahoogroups.com
      > *Sent:* Sun, May 16, 2010 7:17:47 PM
      > *Subject:* Re: [webalizer] webalizer hangs on "History file not
      > found..." message
      >
      > On 5/16/2010 10:38, Sara Pipe wrote:
      > > I am running webalizer for the first time on the server and when I say
      > > "webalizer" and hit enter, it says
      > > "History file not found..." & then it does not do anything anymore.
      > >
      > > Do you know what I should do?
      >
      > if you are only typing "webalizer" on the command line, it may not be
      > looking at
      > your conf or log files... have you customized your conf file for your
      > server?
      > what is the name of your conf file and where is it located?
      >
      > there should be man pages and possibly even the original README.FIRST
      > and README
      > files...
    • Sara Pipe
      Hi Waldo, This is a webalizer source installation. & I am running Redhat on my system. I read http://www.libpng.org/pub/png/pngfaq.html and so I recompiled the
      Message 2 of 12 , May 16, 2010
      • 0 Attachment
        Hi Waldo,

        This is a webalizer source installation.


        & I am running Redhat on my system.


        I read http://www.libpng.org/pub/png/pngfaq.html and so I recompiled the libraries again. It gave the same error again :(


        Any clues?


        Thanks,

        Sara

         

        From: waldo kitty <wkitty42@...>
        To: webalizer@yahoogroups.com
        Sent: Sun, May 16, 2010 9:02:51 PM
        Subject: Re: [webalizer] webalizer hangs on "History file not found..." message

         

        On 5/16/2010 14:36, Sara Pipe wrote:
        > Yeah I added the logfile name in front and did
        > Webalizer logfile.log
        >
        > so it ran & now it says:
        > Generating report for March 2010
        > gd-png: fatal libpng error: Incompatible libpng version in application
        > and library
        > Segmentation fault
        >
        > I had just installed the latest libpng....what could be wrong?

        your version of webalizer is not compiled against that version of libpng... is
        this a binary or a source installation?

        you might need to do a source install and recompile webalizer with the libs
        needed... this means that you may have to also install the compilation tools and
        libs... i haven't looked in the webalizer sources in years so i do not recall if
        there is/was a "top limit" on the versions of the libs...

        if this is a binary install, hopefully there are two flavors... one flavor being
        compiled dynamic so that the libs are picked up and the other flavor being
        static so your installed libs don't matter... static binaries will be larger
        since they compile all the libs into the binary... the major plus for this is
        that you don't have to futz around with the installed libs...

        what OS are you running on? how did you install webalizer?

        > Thank you again,
        > Sara
        >
        > ----------------------------------------------------------
        > *From:* waldo kitty <wkitty42@...>
        > *To:* webalizer@yahoogroups.com
        > *Sent:* Sun, May 16, 2010 7:17:47 PM
        > *Subject:* Re: [webalizer] webalizer hangs on "History file not
        > found..." message
        >
        > On 5/16/2010 10:38, Sara Pipe wrote:
        > > I am running webalizer for the first time on the server and when I say
        > > "webalizer" and hit enter, it says
        > > "History file not found..." & then it does not do anything anymore.
        > >
        > > Do you know what I should do?
        >
        > if you are only typing "webalizer" on the command line, it may not be
        > looking at
        > your conf or log files... have you customized your conf file for your
        > server?
        > what is the name of your conf file and where is it located?
        >
        > there should be man pages and possibly even the original README.FIRST
        > and README
        > files...


      • Ger Hobbelt
        From the error message, I d say it looks like webalizer directly or indirectly uses libgd as well (haven ;t checked, this is off the cuff) and libgd is
        Message 3 of 12 , May 17, 2010
        • 0 Attachment
          From the error message, I'd say it looks like webalizer directly or indirectly uses libgd as well (haven';t checked, this is off the cuff) and libgd is complaining. Given that you reported a webalizer source install, the way forward would be to check if libgd is required (most probably, as gd is often used for graphing) and when yes, gd must also be upgraded, alas.


          --
          Met vriendelijke groeten / Best regards,

          Ger Hobbelt

          --------------------------------------------------
          web:    http://www.hobbelt.com/
                 http://www.hebbut.net/
          mail:   ger@...
          mobile: +31-6-11 120 978
          --------------------------------------------------

        • Sara Pipe
          Dear all, I have Linux redhat server and I have installed source code of  webalizer-2.21-02 & libpng-1.2.18 on it. When I am trying to run webalizer it says:
          Message 4 of 12 , May 17, 2010
          • 0 Attachment
            Dear all,

            I have Linux redhat server and I have installed source code of  webalizer-2.21-02 & libpng-1.2.18 on it.

            When I am trying to run webalizer it says:

            Generating report for March 2010
            gd-png: fatal libpng error: Incompatible libpng version in application and library
             Segmentation fault

            I can not see why. It does not even say which version of libpng is it seeing in application and which one is it seeing in the library, they shouldbe both libpng-1.2.18.

            Does anyone know how to fix it?

            Thanks,
            Sara


          • Sara Pipe
            Hi Ger, Thanks for your reply. Do you know which version of gd do I have to install? I have  webalizer-2.21-02 and libpng-1.2.18. Thank you, Sara ... From:
            Message 5 of 12 , May 17, 2010
            • 0 Attachment
              Hi Ger,

              Thanks for your reply.

              Do you know which version of gd do I have to install? I have  webalizer-2.21-02 and libpng-1.2.18.

              Thank you,
              Sara

              --- On Mon, 5/17/10, Ger Hobbelt <ger@...> wrote:

              From: Ger Hobbelt <ger@...>
              Subject: Re: [webalizer] webalizer hangs on "History file not found..." message
              To: webalizer@yahoogroups.com
              Date: Monday, May 17, 2010, 8:44 AM

               

              From the error message, I'd say it looks like webalizer directly or indirectly uses libgd as well (haven';t checked, this is off the cuff) and libgd is complaining. Given that you reported a webalizer source install, the way forward would be to check if libgd is required (most probably, as gd is often used for graphing) and when yes, gd must also be upgraded, alas.


              --
              Met vriendelijke groeten / Best regards,

              Ger Hobbelt

              ------------ --------- --------- --------- --------- --
              web:    http://www.hobbelt. com/
                     http://www.hebbut. net/
              mail:   ger@hobbelt. com
              mobile: +31-6-11 120 978
              ------------ --------- --------- --------- --------- --


            • Sara Pipe
              Dear Ger, I also upgraded gd again. But no luck. I have gd-2.0.35 and it is giving the same error. ... From: Sara Pipe Subject: Re:
              Message 6 of 12 , May 17, 2010
              • 0 Attachment
                Dear Ger,

                I also upgraded gd again. But no luck. I have gd-2.0.35 and it is giving the same error.

                :(

                --- On Mon, 5/17/10, Sara Pipe <sara_im_pipes@...> wrote:

                From: Sara Pipe <sara_im_pipes@...>
                Subject: Re: [webalizer] webalizer hangs on "History file not found..." message
                To: webalizer@yahoogroups.com
                Date: Monday, May 17, 2010, 9:17 AM

                 

                Hi Ger,

                Thanks for your reply.

                Do you know which version of gd do I have to install? I have  webalizer-2. 21-02 and libpng-1.2.18.

                Thank you,
                Sara

                --- On Mon, 5/17/10, Ger Hobbelt <ger@hobbelt. com> wrote:

                From: Ger Hobbelt <ger@hobbelt. com>
                Subject: Re: [webalizer] webalizer hangs on "History file not found..." message
                To: webalizer@yahoogrou ps.com
                Date: Monday, May 17, 2010, 8:44 AM

                 

                From the error message, I'd say it looks like webalizer directly or indirectly uses libgd as well (haven';t checked, this is off the cuff) and libgd is complaining. Given that you reported a webalizer source install, the way forward would be to check if libgd is required (most probably, as gd is often used for graphing) and when yes, gd must also be upgraded, alas.


                --
                Met vriendelijke groeten / Best regards,

                Ger Hobbelt

                ------------ --------- --------- --------- --------- --
                web:    http://www.hobbelt. com/
                       http://www.hebbut. net/
                mail:   ger@hobbelt. com
                mobile: +31-6-11 120 978
                ------------ --------- --------- --------- --------- --



              • Bradford L. Barrett
                Recompile the Webalizer against the new version of gd.. --
                Message 7 of 12 , May 17, 2010
                • 0 Attachment
                  Recompile the Webalizer against the new version of gd..

                  --

                  On Mon, 17 May 2010, Sara Pipe wrote:

                  > Dear Ger,
                  >
                  > I also upgraded gd again. But no luck. I have gd-2.0.35 and it is giving the same error.
                  >
                  > :(
                  >
                  > --- On Mon, 5/17/10, Sara Pipe <sara_im_pipes@...> wrote:
                  >
                  > From: Sara Pipe <sara_im_pipes@...>
                  > Subject: Re: [webalizer] webalizer hangs on "History file not found..." message
                  > To: webalizer@yahoogroups.com
                  > Date: Monday, May 17, 2010, 9:17 AM
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >  
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  > Hi Ger,
                  >
                  > Thanks for your reply.
                  >
                  > Do you know which version of gd do I have to install? I have  webalizer-2. 21-02 and libpng-1.2.18.
                  >
                  > Thank you,
                  > Sara
                  >
                  > --- On Mon, 5/17/10, Ger Hobbelt <ger@hobbelt. com> wrote:
                  >
                  > From: Ger Hobbelt <ger@hobbelt. com>
                  > Subject: Re: [webalizer] webalizer hangs on "History file not found..." message
                  > To: webalizer@yahoogrou ps.com
                  > Date: Monday, May 17, 2010, 8:44 AM
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >  
                  >
                  >
                  >
                  >
                  >
                  >
                  > From the error message, I'd say it looks like webalizer directly or indirectly uses libgd as well (haven';t checked, this is off the cuff) and libgd is complaining. Given that you reported a webalizer source install, the way forward would be to check if libgd is required (most probably, as gd is often used for graphing) and when yes, gd must also be upgraded, alas.
                  >
                  >
                  >
                  > --
                  > Met vriendelijke groeten / Best regards,
                  >
                  > Ger Hobbelt
                  >
                  > ------------ --------- --------- --------- --------- --
                  > web:    http://www.hobbelt com/
                  >        http://www.hebbut net/
                  >
                  > mail:   ger@hobbelt. com
                  > mobile: +31-6-11 120 978
                  > ------------ --------- --------- --------- --------- --
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                • Ger Hobbelt
                  Sara, ... One reminder to add here: check the configure script to see which libs are used by webalizer. You probably need to spec --with-gd= and/or
                  Message 8 of 12 , May 17, 2010
                  • 0 Attachment
                    Sara,

                    On Mon, May 17, 2010 at 3:37 PM, Bradford L. Barrett <brad@...> wrote:
                      Recompile the Webalizer against the new version of gd..


                    +1 for above.


                    One reminder to add here: check the configure script to see which libs are used by webalizer. You probably need to spec --with-gd=<path> and/or --with-png=<path> ./configure args for webalizer so that the configure script 'sees' the correct gd and png libs.

                    ./configure --help
                    dumps a list of all options, including those --with-xyz=<path> ones.

                    When you spec --with-gd=, you generally don't need to spec --with-gd-lib and --with-gd-include as those are assumed to be <path>/lib and <path>/include, which is correct 99% of the time, particularly when those libs were built from source as well.

                    The next bit of trouble then would be making sure the appropriate versions of the shared libs are where they're expected to be.
                    See

                    man ldd

                    for ldd help about showing you which shared libs ( & their versions) are qreuired by your webalizer binary), plus

                    man ldconfig

                    for some info about making sure the OS 'knows' about those shared libs you just built and 'make install'ed.


                    May seem like a lot the first time around, but since you've got trouble, you can either go the static lib route (webalaizer: ./configure --enable-static ) together with --with-gd/png/... or stick to shared libs, but juggling a bit to get the 'right' versions there. I'd opt to try the latter before falling back to the former.



                    --
                    Met vriendelijke groeten / Best regards,

                    Ger Hobbelt

                    --------------------------------------------------
                    web:    http://www.hobbelt.com/
                           http://www.hebbut.net/
                    mail:   ger@...
                    mobile: +31-6-11 120 978
                    --------------------------------------------------

                  • Sara Pipe
                    Thank you for your descriptive message Ger, I tried: ./configure --enable-geoip --enable-bz2 --with-gd=/usr/lib/libdb-4.4.so --with-z=/usr/local/lib/libz.so.1
                    Message 9 of 12 , May 21, 2010
                    • 0 Attachment
                      Thank you for your descriptive message Ger,

                      I tried: ./configure --enable-geoip --enable-bz2 --with-gd=/usr/lib/libdb-4.4.so --with-z=/usr/local/lib/libz.so.1

                      and it is complaining that:
                      .....
                      checking for main in -lm... no
                      checking for main in -lz... no
                      configure: error: z library not found.. please install libz

                      I have zlib installed. I can not understand why. I even reinstalled zlib & it "sudo make install"ed successfully: chmod 644 /usr/local/include/zlib.h /usr/local/include/zconf.h

                      Could it be the original problem that:
                      When I was saying "make" to webalizer, it said:
                      In file included from /usr/local/include/zlib.h:34,
                                       from webalizer.c:44:
                      /usr/local/include/zconf.h:
                          373:6: error: token "=" is not valid in preprocessor expressions
                          make: *** [webalizer.o] Error 1

                      & so I looked into zconf.h and on that line it said:
                      "
                      /* a little trick to accommodate both "#define _LARGEFILE64_SOURCE" and
                       * "#define _LARGEFILE64_SOURCE 1" as requesting 64-bit operations, (even
                       * though the former does not conform to the LFS document), but considering
                       * both "#undef _LARGEFILE64_SOURCE" and "#define _LARGEFILE64_SOURCE 0" as
                       * equivalently requesting no 64-bit operations
                       */
                      #if -_LARGEFILE64_SOURCE - -1 == 1
                      #  undef _LARGEFILE64_SOURCE
                      #endif
                      "

                      I did not know what to do, so I commented the whole #if & #endif part out. Then the make ran fine, then I got to the gd version problem.

                      Do you understand what is going on?
                      Thanks,
                      Sara


                      --- On Mon, 5/17/10, Ger Hobbelt <ger@...> wrote:

                      From: Ger Hobbelt <ger@...>
                      Subject: Re: [webalizer] webalizer hangs on "History file not found..." message
                      To: webalizer@yahoogroups.com
                      Date: Monday, May 17, 2010, 7:56 PM

                       

                      Sara,

                      On Mon, May 17, 2010 at 3:37 PM, Bradford L. Barrett <brad@mrunix. net> wrote:
                        Recompile the Webalizer against the new version of gd..


                      +1 for above.


                      One reminder to add here: check the configure script to see which libs are used by webalizer. You probably need to spec --with-gd=<path> and/or --with-png=<path> ./configure args for webalizer so that the configure script 'sees' the correct gd and png libs.

                      ./configure --help
                      dumps a list of all options, including those --with-xyz=<path> ones.

                      When you spec --with-gd=, you generally don't need to spec --with-gd-lib and --with-gd-include as those are assumed to be <path>/lib and <path>/include, which is correct 99% of the time, particularly when those libs were built from source as well.

                      The next bit of trouble then would be making sure the appropriate versions of the shared libs are where they're expected to be.
                      See

                      man ldd

                      for ldd help about showing you which shared libs ( & their versions) are qreuired by your webalizer binary), plus

                      man ldconfig

                      for some info about making sure the OS 'knows' about those shared libs you just built and 'make install'ed.


                      May seem like a lot the first time around, but since you've got trouble, you can either go the static lib route (webalaizer: ./configure --enable-static ) together with --with-gd/png/ ... or stick to shared libs, but juggling a bit to get the 'right' versions there. I'd opt to try the latter before falling back to the former.



                      --
                      Met vriendelijke groeten / Best regards,

                      Ger Hobbelt

                      ------------ --------- --------- --------- --------- --
                      web:    http://www.hobbelt. com/
                             http://www.hebbut. net/
                      mail:   ger@hobbelt. com
                      mobile: +31-6-11 120 978
                      ------------ --------- --------- --------- --------- --


                    Your message has been successfully submitted and would be delivered to recipients shortly.