Loading ...
Sorry, an error occurred while loading the content.

Webalizer geolocation on Mac

Expand Messages
  • Željko Filipin
    Hi, I have installed Webalizer on Ubuntu with Synaptic Package Manager and it works just fine. Then I installed Webalizer on Mac (10.6.2) with
    Message 1 of 1 , Feb 19, 2010
    • 0 Attachment

      I have installed Webalizer on Ubuntu with Synaptic Package Manager and it works just fine.

      Then I installed Webalizer on Mac (10.6.2) with http://webalizer.darwinports.com/. But geolocation does not work.

      I have parsed the exactly same log with Ubuntu and Mac, and Ubuntu finds 156 locations and Mac finds only one: `Unresolved/Unknown`.

      [FAQ][1] in `7b. My Server doesn't do name lookups. Will The Webalizer?` says to read [DNS.README][2] to figure out how to set up geolocation. I have read it and I did not understand anything.

      At [download][4] page I have found the link to [Latest Webalizer GeoDB database][5]. It's readme says I should probably just copy GeoDB.dat to /usr/share/GeoDB, but that did not help. It also says:

      > The default location can be found by using the '-vV' command line switches of the Webalizer if you are unsure.

      But that does not say where default location is.


          $ webalizer -vV
          Webalizer V2.01-10 (Darwin 10.2.0) English
          Copyright 1997-2001 by Bradford L. Barrett


          $ webalizer -vV
          Webalizer V2.01-10 (Linux 2.6.31-16-generic) locale Copyright 1997-2001 by Bradford L. Barrett

      When I run webalizer on Ubuntu it says it is using geoip database (Mac does not even display that line):

          $ webalizer -o report december.log
          Using default GeoIP database

      [README][3] says I should use -J switch to point to geolocation database, but I guess I am doing something wrong, because it tries to use geolocation file as input file:

          $ webalizer -o report -J /Users/zeljko/GeoDB.dat december.log
          Webalizer V2.01-10 (Darwin 10.2.0) English
          Using logfile /Users/zeljko/GeoDB.dat (clf)
          Creating output in report
          Hostname for reports is 'mac'
          Reading history file... webalizer.hist
          Skipping bad record (1)
          No valid records found!

      It behaves the same on Ubuntu if I try to use downloaded geolocation database.

      I have tried to compile webalizer on Mac from source, but it was dependency hell. It required a ton of stuff to install first, and nothing was easy to install.

      Is there a way to enable geolocation on Mac, or an easier way to install it from source?

      watir.com - community manager
      pledgie.com/campaigns/2982 - donate to Watir
      watirpodcast.com - host
      testingpodcast.com - podcasts on software testing. all of them

        [1]: http://www.mrunix.net/webalizer/faq.html
        [2]: ftp://ftp.mrunix.net/pub/webalizer/DNS.README
        [3]: ftp://ftp.mrunix.net/pub/webalizer/README
        [4]: http://www.mrunix.net/webalizer/download.html
        [5]: ftp://ftp.mrunix.net/pub/webalizer/webalizer-geodb-latest.tgz
    Your message has been successfully submitted and would be delivered to recipients shortly.