Loading ...
Sorry, an error occurred while loading the content.

Re: no DNS resolve

Expand Messages
  • antonzerty
    Hi, any chance to have some feedback to this problem? I don t think that I did something wrong! Thanks for your valuable support AZ ... support ... script to
    Message 1 of 5 , Sep 24, 2008
    • 0 Attachment
      Hi,

      any chance to have some feedback to this problem? I don't think that I
      did something wrong!

      Thanks for your valuable support

      AZ

      --- In webalizer@yahoogroups.com, "antonzerty" <antonzerty@...> wrote:
      >
      > Some more info!
      >
      > I did install Berkeley DB 4.7.25 and re-run configure with the option:
      >
      > --with-dblib
      >
      > and no DNS related warnings were the case any more.
      >
      > Did 'make clean' to get rid of the previous build, re-run make and get
      > the following error:
      >
      > dns_resolv.c: In function `dns_resolver':
      > dns_resolv.c:199: error: too many arguments to function
      > dns_resolv.c: In function `open_cache':
      > dns_resolv.c:773: error: too many arguments to function
      > dns_resolv.c: In function `geodb_open':
      > dns_resolv.c:831: error: too many arguments to function
      > make: *** [dns_resolv.o] Error 1
      >
      > Thanks for your help
      >
      > --- In webalizer@yahoogroups.com, "antonzerty" <antonzerty@> wrote:
      > >
      > > Thanks for your prompt reply!
      > >
      > > Indeed following in in the configure.log:
      > >
      > > ------------------
      > > configure:5606: WARNING: libdb not found.. DNS/GeoDB code disabled!
      > > ------------------
      > >
      > > does this relate to:
      > >
      > > -------------------
      > > For native DNS and Geolocation (GeoDB) support, the Berkeley DB
      > > library (by sleepycat, now owned by Oracle) v4.1 or higher and
      > > associated header file is required.
      > > http://www.oracle.com/technology/products/berkeley-db/
      > > -------------------
      > >
      > > do I have to install that first?
      > >
      > > Thanks
      > >
      > > AZ
      > >
      > > --- In webalizer@yahoogroups.com, "Bradford L. Barrett" <brad@> wrote:
      > > >
      > > >
      > > > You do not need to specify --enable-dns with version 2.20, DNS
      support
      > > > is enabled by default. Check the output from the configure
      script to
      > > > see if any errors or warning were found which would disable it. To
      > > > determine if DNS support is built into the binary, execute the
      > > following:
      > > >
      > > > webalizer -vV
      > > >
      > > > and if present, you will see "DNS IPv6" listed as one of the
      options.
      > > >
      > > > --
      > > >
      > > > On Mon, 22 Sep 2008, antonzerty wrote:
      > > >
      > > > > Dear group,
      > > > >
      > > > > I compiled (with --enable-dns) and installed current 2.20-01
      source
      > > > > code and when I run it, it doesn't resolve the IPs! In my conf
      > file I
      > > > > did include:
      > > > >
      > > > > dns_cache.db
      > > > > DNSChildren 5
      > > > >
      > > > > Thanks for your kind support
      > > > >
      > > > > Anton
      > > > >
      > > > >
      > > > > ------------------------------------
      > > > >
      > > > > Webalizer homepage: http://www.webalizer.org
      > > > > Yahoo! Groups Links
      > > > >
      > > > >
      > > > >
      > > >
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.