Re: error compiling 2.20 with gcc < 4 ?
- --- In firstname.lastname@example.org, "hansmeiserweb" <hansmeiserweb@...>
> Hi,I don't believe your errors are due to the version of gcc, but the
> i want to upgrade webaklizer to new version. My newer maschines run
> gcc 4.x and i can compile successfully.
> I have a lot of old maschines i cannot upgrade with gcc v4 (too old)
> with gcc 3.4.6 i got following errors.
version of the berkeley DB you are using. You need db v4.1 or higher.
What version are you running on your old machines? Chances are you
just need to upgrade to a newer version of DB or disable the DNS/GeoDB
code at configure time (using --enable-dns=no).
> I don't believe your errors are due to the version of gcc, but theOoops, yes. 4.0 was installed. I packaged higher version a few months
> version of the berkeley DB you are using. You need db v4.1 or higher.
ago but forgot to install it on compile-machine. ;)
No Problem with formerly written dns_cache.db ?
Can we expect more versions in the future? I think the webalizer-
community is very faithful...
> No Problem with formerly written dns_cache.db ?No problems.. the on disk format is the same, and previous incarnations
will work with the new code (which was a goal of the 2.20 release; to
be a 'drop-in' replacement). You can verify by running 'wcmgr' against
your old cache files.
> Can we expect more versions in the future?Yes..
Bradford L. Barrett brad at mrunix dot net
A free electron in a sea of neutrons DoD#1750 KD4NAW
The only thing Micro$oft has done for society, is make people
believe that computers are inherently unreliable.