Loading ...
Sorry, an error occurred while loading the content.

IndexAlias

Expand Messages
  • Katie
    I m wondering if I can stop the automatic consolidation of index.*? I have dynamic pages with ColdFusion, so pages are index.cfm? blahblahblah. They are all
    Message 1 of 5 , Jan 12, 2006
    • 0 Attachment
      I'm wondering if I can stop the automatic consolidation of index.*? I
      have dynamic pages with ColdFusion, so pages are index.cfm?
      blahblahblah. They are all coming up as /site/. I really need the
      count of hits on each page.

      Is there a setting I can change? I've already done the ?,&, and = in
      the webalizer.c and that worked great. I'm getting what I need except
      the index.cfm?blahblahblahs.

      Thanks for any insight.
    • Katie
      ... I ... except ... I got it figured out. Went back into the webalizer.c and commented out the /* add_nlist( index. ,&index_alias);*/ line. Seems to be
      Message 2 of 5 , Jan 12, 2006
      • 0 Attachment
        --- In webalizer@yahoogroups.com, "Katie" <klc@w...> wrote:
        >
        > I'm wondering if I can stop the automatic consolidation of index.*?
        I
        > have dynamic pages with ColdFusion, so pages are index.cfm?
        > blahblahblah. They are all coming up as /site/. I really need the
        > count of hits on each page.
        >
        > Is there a setting I can change? I've already done the ?,&, and = in
        > the webalizer.c and that worked great. I'm getting what I need
        except
        > the index.cfm?blahblahblahs.
        >
        > Thanks for any insight.
        >

        I got it figured out. Went back into the webalizer.c and commented out
        the /* add_nlist("index.",&index_alias);*/ line. Seems to be doing the
        trick.

        Thanks!
      • tankman67
        I m running into an issue with Webalizer after upgrading to Gallery3. It seems Gallery3 places index.php in between the domain and the directory structure of
        Message 3 of 5 , Aug 15 4:06 PM
        • 0 Attachment
          I'm running into an issue with Webalizer after upgrading to Gallery3. It seems Gallery3 places index.php in between the domain and the directory structure of the website. For example, www.domain.com/index.php/2011/summervaction/

          As a result, Webalizer is stripping the "index." and everything after. This makes the stats read as if every single request is for /

          I see in the configuration file where I can add additional IndexAlias definitions but there doesn't appear to be away to exclude "index." Does anyone know if this is possible?

          Thanks in advance for any suggestions!

          Dallas
        • Bradford L. Barrett
          Try using: DefaultIndex no in your config file.. Here is the relevant bit from the README file: DefaultIndex This option is used to enable/disable the use of
          Message 4 of 5 , Aug 15 7:07 PM
          • 0 Attachment
            Try using:

            DefaultIndex no


            in your config file..

            Here is the relevant bit from the README file:

            DefaultIndex This option is used to enable/disable the use of "index." as
            a default index name to be stripped from the end of a URL.
            Most sites should not need to use this option, however some
            may find it useful, particularly those whose default index
            file name is something different, or those sites that use
            'index.php' or similar URLs to generate dynamic content.
            This option does not effect any of the names that may be
            defined using the IndexAlias option, and those names will
            still function as described. Values may be 'yes' or 'no',
            with 'yes' being the default.

            --

            On Mon, 15 Aug 2011, tankman67 wrote:

            > I'm running into an issue with Webalizer after upgrading to Gallery3.
            > It seems Gallery3 places index.php in between the domain and the
            > directory structure of the website. For example,
            > www.domain.com/index.php/2011/summervaction/
            >
            > As a result, Webalizer is stripping the "index." and everything after.
            > This makes the stats read as if every single request is for /
            >
            > I see in the configuration file where I can add additional IndexAlias
            > definitions but there doesn't appear to be away to exclude "index."
            > Does anyone know if this is possible?
            >

            --
            Bradford L. Barrett brad@...
            A free electron in a sea of neutrons DoD#1750 KD4NAW

            The only thing Micro$oft has done for society, is make people
            believe that computers are inherently unreliable.
          • tankman67
            Thanks for the reply Bradford. I ll provide a little more detail. I installed Webalizer with apt-get on my Debian system. This installed version 2.01. I
            Message 5 of 5 , Aug 16 6:27 AM
            • 0 Attachment
              Thanks for the reply Bradford. I'll provide a little more detail. I installed Webalizer with apt-get on my Debian system. This installed version 2.01. I checked the README located in /usr/share/doc/webalizer and did some Googling - which I try to do to prevent asking stupid questions - but didn't see this option.

              I took your advice however, but received the following output:
              Warning: Invalid keyword 'DefaultIndex' (/etc/webalizer/webalizer.conf)

              I see the README file at ftp://ftp.mrunix.net/pub/webalizer/README (which appears to be for version 2.23-05) DOES contain this option.

              I will try upgrading my Webalizer version and test. Thanks again for pointing me in the right direction here.

              Dallas

              --- In webalizer@yahoogroups.com, "Bradford L. Barrett" <brad@...> wrote:
              >
              >
              > Try using:
              >
              > DefaultIndex no
              >
              >
              > in your config file..
              >
              > Here is the relevant bit from the README file:
              >
              > DefaultIndex This option is used to enable/disable the use of "index." as
              > a default index name to be stripped from the end of a URL.
              > Most sites should not need to use this option, however some
              > may find it useful, particularly those whose default index
              > file name is something different, or those sites that use
              > 'index.php' or similar URLs to generate dynamic content.
              > This option does not effect any of the names that may be
              > defined using the IndexAlias option, and those names will
              > still function as described. Values may be 'yes' or 'no',
              > with 'yes' being the default.
              >
              > --
              >
              > On Mon, 15 Aug 2011, tankman67 wrote:
              >
              > > I'm running into an issue with Webalizer after upgrading to Gallery3.
              > > It seems Gallery3 places index.php in between the domain and the
              > > directory structure of the website. For example,
              > > www.domain.com/index.php/2011/summervaction/
              > >
              > > As a result, Webalizer is stripping the "index." and everything after.
              > > This makes the stats read as if every single request is for /
              > >
              > > I see in the configuration file where I can add additional IndexAlias
              > > definitions but there doesn't appear to be away to exclude "index."
              > > Does anyone know if this is possible?
              > >
              >
              > --
              > Bradford L. Barrett brad@...
              > A free electron in a sea of neutrons DoD#1750 KD4NAW
              >
              > The only thing Micro$oft has done for society, is make people
              > believe that computers are inherently unreliable.
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.