Loading ...
Sorry, an error occurred while loading the content.

Webalizer 2.01-10 w/ geo seg-faults

Expand Messages
  • msturtz
    Hello, Using Webalizer 2.01-10 with Geolizer... I m trying to run it on a month s worth of data at once. The data is all compressed (gzip -9) and is quite
    Message 1 of 3 , Jan 10, 2005
    • 0 Attachment
      Hello,

      Using Webalizer 2.01-10 with Geolizer... I'm trying to run it on a
      month's worth of data at once. The data is all compressed (gzip -9)
      and is quite large (219M _after_ compression).

      I do something like:

      zcat <glob of daily logfiles> |webalizer -c <config file>

      It runs for a while, printing out lots of "Truncating oversized
      referrer field", then gets to "Saving current run data [date]" and
      finally "Generating report for [month year]". Then it seg-faults.
      It appears to have written out most of the HTML and CSV files I asked
      for. Based on the timestamp, it's also updating webalizer.current.
      It is NOT updating webalizer.hist or index.html.

      Any ideas? Or any other info I could provide?

      -Matt-
    • msturtz
      For what it s worth, I discovered later in the day that if I use the staticly linked pre-built binary for my platform I don t have any issues -- it happily
      Message 2 of 3 , Jan 11, 2005
      • 0 Attachment
        For what it's worth, I discovered later in the day that if I use the
        staticly linked pre-built binary for my platform I don't have any
        issues -- it happily chugged through the whole day, generated the
        reports, and returned successful exit status.

        Anybody else have this problem? Platform is RedHat AS 3...

        -Matt-


        --- In webalizer@yahoogroups.com, "msturtz" <yahoo@m...> wrote:
        >
        > Hello,
        >
        > Using Webalizer 2.01-10 with Geolizer... I'm trying to run it on a
        > month's worth of data at once. The data is all compressed (gzip -
        9)
        > and is quite large (219M _after_ compression).
        >
        > I do something like:
        >
        > zcat <glob of daily logfiles> |webalizer -c <config file>
        >
        > It runs for a while, printing out lots of "Truncating oversized
        > referrer field", then gets to "Saving current run data [date]" and
        > finally "Generating report for [month year]". Then it seg-faults.
        > It appears to have written out most of the HTML and CSV files I
        asked
        > for. Based on the timestamp, it's also updating
        webalizer.current.
        > It is NOT updating webalizer.hist or index.html.
        >
        > Any ideas? Or any other info I could provide?
        >
        > -Matt-
      • Enric Naval
        Just one hint. Is it generating the .png files? If it isn t, then the problem could be a wrong version of the gd library or the libpng libraries. ... =====
        Message 3 of 3 , Jan 12, 2005
        • 0 Attachment
          Just one hint. Is it generating the .png files?

          If it isn't, then the problem could be a wrong version
          of the "gd" library or the "libpng" libraries.


          --- msturtz <yahoo@...> wrote:

          >
          > For what it's worth, I discovered later in the day
          > that if I use the
          > staticly linked pre-built binary for my platform I
          > don't have any
          > issues -- it happily chugged through the whole day,
          > generated the
          > reports, and returned successful exit status.
          >
          > Anybody else have this problem? Platform is RedHat
          > AS 3...
          >
          > -Matt-
          >
          >
          > --- In webalizer@yahoogroups.com, "msturtz"
          > <yahoo@m...> wrote:
          > >
          > > Hello,
          > >
          > > Using Webalizer 2.01-10 with Geolizer... I'm
          > trying to run it on a
          > > month's worth of data at once. The data is all
          > compressed (gzip -
          > 9)
          > > and is quite large (219M _after_ compression).
          > >
          > > I do something like:
          > >
          > > zcat <glob of daily logfiles> |webalizer -c
          > <config file>
          > >
          > > It runs for a while, printing out lots of
          > "Truncating oversized
          > > referrer field", then gets to "Saving current run
          > data [date]" and
          > > finally "Generating report for [month year]".
          > Then it seg-faults.
          > > It appears to have written out most of the HTML
          > and CSV files I
          > asked
          > > for. Based on the timestamp, it's also updating
          > webalizer.current.
          > > It is NOT updating webalizer.hist or index.html.
          > >
          > > Any ideas? Or any other info I could provide?
          > >
          > > -Matt-
          >
          >
          >
          >


          =====
          Enric Naval
          Estudiante de Inform�tica de Gesti�n en la Udl (Lleida)
          GRIHO webalizer.conf
          http://griho.udl.es/webalizer/webalizer.conf.txt

          __________________________________________________
          Do You Yahoo!?
          Tired of spam? Yahoo! Mail has the best spam protection around
          http://mail.yahoo.com
        Your message has been successfully submitted and would be delivered to recipients shortly.