Loading ...
Sorry, an error occurred while loading the content.
 

Re: [webalizer] Wrong year showing into reports

Expand Messages
  • Fabien Chevalier
    ... Claude, There is 99.999% chances that webalizer has no problem at all and that you did something wrong somewhere ! You should provide more information,
    Message 1 of 3 , Jun 21, 2004
      Claude Berube wrote:
      Wrong year showing into reports

      I ran webaliser on my site and it is giving me "March 2003" data instead of the current years data.  All the current year months are OK except for this one.

      I am pretty shure the data is really the one of march 2003.  Now what happened with march 2004 data.

      I wonder what could have caused this to happen. 

      Does anybody have any clues about this problem.


      CLAUDE

      Claude,
      There is 99.999% chances that webalizer has no problem at all and that you did something wrong
      somewhere !
      You should provide more information, otherwise nobody will be able to help you.

      Cheer,

      Fabien
    • Enric Naval
      ... Most probably, his incremental data is corrupted. He should delete the webalizer.hist and webalizer.current files and re-run all logs in cronological
      Message 2 of 3 , Jun 22, 2004
        --- Fabien Chevalier <fabien@...>
        wrote:
        > Claude Berube wrote:
        >
        > >
        > > I ran webaliser on my site and it is giving me
        > "March 2003" data
        > > instead of the current years data. All the
        > current year months are OK
        > > except for this one.
        > >
        > > I am pretty shure the data is really the one of
        > march 2003. Now what
        > > happened with march 2004 data.
        > >
        > > I wonder what could have caused this to happen.
        > >
        > > Does anybody have any clues about this problem.
        > >
        > >
        > > CLAUDE
        > >
        > Claude,
        > There is 99.999% chances that webalizer has no
        > problem at all and that
        > you did something wrong
        > somewhere !
        > You should provide more information, otherwise
        > nobody will be able to
        > help you.
        >
        > Cheer,
        >
        > Fabien
        >


        Most probably, his incremental data is corrupted. He
        should delete the webalizer.hist and webalizer.current
        files and re-run all logs in cronological order, first
        older (and, of course, make a backup before doing so,
        because his past stats will be lost when deleting the
        incremental data files). If the error appears again
        then that means that the error was not in the
        incremental data but in the log files themselves. He
        should then delete the incremental data again and feed
        the log files one by one, checking each time when the
        error appears. When the error appears, check by hand
        the log file, and check for problems. For instance, an
        entry saying May/2003/ instead of May/2004/, or the
        log files for May 2003 and May 2004 getting swapped.

        Actually, mosts weird problems in webalizer are caused
        by incremental data going hairwire. Re-creating the
        stats from raw log files is also faster than
        hand-checking the log files, so the deletion of
        incremental data is the first thing I recommend people
        to do :) That's why you need a backup of your log
        files: if the incremental data gets corrupted, then
        you can re-create it by getting webalizer to analyze
        again the log files. You may also wish to preserve
        them for historical purposes, so you can show people
        how your website took off.

        Please, Claude, tell us if deleting the incremental
        data worked for you.

        =====
        Enric Naval
        Estudiante de Inform�tica de Gesti�n en la Udl (Lleida)
        GRIHO webalizer.conf
        http://griho.udl.es/webalizer/webalizer.conf.txt



        __________________________________
        Do you Yahoo!?
        Yahoo! Mail Address AutoComplete - You start. We finish.
        http://promotions.yahoo.com/new_mail
      Your message has been successfully submitted and would be delivered to recipients shortly.