Loading ...
Sorry, an error occurred while loading the content.

Re: [webalizer] usage by country

Expand Messages
  • simon benedict
    thanks a lot for ur reply but i want to tell you that i am using the IIS generated log to generate the web statistics. What i mean exactly is this my website
    Message 1 of 9 , May 3, 2004
    • 0 Attachment
      thanks a lot for ur reply but i want to tell you that i am using the  IIS generated log to generate the web statistics.
       
      What i mean exactly is this
       
      my website is running on win2k machine running IIS and i generate logs in ncsa.log format and I ftp them to my red hat linux box where i have webalizer running to get my web usage .
       
      so the logs are produced by IIS and not by apache .
       
      is there any change i need to do in IIS or change the log file format ??
       
      appreciate if you let me know
       
      thanks n regards
       
       
      simon
       
       
       
       
       
       
       
       
       
       
      tanislaw Pusep <stanis@...> wrote:
      Hello Simon!
      By default, Webalizer's country identification comes from reverse DNS records that Web server wrotes to logs. Every time client connects Apache tries to obtain it's hostname by IP address and writes hostname to logs. Webalizer simply extracts hostname suffix and resolves country name using special table.
      The problem is: not all clients has hostname associated. Many ISP doesn't care about this. So Webalizer "gets lost".
      To overcome this problem you can use software that has database to associate IP ranges directly to country. I've written a patch that integrates GeoIP library support into Webalizer: http://sysd.org/proj/log.php#glzr
      On this address there's a patch to Webalizer source and static binary for Linux. Good luck!


      ----- Original Message -----
      From: simon benedict <sbdcunha@...>
      Date: Wed, 21 Apr 2004 09:26:40 -0700 (PDT)
      To: webalizer@yahoogroups.com
      Subject: [webalizer] usage by country

      > Hi All

      > I am running webalizer on Linux Box and using the log files from IIS to generate the statistics.

      > but the usage by country shows me 87%  unresolved/unknown


      > http://weblog.baladia.gov.kw/usage_200404.html


      > i really dont know if it should be this way and how do i get rid of this so that my pie chart graph shows all countries

      > do i have to change any settings in my IIS or the webalizer.conf file


      > thnks and appreacite


      > regards

      > simon
      >
      >
      >
      >
      > ---------------------------------
      >
      >
      >
      >
      >
      > > ATTACHMENT part 2 application/x-pkcs7-signature name=smime.p7s
      >
      >
      >            
      > ---------------------------------
      > Do you Yahoo!?
      Yahoo! Photos: High-quality 4x6 digital prints for 25�
      --
      ______________________________________________
      Check out the latest SMS services @ http://www.linuxmail.org
      This allows you to send and receive SMS through your mailbox.


      Powered by Outblaze


      Webalizer homepage: http://www.webalizer.org
      Webalizer for NT: http://www.medasys-lille.com/webalizer/


      ttp://www.webalizer.org
      Webalizer for NT: http://www.medasys-lille.com/webalizer/






      Yahoo! Groups Links


      Do you Yahoo!?
      Win a $20,000 Career Makeover at Yahoo! HotJobs

    • simon benedict
      hi, I have downloaded the patch for linux and unzipped it the below directory /usr/src/geolizer_2.01-10-static-linux I already had Webalizer V2.01-10 (Linux
      Message 2 of 9 , May 5, 2004
      • 0 Attachment
        hi,
         
        I have downloaded the patch for linux and unzipped it the below directory
         
        /usr/src/geolizer_2.01-10-static-linux
         
        I already had Webalizer V2.01-10 (Linux 2.4.18-14) English installed before .
         
        there is a sample.conf file avaliable and has the keywords
         
        GeoIP          yes
         GeoIPDatabase  /usr/local/share/GeoIP/GeoIP.dat
         
        the path to the GeoIP.dat file
         
        but it gives me the following error when i run webalizer saying
         
        Warning: Invalid keyword 'GeoIP' (webalizer.conf)
        Warning: Invalid keyword 'GeoIPDatabase' (webalizer.conf)
         
        also i cannot run  the patch as speciafied in the INSTALL file
         
        appreciate if you can let me know the steps i can patch webalizer and have use the GeoIP database or
         
        if I can use the keyword GeoIP in the webalizer.conf file directly and how
         
         
        thanks and appreciate
         
         
        simon
         
         


         


        Do you Yahoo!?
        Win a $20,000 Career Makeover at Yahoo! HotJobs
      • simon benedict
        hi, I have recently used webalizer to process my squid log files and there are 2 queries i want to clearify i am using the patched webalizer and when I run it
        Message 3 of 9 , May 16, 2004
        • 0 Attachment

          hi,
           
          I have recently used webalizer to process my squid log files and there are 2 queries i want to clearify
           
          i am using the patched webalizer and when I run it i get the below errors . the squid access.log file size was about 9 mb
           
          1) Warning: Truncating oversized request field
          Skipping bad record (50155)
          Warning: Truncating oversized request field [50236]
          Warning: Truncating oversized request field [50915]
          Warning: Truncating oversized request field [51177]

          2) the countries option show unresolved/unknown 100 %

           

          do i need to make any changes in my squid.conf file

           

          appreciate your help

           

          thanks and regards

           

          simon

           


          Do you Yahoo!?
          SBC Yahoo! - Internet access at a great low price.

        • enventa2000
          ... Hello. ... there are 2 queries i want to clearify ... errors . the squid access.log file size was about 9 mb ... These are only warnings. You may want to
          Message 4 of 9 , May 17, 2004
          • 0 Attachment
            > hi,

            Hello.

            >
            > I have recently used webalizer to process my squid log files and
            there are 2 queries i want to clearify
            >
            > i am using the patched webalizer and when I run it i get the below
            errors . the squid access.log file size was about 9 mb
            >
            > 1) Warning: Truncating oversized request field
            > Skipping bad record (50155)
            > Warning: Truncating oversized request field [50236]
            > Warning: Truncating oversized request field [50915]
            > Warning: Truncating oversized request field [51177]
            >

            These are only warnings. You may want to attempt to solve the "bad
            record" warning, because of its potencial for problems in the future.
            The number in parenthesis is the line number in the log file.

            Launch your favourite text editor and open the squid logfile. Go to
            line number 50155 and inspect the line and the lines around it. You
            will probably find a log entry cut in half, or some other strange
            thing. Delete the faulty line or correct it if you prefer so.

            The "oversized request field" are very long URLs. You can edit the
            code and increase the size of the internal fields storing the URLs,
            but notice that this will cause webalizer to increase menory usage.
            You may run out of RAM if your machine has very little memory.

            In webalizer.h you'll find a line like this:

            #define MAXURLH 128 /* Max URL field size in htab
            */

            You need to change 128 to a higher value. If you have a 32 bit
            machine, it is more efficient to increase this value in increases of
            32. Try 128+32=160 or 128+32*2=192

            #define MAXURLH 160

            You'll probably still have warnings unless you put a very high value.
            Normally those are attempts to overflow some buffer in your server, or
            some sites which have exagerately long request strings for some
            reason.

            > 2) the countries option show unresolved/unknown 100 %
            >
            >
            >
            > do i need to make any changes in my squid.conf file

            Hum, have you activated the DNS resolution in webalizer.conf? This
            line should be uncommented. No need to uncomment the DNSCache line.

            DNSChildren 10

            Also notice that you need to compile using this option in the
            "configure" script:

            make clean
            ./configure --enable-dns
            make
            make install


            Is your server capable of resolving addresses? (try executing
            "nslookup some_ip" in the command line)
          Your message has been successfully submitted and would be delivered to recipients shortly.