Loading ...
Sorry, an error occurred while loading the content.

Expand Messages
  • guy@guymerritt.org
    I had found a webpage that said you could write the following shell script, with multiple config. files in a folder at /etc/webalizer, and webalizer would run
    Message 1 of 2 , Feb 10, 2004
    • 0 Attachment
      I had found a webpage that said you could write the following shell
      script, with multiple config. files in a folder at /etc/webalizer, and
      webalizer would run at the appointed time when this was added to the
      crontab. Here's the weird thing: it worked fine for about 2 months.
      Suddenly it won't work AND the script is apparently ok because when I
      double-click on the file it runs (from a graphical desktop deal).

      #!/bin/sh

      for i in /etc/webalizer/*.conf; do webalizer -c $i; done



      The above is located at /root/web.script . Below is the output in
      squrrelmail for the cron job:

      /root/web.script: webalizer: command not found



      I'm a newbie to Linux, webalizer, etc. Anyone tell me what might be
      happening?



      Thanks

      Guy Merritt
    • Fabien Chevalier
      ... Hello, Try to replace webalizer in your shell script with the complete path to webalizer. The error you have is that when the script is run the webalizer
      Message 2 of 2 , Feb 10, 2004
      • 0 Attachment
        guy@... wrote:

        > I had found a webpage that said you could write the following shell
        >script, with multiple config. files in a folder at /etc/webalizer, and
        >webalizer would run at the appointed time when this was added to the
        >crontab. Here's the weird thing: it worked fine for about 2 months.
        >Suddenly it won't work AND the script is apparently ok because when I
        >double-click on the file it runs (from a graphical desktop deal).
        >
        >#!/bin/sh
        >
        >for i in /etc/webalizer/*.conf; do webalizer -c $i; done
        >
        >
        >
        >The above is located at /root/web.script . Below is the output in
        >squrrelmail for the cron job:
        >
        >/root/web.script: webalizer: command not found
        >
        >
        >
        >I'm a newbie to Linux, webalizer, etc. Anyone tell me what might be
        >happening?
        >
        >
        >
        >Thanks
        >
        >Guy Merritt
        >
        >
        >
        >
        Hello,

        Try to replace 'webalizer' in your shell script with the complete path
        to webalizer.
        The error you have is that when the script is run the webalizer is not
        found on your PATH.
        By the way, you should try to run your script from the console, and not
        to double click
        on it in your favourite GUI -- and tell us if you get the same error
        message or not.

        bye,

        Fabien
      Your message has been successfully submitted and would be delivered to recipients shortly.