Loading ...
Sorry, an error occurred while loading the content.

Stuck on installing gd2.0.21

Expand Messages
  • John B. Moore
    I ve been beating on this for several hours.. (platform RedHat 9) Downloaded gd2.0.0.21 and ran ./configure It indicated that it could not support for any of
    Message 1 of 6 , Jan 16, 2004
    • 0 Attachment
      I've been beating on this for several hours..

      (platform RedHat 9)

      Downloaded gd2.0.0.21 and ran ./configure

      It indicated that it could not support for any of the graphic formats
      because it could not find the sources.. OK.. I first did a search for
      the png.h file.. nowhere.. OK

      I went and downloaded and installed.

      libpng-devel-1.2.2-16.i386.rpm

      That put a lot of stuff but not the desired png.h.. it still could not
      find it. Did a search of the entire system. Still not there..

      Then spent the last hour searching for help on this, but so far, no joy

      Any "kick in the pants" in the right direction would be appreciated..

      John...
    • moron@industrial.org
      ... Did you remember to run ldcongif afterwards? You may also want to pass the paths when you run configure. Try configure --help to see your list of
      Message 2 of 6 , Jan 16, 2004
      • 0 Attachment
        > I've been beating on this for several hours..
        > (platform RedHat 9)
        > Downloaded gd2.0.0.21 and ran ./configure
        > It indicated that it could not support for any of the graphic formats
        > because it could not find the sources.. OK.. I first did a search for
        > the png.h file.. nowhere.. OK
        > libpng-devel-1.2.2-16.i386.rpm

        Did you remember to run ldcongif afterwards? You may also want to pass
        the paths when you run configure. Try "configure --help" to see your list
        of options. Usually it's something like:

        --png-lib=/usr/local/lib

        > That put a lot of stuff but not the desired png.h.. it still could not
        > find it. Did a search of the entire system. Still not there..

        It's not just PNG but GD I thought (haven't got the source in front of me
        though).

        Redhat does many things bass ackwards (grrr) so it's probably just that
        you either need to run ldconfig (possibly with a path argument) or pass
        the path on the command line to configure.

        Cheers

        --
        |) __,,_____________ moron : <moron@...> (|
        |) < ___________/ EEEI news : <infosuck@...> (|
        |) / /-' musician community : http://ampfea.org (|
        |) /___/ industrial & DIY culture : http://industrial.org (|
        |) deterrent industries : http://deterrent.net (|
      • John B. Moore
        ... Sorry for my ignorance.. what is ldcongif ? Can t even find the beast on my system? (more investigating....) heh,heh...typo on your part.. ldconfig..
        Message 3 of 6 , Jan 16, 2004
        • 0 Attachment
          --- In webalizer@yahoogroups.com, moron@i... wrote:

          >
          > Did you remember to run ldcongif afterwards?

          Sorry for my ignorance.. what is ldcongif ? Can't even find the
          beast on my system?

          (more investigating....)

          heh,heh...typo on your part.. ldconfig.. trying to trick me huh <G>

          Ok did

          ldconfig -v | grep png

          ..and it returned..

          libimlib-png.so -> libimlib-png.so
          libpng12.so.0 -> libpng12.so.0.1.2.2




          You may also want to pass
          > the paths when you run configure. Try "configure --help" to see
          your list
          > of options. Usually it's something like:
          >
          > --png-lib=/usr/local/lib

          Ends up the libpng.so files are in /usr/lib but adding that to the
          configure did no good..

          Also downloaded libpng10-1.2.13-8.src.rpm ...no help

          libpng-1.1.5.tar.gz ..extracted and put in
          /usr/include under libpng

          That got me a bit further..

          Now I have the error

          checking for png_create_read_struct in -lpng ...no


          ...bit more progress,but..<sigh>

          ...did a search on that "png_create_read_struct" got some hits but
          made little sense, but it did suggest looking at the config.log file
          and I found that it was not finding the libpng-config..

          ..then it checked the png.h for "usability" and choked on
          "pngconf.h" which is in /usr/include/libpng..

          ..I suspect that I did not install the source correctly?? based on
          other messages I put the contents of libpng-1.2.5 into
          /usr/include/libpng I then noticed that all of the other source
          packages had their *.h files in the root "include" so I copied the
          png.h and pngconf.h to the root.. ??????

          ..so...lines from the config.log

          ==========
          configure:10109: checking for png_create_read_struct in -lpng
          configure:10140: gcc -o conftest -g -O2 conftest.c -lpng -lz -lm >&5
          /usr/bin/ld: cannot find -lpng
          ==========

          I found the following in a message I found on a similar problem..

          "So it's not adding the -L argument for some reason. Try setting
          LDFLAGS=-L/usr/local/lib in configure's environment. "

          ..unfortunately I don't have a clue as yet as to what the "configure's
          environment" entails..

          Maybe if someone can enlighten me on any of this I can "proceed"...
          (groping in the dark)

          Thanks..

          John..
        • moron@industrial.org
          ... Ok. First of all, make sure you clean up after configure before you rerun or else it may not actually change anything (look for config.cache and blow it
          Message 4 of 6 , Jan 16, 2004
          • 0 Attachment
            > I found the following in a message I found on a similar problem..
            > "So it's not adding the -L argument for some reason. Try setting
            >
            > ..unfortunately I don't have a clue as yet as to what the "configure's
            > environment" entails..

            Ok. First of all, make sure you clean up after configure before you rerun
            or else it may not actually change anything (look for config.cache and
            blow it away). As far as changing configure's environment there are two
            ways to do that depending on whether they mean the way it runs or whether
            they just want you to pass it an argument.

            They probably mean this:

            VARNAME=foofy ./configure [possibly with extra arguments here]

            where VARNAME is the environment variable you want set.

            First, delete the config.cache and then rerun just as ./configure in case
            ldconfig solved it. If that doesn't solve it then delete config.cache and
            then try it with the environment variable passed before configure. If
            that doesn't work you can then also try passing the library paths. Often
            I have found that it is actually looking for a subpart of the path, i.e.
            /usr or /usr/lib instead of the full thing so give that a try too.

            All this said, is there not an RPM for Redhat to install Webalizer? I
            would find it quit surprising if this was not a stock thing.

            What version of the source are you trying to install by the way?

            Cheers

            --
            |) __,,_____________ moron : <moron@...> (|
            |) < ___________/ EEEI news : <infosuck@...> (|
            |) / /-' musician community : http://ampfea.org (|
            |) /___/ industrial & DIY culture : http://industrial.org (|
            |) deterrent industries : http://deterrent.net (|
          • John B. Moore
            ... rerun ... I have consistantly deleted the gd-2.0.21 directory and re untared the gz file. Therefore I m certain it is fresh for each test. ... case ...
            Message 5 of 6 , Jan 17, 2004
            • 0 Attachment
              --- In webalizer@yahoogroups.com, moron@i... wrote:

              > Ok. First of all, make sure you clean up after configure before you
              rerun
              > or else it may not actually change anything (look for config.cache and
              > blow it away).


              I have consistantly deleted the gd-2.0.21 directory and re untared
              the gz file. Therefore I'm certain it is "fresh" for each test.



              > First, delete the config.cache and then rerun just as ./configure in
              case
              > ldconfig solved it.

              no joy....


              > then try it with the environment variable passed before configure.

              no joy...

              ..tried..

              LDFLAGS=-L/usr/lib ./configure --enable-dns
              --with-dblib=/usr/include/db4 --with-pnglib=/usr/lib

              produced the exact same output error as before.. Note that the
              thread that I got the LDFLAGS idea from had it pointing to the
              /usr/local/lib but on RH9 this directory is empty so I made the
              assumption that I should point it to the /usr/lib directory which has
              all the libs that I am aware of...??


              If
              > that doesn't work you can then also try passing the library paths.
              Often
              > I have found that it is actually looking for a subpart of the path, i.e.
              > /usr or /usr/lib instead of the full thing so give that a try too.
              >

              Well my current "test" configure command line is..


              LDFLAGS=-L/usr/lib ./configure --enable-dns
              --with-dblib=/usr/include/db4 --with-pnglib=/usr/lib --prefix=/usr

              .. after reading all the install docs "again"

              ..I tried..

              LDFLAGS=-L/usr/lib ./configure --enable-dns
              --with-dblib=/usr/include/db4 --with-png=/usr

              ..and

              LDFLAGS=-L/usr/lib ./configure --enable-dns
              --with-dblib=/usr/include/db4 --with-pnglib=/usr

              ..and both of those with the --prefix=/usr

              ..and then both without the LDFLAGS

              ..and then 'everything" all in one..

              unfortunately.. non of the above seems to change the outcome or the
              output of the config.log



              > All this said, is there not an RPM for Redhat to install Webalizer?

              Even if there was I would have to get the gd installed and that is
              where I'm stuck.. I have to gotten to installing Webalizer yet!!! I
              did find a rpm for an earlier version of gd.. (gd-1.8.4-11.i386.rpm)
              tested that and webalizer configure could not "see" that either.. I
              would prefer to use the latest gd if at all possible


              >
              > What version of the source are you trying to install by the way?
              >

              gd-2.0.21 (as indicated on the header of this thread..<G>)

              I really do appreciate your efforts.. If you have any other ideas or
              see something I missed.. please "don't be shy"..<G>

              BTW.. I posted the config.log at

              http://www.esonicspider.com/config_log_2.txt

              ...by chance something in there rings a bell for someone..

              John..
            • John B. Moore
              FWIW, The solution to my problem turned out to be as follows.. RedHat9 installs the libpng library libpng12.so.0.1.2.2. Therefore all that is required to make
              Message 6 of 6 , Jan 19, 2004
              • 0 Attachment
                FWIW,

                The solution to my problem turned out to be as follows..


                RedHat9 installs the libpng library libpng12.so.0.1.2.2. Therefore all
                that is required to make sure there is a symbolic link from
                "libpng.so" to this file..

                cd /usr/lib
                ln -s libpng12.so.0.1.2.2 libpng.so

                I then used the command line

                ./configure --with-png=/usr --withpnglib=/usr --prefix=/usr

                ..and it now provides png support.

                (Also note that I had to download the source files for libpng and also
                place them in the /usr/include directory. They were not installed by
                default)

                Hope that saves someone a few days...<G>

                John..
              Your message has been successfully submitted and would be delivered to recipients shortly.