Loading ...
Sorry, an error occurred while loading the content.

Expand Messages
  • Joe
    We ve installed webalizer several times and get it working correctly. We need to have the top 100 URLs listed instead of the default 30. We modify
    Message 1 of 3 , Jan 12, 2004
    • 0 Attachment
      We've installed webalizer several times and get it working correctly.
      We need to have the top 100 URLs listed instead of the default 30. We
      modify /etc/cron.daily/webalizer.pl file to include the switch '-U
      100' to produce output with the correct number of top URLs. This is
      the only change we make to the webalizer.pl script. This does produce
      output with the correct number of URL's when the cron job runs
      (cron.daily), but the log files are empty.

      The cron daemon reports the following error for EVERY site:

      sh: /home/sites/www.hardynet.net/logs/web.log: Permission denied

      The permissions for the web log files are:

      -rw-rw-r-- 1 root home 0 Jan 9 05:09 web.log

      We have repeated this process several times with the same result every
      time. I have googled the problem, and searched the archives and have
      found folks with the same issue, but the question goes unresolved.

      Does anyone have some insight into how to correct this? Any help
      would be most appreciated.

      Joseph Brennskag
      Hardy Telecommuncations
      304-897-9911
      joe@...
    • blane_warrene
      Have you tried setting the config options in the webalizer.conf file - or if for multiple virtual domains - tried setting them in individual conf files: i.e.
      Message 2 of 3 , Jan 12, 2004
      • 0 Attachment
        Have you tried setting the config options in the webalizer.conf file -
        or if for multiple virtual domains - tried setting them in individual
        conf files:

        i.e. domain1.conf, domain2.conf, domain3.conf??

        the master or individual conf files allow you to override the defaults
        (30) with whatever amount you like.

        You could test it by creating a directory in /etc called
        webalizer_test and putting a domain1.conf file for one of the domains,
        setting the parameters and then running this manually on the command line:

        for i in /etc/webalizer_test/*.conf; do webalizer -c $i; done

        You can always copy the /etc/webalizer/conf.sample file over to this
        domain1.conf and edit the settings in it.

        Running this manually will not disturb your current cron settings.

        We set this up as a template and have individual conf for all domains
        that we admin for. It all runs off one box and processes daily in cron.

        Generally you only have to edit four or five settings when adding a
        new domain.

        Blane Warrene
        http://www.practicalapplications.net


        --- In webalizer@yahoogroups.com, "Joe " <joe@h...> wrote:
        > We've installed webalizer several times and get it working correctly.
        > We need to have the top 100 URLs listed instead of the default 30. We
        > modify /etc/cron.daily/webalizer.pl file to include the switch '-U
        > 100' to produce output with the correct number of top URLs. This is
        > the only change we make to the webalizer.pl script. This does produce
        > output with the correct number of URL's when the cron job runs
        > (cron.daily), but the log files are empty.
        >
        > The cron daemon reports the following error for EVERY site:
        >
        > sh: /home/sites/www.hardynet.net/logs/web.log: Permission denied
        >
        > The permissions for the web log files are:
        >
        > -rw-rw-r-- 1 root home 0 Jan 9 05:09 web.log
        >
        > We have repeated this process several times with the same result every
        > time. I have googled the problem, and searched the archives and have
        > found folks with the same issue, but the question goes unresolved.
        >
        > Does anyone have some insight into how to correct this? Any help
        > would be most appreciated.
        >
        > Joseph Brennskag
        > Hardy Telecommuncations
        > 304-897-9911
        > joe@h...
      • Bradford L. Barrett
        ... [...] ... Sure.. fix the permissions on your server. This has nothing to do with the webalizer. The user you are running the cron job under does not have
        Message 3 of 3 , Jan 12, 2004
        • 0 Attachment
          > The cron daemon reports the following error for EVERY site:
          >
          > sh: /home/sites/www.hardynet.net/logs/web.log: Permission denied
          >
          > The permissions for the web log files are:
          >
          > -rw-rw-r-- 1 root home 0 Jan 9 05:09 web.log
          >
          [...]
          > Does anyone have some insight into how to correct this? Any help
          > would be most appreciated.

          Sure.. fix the permissions on your server. This has nothing to do with
          the webalizer. The user you are running the cron job under does not have
          permission to read the log file. The permission on the individual
          log files means nothing if the user does not have permissions to traverse
          the entire diretory tree to the file. Basic unix permissions 101.

          --
          Bradford L. Barrett brad@...
          A free electron in a sea of neutrons DoD#1750 KD4NAW

          The only thing Micro$oft has done for society, is make people
          believe that computers are inherently unreliable.
        Your message has been successfully submitted and would be delivered to recipients shortly.