Loading ...
Sorry, an error occurred while loading the content.
 

GDLib error installing Webalizer 2.01-10

Expand Messages
  • Alex Teugels
    Hi I m installing Webalizer 2.01-10 on a Redhat 8.0 box by compiling from source. I already have the following software installed for use with PHP, and they
    Message 1 of 1 , Oct 21, 2003
      Hi

      I'm installing Webalizer 2.01-10 on a Redhat 8.0 box by compiling from
      source. I already have the following software installed for use with PHP,
      and they seem to work as expected:

      gd-2.0.15
      libpng-1.2.5
      jpeg-6b
      freetype-2.1.5

      I try the following:

      [root]# tar -zxvf webalizer-2.01-10-src.tgz
      [root]# cd webalizer-2.01-10
      [root]# ./configure --with-gd=/usr/local/lib
      (no errors)

      [root]# make
      gcc -I/usr/local/lib -Wall -O2 -DETCDIR=\"/etc\" -DHAVE_GETOPT_H=1 -DHAVE_M
      ATH_H=1 -c webalizer.c
      gcc -I/usr/local/lib -Wall -O2 -DETCDIR=\"/etc\" -DHAVE_GETOPT_H=1 -DHAVE_M
      ATH_H=1 -c hashtab.c
      gcc -I/usr/local/lib -Wall -O2 -DETCDIR=\"/etc\" -DHAVE_GETOPT_H=1 -DHAVE_M
      ATH_H=1 -c linklist.c
      gcc -I/usr/local/lib -Wall -O2 -DETCDIR=\"/etc\" -DHAVE_GETOPT_H=1 -DHAVE_M
      ATH_H=1 -c preserve.c
      gcc -I/usr/local/lib -Wall -O2 -DETCDIR=\"/etc\" -DHAVE_GETOPT_H=1 -DHAVE_M
      ATH_H=1 -c dns_resolv.c
      gcc -I/usr/local/lib -Wall -O2 -DETCDIR=\"/etc\" -DHAVE_GETOPT_H=1 -DHAVE_M
      ATH_H=1 -c parser.c
      gcc -I/usr/local/lib -Wall -O2 -DETCDIR=\"/etc\" -DHAVE_GETOPT_H=1 -DHAVE_M
      ATH_H=1 -c output.c
      gcc -I/usr/local/lib -Wall -O2 -DETCDIR=\"/etc\" -DHAVE_GETOPT_H=1 -DHAVE_M
      ATH_H=1 -I/usr/local/include -c graphs.c
      cc1: warning: changing search order for system directory
      "/usr/local/include"
      cc1: warning: as it has already been specified as a non-system directory
      gcc -L/usr/local/lib -o webalizer webalizer.o hashtab.o linklist.o
      preserve.o parser.o output.o dns_resolv.o graphs.o -lgd -lpng -lz -lm
      rm -f webazolver
      ln -s webalizer webazolver

      [root]# make install
      /usr/bin/install -c webalizer /usr/local/bin/webalizer
      /usr/bin/install -c -m 644 webalizer.1 /usr/local/man/man1/webalizer.1
      /usr/bin/install -c -m 644 sample.conf /etc/webalizer.conf.sample
      rm -f /usr/local/bin/webazolver
      ln -s /usr/local/bin/webalizer /usr/local/bin/webazolver

      [root]# webalizer
      webalizer: error while loading shared libraries: libgd.so.2: cannot open
      shared object file: No such file or directory

      Can anyone help please? Any comments appreciated.

      Alex
    Your message has been successfully submitted and would be delivered to recipients shortly.