Loading ...
Sorry, an error occurred while loading the content.

Webalizer/Incremental/OpenBSD

Expand Messages
  • Frank Rössler
    Hello all, I just migrated several webservers from linux to OpenBSD 3.3. This works perfect with one exception : If incremental mode is on (which is needed on
    Message 1 of 6 , Jun 4, 2003
    • 0 Attachment
      Hello all,

      I just migrated several webservers from linux to OpenBSD 3.3.
      This works perfect with one exception :

      If incremental mode is on (which is needed on certain hosts, since
      logfiles get rotated more than once a month),
      Webalizer inserts blank lines in the file webalizer.current (eg. in the
      agent-list).
      On the next run I get this well-known "unable to restore run
      data(10)"-error.
      Removing the blank lines (grep -v ^$...) allows it to run again - once.
      I get these blank lines again and so forth.

      Now I have two options:
      - to start a script before or after each webalizer run to clean up my
      webalizer.current-files
      - get webalizer patched to omit these blank lines. (which hopefully
      won't lead to side effects)

      since this seems to be specific to OpenBSD I suppose it's got something
      to do with certain differences in the system's libs
      and i'm sure others ran into this same issue.

      That said, I would like to ask the community if there's already
      something existing, before I start to invent the wheel another time ...

      Thanks in advance,
      Frank
    Your message has been successfully submitted and would be delivered to recipients shortly.