Loading ...
Sorry, an error occurred while loading the content.

Re: [webalizer] problem with grouping agents (browsers)

Expand Messages
  • Kees de Keizer
    ... GroupAgent +MSIE+6* Microsoft Internet Explorer 6.x GroupAgent +MSIE+5* Microsoft Internet Explorer 5.x GroupAgent +MSIE+4* Microsoft Internet Explorer 4.x
    Message 1 of 5 , Nov 7, 2002
    • 0 Attachment
      jmezzza wrote on 07-11-2002:

      > Can anyone tell me the proper syntax to group MSIE 6.0, MSIE 5.5 etc
      > for user agents?
      > I tried:
      >
      > GroupAgent MSIE 6.0
      > GroupAgent MSIE6.0
      > GroupAgent "MSIE 6.0"
      > GroupAgent 'MSIE 6.0'
      >
      > Each attempt ignores the space following MSIE and groups anything
      > starting with MSIE (ignoring the version).

      GroupAgent +MSIE+6* Microsoft Internet Explorer 6.x
      GroupAgent +MSIE+5* Microsoft Internet Explorer 5.x
      GroupAgent +MSIE+4* Microsoft Internet Explorer 4.x
      GroupAgent +MSIE+3* Microsoft Internet Explorer 3.x

      Make sure you put them in front of the Netscape/Mozilla entries.
      If you check your logfiles properly, you can find the ID-strings
      for a variety of browsers.
      --
      Kees de Keizer NT Administrator T: +31-10-2448344
      Wirehub! part of easynet PGP: 0x24E3770B F: +31-10-2448356
      http://www.wirehub.net/ kees.de.keizer@...
      Just what time of night do you call this ? [Song&Dance]
    • Jason Gomez
      Kees de Keizer: I tried placed your suggestion before Netscape and Mozilla, however, the outcome has not changed. This is part of my config file. GroupAgent
      Message 2 of 5 , Nov 7, 2002
      • 0 Attachment
        Kees de Keizer:

        I tried placed your suggestion before Netscape and Mozilla, however, the
        outcome has not changed. This is part of my config file.

        GroupAgent +MSIE+6* Microsoft Internet Explorer 6.x
        GroupAgent +MSIE+5* Microsoft Internet Explorer 5.x
        GroupAgent +MSIE+4* Microsoft Internet Explorer 4.x
        GroupAgent +MSIE+3* Microsoft Internet Explorer 3.x
        GroupAgent Mozilla/5.0 Mozilla 1.0
        GroupAgent Mozilla/4.7 Netscape Navigator 4.7
        GroupAgent Mozilla/4.5 Netscape Navigator 4.5
        GroupAgent Mozilla/4.0 Netscape Navigator 4.0
        GroupAgent Netscape6/6* Netscape Navigator 6.0
        GroupAgent Netscape/7* Netscape Navigator 7.0

        Any other suggestions ???

        Thanks for replying,

        Jason
      • Kees de Keizer
        ... The Netscape/Mozilla sequence is not in the right order. I can only drop you a few of my lines of agents: GroupAgent Opera/6 Opera 6.x
        Message 3 of 5 , Nov 8, 2002
        • 0 Attachment
          Jason Gomez wrote on 07-11-2002:

          > Kees de Keizer:
          >
          > I tried placed your suggestion before Netscape and Mozilla, however, the
          > outcome has not changed. This is part of my config file.
          >
          > GroupAgent +MSIE+6* Microsoft Internet Explorer 6.x
          > GroupAgent +MSIE+5* Microsoft Internet Explorer 5.x
          > GroupAgent +MSIE+4* Microsoft Internet Explorer 4.x
          > GroupAgent +MSIE+3* Microsoft Internet Explorer 3.x
          > GroupAgent Mozilla/5.0 Mozilla 1.0
          > GroupAgent Mozilla/4.7 Netscape Navigator 4.7
          > GroupAgent Mozilla/4.5 Netscape Navigator 4.5
          > GroupAgent Mozilla/4.0 Netscape Navigator 4.0
          > GroupAgent Netscape6/6* Netscape Navigator 6.0
          > GroupAgent Netscape/7* Netscape Navigator 7.0
          > Any other suggestions ???

          The Netscape/Mozilla sequence is not in the right order.

          I can only drop you a few of my lines of agents:

          GroupAgent Opera/6 Opera 6.x
          GroupAgent Opera/5 Opera 5.x
          GroupAgent Opera/4 Opera 4.x
          GroupAgent Opera/3 Opera 3.x
          GroupAgent +MSIE+6* Microsoft Internet Explorer 6.x
          GroupAgent +MSIE+5* Microsoft Internet Explorer 5.x
          GroupAgent +MSIE+4* Microsoft Internet Explorer 4.x
          GroupAgent +MSIE+3* Microsoft Internet Explorer 3.x
          GroupAgent +Netscape/7 Netscape Navigator 7.x
          GroupAgent +Netscape6/ Netscape Navigator 6.x
          GroupAgent Mozilla/5 Mozilla/Gecko
          GroupAgent Mozilla/4 Netscape Navigator 4.x
          GroupAgent Mozilla/3 Netscape Navigator 3.x
          GroupAgent Googlebot GoogleBot
          GroupAgent MSProxy Microsoft Proxy
          GroupAgent Proxy Other Proxy software
          GroupAgent Lynx Lynx
          GroupAgent * Other
          HideAgent *

          Did you remove the webalizer.current and regenerate the stats?
          --
          Kees de Keizer NT Administrator T: +31-10-2448344
          Wirehub! part of easynet PGP: 0x24E3770B F: +31-10-2448356
          http://www.wirehub.net/ kees.de.keizer@...
          Do you plan to put up a fight ? [JC Superstar]
        • Kees de Keizer
          ... That can t be the problem then. ... This has to to with the way webalizer has been compiled. The default length for the agent string is not long enough to
          Message 4 of 5 , Nov 8, 2002
          • 0 Attachment
            Jason Gomez wrote on 08-11-2002:

            > I am not using the incremental mode for webalizer, so I
            > do not have a webalizer.current.

            That can't be the problem then.

            > I changed the order of the config file:
            > GroupAgent +MSIE+6* Microsoft Internet Explorer 6.x
            > GroupAgent +MSIE+5* Microsoft Internet Explorer 5.x
            > GroupAgent +MSIE+4* Microsoft Internet Explorer 4.x
            > GroupAgent +MSIE+3* Microsoft Internet Explorer 3.x
            > GroupAgent +MSIE+2* Microsoft Internet Explorer 2.x
            > GroupAgent +Netscape/7 Netscape Navigator 7.0
            > GroupAgent +Netscape6/ Netscape Navigator 6.0
            > GroupAgent Mozilla/5.0 Mozilla 1.0
            > GroupAgent Mozilla/4.7 Netscape Navigator 4.7
            > GroupAgent Mozilla/4.5 Netscape Navigator 4.5
            > GroupAgent Mozilla/4.0 Netscape Navigator 4.0
            >
            > MSIE is not being grouped and I do not get anything for
            > Netscape/7 and Netscape6/.

            This has to to with the way webalizer has been compiled. The
            default length for the agent string is not long enough to
            catch the Netscape version for 6.x or higher:

            | From Bradford L. Barrett:
            | GroupAgent +Netscape6/ Netscape Navigator 6.x
            | Unless you modified the MAXAGENT value in webalizer.h, most
            | netscape 6 (and possibly other user agents) won't be caught
            | with the above.. the newer mozilla browsers have such large
            | user agent strings, they get truncated and the real id string
            | ("Netscape6") gets lost..

            > This is a sample of the log:
            > 205.188.209.140 - - [02/Oct/2002:13:33:58 -0400] "GET /fcla/cr/uwfsearch
            > HTTP/1.0" 302 296 "http://library.uwf.edu/" "Mozilla/4.0 (compatible;
            > MSIE 5.0; AOL 7.0; Windows 95; DigExt)"
            > Any other ideas why MSIE is not being grouped?

            A difference between IIS and Apache:

            Apache...: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
            IIS......: Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+98)

            Maybe, but I'm not certain, quotes can help: "MSIE 6.*"
            --
            Kees de Keizer NT Administrator T: +31-10-2448344
            Wirehub! part of easynet PGP: 0x24E3770B F: +31-10-2448356
            http://www.wirehub.net/ kees.de.keizer@...
            I could show you my favourite obsession [Rocky Horror Show]
          Your message has been successfully submitted and would be delivered to recipients shortly.