Loading ...
Sorry, an error occurred while loading the content.

RE: [webalizer] nothing happens!

Expand Messages
  • Waitman Gobble
    Frank Did you happen to receive an error ? I haven t messed with PWS too much but my guess is that it doesn t log in NCSA, probably uses w3c. or a Microsoft
    Message 1 of 3 , Nov 14, 2000
    • 0 Attachment
      Frank

      Did you happen to receive an "error"?

      I haven't messed with PWS too much but my guess is that it doesn't log in
      NCSA, probably uses w3c. or a Microsoft format. If you can post a couple of
      lines of a log file from PWS, I can let you know.

      I have worked with IIS4 under NT4 extensively and it has an NCSA option but
      it does CLF and not "Combined" format so you lose the ever-so-important
      referrer and ua data.

      Even running convlog on w3c drops these fields.

      There are a couple of fellows on this list, including myself, that have
      written some utilities to convert the w3c into NCSA "combined". Mine isn't
      so conventional though, requires that PHP is running on the NT machine. You
      can find some VBS, others if you hunt around this newsgroup.

      But if I remember correctly Brad has already/is putting support for w3c into
      webalizer, this would be "best" solution.

      By the way, if you can bare to part with ASP and/or ActiveX, I would totally
      suggest running Apache on your workstation. Much spiffier.

      Best,

      Waitman Gobble
      Media Keepsakes
      Buena Park, CA

      -----Original Message-----
      From: eichef@... [mailto:eichef@...]
      Sent: Tuesday, November 14, 2000 6:51 AM
      To: webalizer@egroups.com
      Subject: [webalizer] nothing happens!


      I tried to use several webalizer versions on a personal web server
      (pws) on a nt 4 workstation. But none of these versions are able to
      handle its logfile. As far as I know, the default format for pws is
      ncsa and webalizer should be able to handle it.

      I tried to use convlog, but convlog says there was no need to convert
      the logfile.

      Does anyone have a idea how to get it running on a windows nt
      workstation with pws installed? I just need the basic features.

      Later I want to install it on a windows nt server with IIS 4
      installed. For testing purposes I used a workstation with pws. Just
      to make that clear.

      Please give me a hint!

      thanks
      Frank



      To unsubscribe from this group, send an email to:
      webalizer-unsubscribe@egroups.com
      Webalizer homepage: http://www.webalizer.org
      Webalizer for NT: http://www.medasys-lille.com/webalizer/
      (Old URL: http://private.homepages.intershop.de/klaus/webalizer/)
    • Waitman Gobble
      Frank, Here is NSCA CLF: host rfc931 authuser [DD/Mon/YYYY:hh:mm:ss] request ddd bbbb host: Either the DNS name or the IP number of the remote client rfc931:
      Message 2 of 3 , Nov 14, 2000
      • 0 Attachment
        Frank,

        Here is NSCA CLF:

        host rfc931 authuser [DD/Mon/YYYY:hh:mm:ss] "request" ddd bbbb

        host: Either the DNS name or the IP number of the remote client
        rfc931: Any information returned by identd for this person, - otherwise.
        authuser: If user sent a userid for authentication, the user name, -
        otherwise.
        Day
        Mon: Month (calendar name)
        YYYY: Year
        hh: hour (24-hour format, the machine's timezone)
        mm: minutes
        ss: seconds
        request: The first line of the HTTP request as sent by the client.
        ddd: the status code returned by the server, - if not available.
        bbbb: the total number of bytes sent, *not including the HTTP/1.0 header*, -
        if not available

        "Combined" also includes the Referrer and the User Agent.

        Your format is w3c format. It is a standard proposed by the w3c (see
        http://www.w3c.org) The format of the log file is changeable, each column is
        optional. Here is an example:

        #Version: 1.0
        #Date: 12-Jan-1997
        #Fields: time cs-method cs-uri
        00:34:23 GET /foo/bar.html

        The #Fields spec tells the parser what fields are included in the log file.

        When I run convlog on the log file you attached, it formats it just fine.

        The command:

        convlog -ie e123.log

        Creates a file e123.log.ncsa as follows:

        192.168.1.110 - - [14/Nov/2000:11:12:30 +0000] "GET /Img/template1_01.jpg
        HTTP/1.0" 404 -
        192.168.1.110 - - [14/Nov/2000:11:12:39 +0000] "GET /Img/template1_01.jpg
        HTTP/1.0" 404 -
        192.168.1.110 - - [14/Nov/2000:11:12:48 +0000] "GET /index.html HTTP/1.0"
        200 -
        192.168.1.110 - - [14/Nov/2000:11:12:48 +0000] "GET /Img/logoM.gif HTTP/1.0"
        200 -
        192.168.1.110 - - [14/Nov/2000:11:12:48 +0000] "GET /detection.htm HTTP/1.0"
        200 -
        192.168.1.110 - - [14/Nov/2000:11:12:48 +0000] "GET /frameset.htm HTTP/1.0"
        200 -
        192.168.1.110 - - [14/Nov/2000:11:12:48 +0000] "GET /intronew.html HTTP/1.0"
        200 -
        192.168.1.110 - - [14/Nov/2000:11:12:48 +0000] "GET /navigationframeohne.htm
        HTTP/1.0" 200 -
        192.168.1.110 - - [14/Nov/2000:11:12:48 +0000] "GET /Img/template1_01.jpg
        HTTP/1.0" 404 -
        192.168.1.110 - - [14/Nov/2000:11:12:48 +0000] "GET /Img/navohne.swf
        HTTP/1.0" 200 -
        192.168.1.110 - - [14/Nov/2000:11:12:48 +0000] "GET /intronew.swf HTTP/1.0"
        200 -
        192.168.1.129 - - [14/Nov/2000:15:18:29 +0000] "GET /index.html HTTP/1.0"
        200 -
        192.168.1.129 - - [14/Nov/2000:15:18:29 +0000] "GET /Img/logoM.gif HTTP/1.0"
        200 -
        192.168.1.129 - - [14/Nov/2000:15:18:29 +0000] "GET /detection.htm HTTP/1.0"
        200 -
        192.168.1.129 - - [14/Nov/2000:15:18:29 +0000] "GET /frameset.htm HTTP/1.0"
        200 -
        192.168.1.129 - - [14/Nov/2000:15:18:29 +0000] "GET /intronew.html HTTP/1.0"
        200 -
        192.168.1.129 - - [14/Nov/2000:15:18:29 +0000] "GET /navigationframeohne.htm
        HTTP/1.0" 200 -
        192.168.1.129 - - [14/Nov/2000:15:18:29 +0000] "GET /Img/template1_01.jpg
        HTTP/1.0" 404 -
        192.168.1.129 - - [14/Nov/2000:15:18:29 +0000] "GET /Img/navohne.swf
        HTTP/1.0" 200 -
        192.168.1.129 - - [14/Nov/2000:15:18:29 +0000] "GET /intronew.swf HTTP/1.0"
        200 -
        192.168.1.129 - - [14/Nov/2000:15:18:35 +0000] "GET /kontakt.htm HTTP/1.0"
        200 -
        192.168.1.129 - - [14/Nov/2000:15:18:40 +0000] "GET /Img/template1_01.jpg
        HTTP/1.0" 404 -

        Running webalizer on e123.log.ncsa does just fine.

        Here is the exact command i typed in:

        webalizer e123.log.ncsa

        Take a look at the results:

        http://gujja.mediakeepsakes.com/wpwst

        Please note that

        #0 i ran webalizer version 1.30-04 on a win2000 machine (APPDEV). I am quite
        certain there is a more recent version available. I just happened to have
        that version zipped up in my download cache.

        #1 i didn't take the time to mess around with the config file for webalizer,
        the reports can (and likely should) be customized.

        #2 I tossed the webalizer OUTPUT from your log file on a Linux box
        i have sitting around here. So it might not pop up exactly speedily.

        If you create a batch file to run convlog then webalizer, you can set the
        batch file to run from the scheduler. On a shared hosting plan you might
        have trouble doing this kinda thing (ie. you don't own the server or have
        admin access).

        Let me know if you have any questions.

        Best,

        Waitman Gobble
        Media Keepsakes
        Buena Park, CA
        Toll Free in US 877-290-2768
        Elsewhere 714-525-6464
        Toll Free Fax 877-588-6865

        -----Original Message-----
        From: Frank Eiche [mailto:frank.eiche@...]
        Sent: Tuesday, November 14, 2000 8:08 AM
        To: waitman@...
        Subject: Re: [webalizer] nothing happens!



        ----- Original Message -----
        From: Waitman Gobble <>
        To: <webalizer@egroups.com>
        Sent: Tuesday, November 14, 2000 4:55 PM
        Subject: RE: [webalizer] nothing happens!


        Hello Waitman,

        > Did you happen to receive an "error"?

        Yes, many...nothing more than errors. Webalizer doesn't even create a singe
        file,
        it isn't able to handle this logfile.

        The logfile looks like this:

        #Software: Microsoft Internet Information Server 4.0
        #Version: 1.0
        #Date: 2000-11-14 11:12:30
        #Fields: time c-ip cs-method cs-uri-stem sc-status
        11:12:30 192.168.1.110 GET /Img/template1_01.jpg 404
        11:12:39 192.168.1.110 GET /Img/template1_01.jpg 404
        11:12:48 192.168.1.110 GET /index.html 200
        11:12:48 192.168.1.110 GET /Img/logoM.gif 200
        11:12:48 192.168.1.110 GET /detection.htm 200
        11:12:48 192.168.1.110 GET /frameset.htm 200
        11:12:48 192.168.1.110 GET /intronew.html 200
        11:12:48 192.168.1.110 GET /navigationframeohne.htm 200
        11:12:48 192.168.1.110 GET /Img/template1_01.jpg 404
        11:12:48 192.168.1.110 GET /Img/navohne.swf 200
        11:12:48 192.168.1.110 GET /intronew.swf 200
        15:18:29 192.168.1.129 GET /index.html 200
        15:18:29 192.168.1.129 GET /Img/logoM.gif 200
        15:18:29 192.168.1.129 GET /detection.htm 200
        15:18:29 192.168.1.129 GET /frameset.htm 200
        15:18:29 192.168.1.129 GET /intronew.html 200
        15:18:29 192.168.1.129 GET /navigationframeohne.htm 200
        15:18:29 192.168.1.129 GET /Img/template1_01.jpg 404
        15:18:29 192.168.1.129 GET /Img/navohne.swf 200
        15:18:29 192.168.1.129 GET /intronew.swf 200
        15:18:35 192.168.1.129 GET /kontakt.htm 200
        15:18:40 192.168.1.129 GET /Img/template1_01.jpg 404


        > I haven't messed with PWS too much but my guess is that it doesn't log in
        > NCSA, probably uses w3c. or a Microsoft format. If you can post a couple
        of
        > lines of a log file from PWS, I can let you know.

        See above. The manual says, it was NCSA, but I'm not sure.

        The most important thing is: we want to track accesses to some realplayer
        movies
        (.rm files), because they are billed "per-access" by our provider.

        And we want to collect as much information as possible about the visitors.
        By the
        way: if possible, everything should be automated, so that a report is
        created every
        day without starting webalizer manually each time. How could I solve this?

        And, as I said before, the target will be a windows nt 4 server with IIS 4
        installed.
        It would be great, if we could use webalizer, since we don't need detailed
        informations,
        just the accesses to the real files.

        Thanks for your answer...would be nice, if I receive a 2nd one :)

        kind regards
        Frank
      Your message has been successfully submitted and would be delivered to recipients shortly.