Loading ...
Sorry, an error occurred while loading the content.

2702Re: [webalizer] usage by country

Expand Messages
  • simon benedict
    May 3 11:07 PM
    • 0 Attachment
      thanks a lot for ur reply but i want to tell you that i am using the  IIS generated log to generate the web statistics.
       
      What i mean exactly is this
       
      my website is running on win2k machine running IIS and i generate logs in ncsa.log format and I ftp them to my red hat linux box where i have webalizer running to get my web usage .
       
      so the logs are produced by IIS and not by apache .
       
      is there any change i need to do in IIS or change the log file format ??
       
      appreciate if you let me know
       
      thanks n regards
       
       
      simon
       
       
       
       
       
       
       
       
       
       
      tanislaw Pusep <stanis@...> wrote:
      Hello Simon!
      By default, Webalizer's country identification comes from reverse DNS records that Web server wrotes to logs. Every time client connects Apache tries to obtain it's hostname by IP address and writes hostname to logs. Webalizer simply extracts hostname suffix and resolves country name using special table.
      The problem is: not all clients has hostname associated. Many ISP doesn't care about this. So Webalizer "gets lost".
      To overcome this problem you can use software that has database to associate IP ranges directly to country. I've written a patch that integrates GeoIP library support into Webalizer: http://sysd.org/proj/log.php#glzr
      On this address there's a patch to Webalizer source and static binary for Linux. Good luck!


      ----- Original Message -----
      From: simon benedict <sbdcunha@...>
      Date: Wed, 21 Apr 2004 09:26:40 -0700 (PDT)
      To: webalizer@yahoogroups.com
      Subject: [webalizer] usage by country

      > Hi All

      > I am running webalizer on Linux Box and using the log files from IIS to generate the statistics.

      > but the usage by country shows me 87%  unresolved/unknown


      > http://weblog.baladia.gov.kw/usage_200404.html


      > i really dont know if it should be this way and how do i get rid of this so that my pie chart graph shows all countries

      > do i have to change any settings in my IIS or the webalizer.conf file


      > thnks and appreacite


      > regards

      > simon
      >
      >
      >
      >
      > ---------------------------------
      >
      >
      >
      >
      >
      > > ATTACHMENT part 2 application/x-pkcs7-signature name=smime.p7s
      >
      >
      >            
      > ---------------------------------
      > Do you Yahoo!?
      Yahoo! Photos: High-quality 4x6 digital prints for 25�
      --
      ______________________________________________
      Check out the latest SMS services @ http://www.linuxmail.org
      This allows you to send and receive SMS through your mailbox.


      Powered by Outblaze


      Webalizer homepage: http://www.webalizer.org
      Webalizer for NT: http://www.medasys-lille.com/webalizer/


      ttp://www.webalizer.org
      Webalizer for NT: http://www.medasys-lille.com/webalizer/






      Yahoo! Groups Links


      Do you Yahoo!?
      Win a $20,000 Career Makeover at Yahoo! HotJobs

    • Show all 9 messages in this topic