Loading ...
Sorry, an error occurred while loading the content.

2332RE: [webalizer] make issue ?

Expand Messages
  • Florent Gilain
    Sep 18, 2003
    • 0 Attachment
      Just one precision :

      if i just tell Apache to use "common" log format, all is working perfectly,
      but if i try to use my customized log format, i doesn't...

      Florent

      -----Message d'origine-----
      De : Florent Gilain [mailto:fgilain@...]
      Envoye : jeudi 18 septembre 2003 18:13
      A : webalizer@yahoogroups.com
      Objet : RE: [webalizer] make issue ?


      I finally decided to completly reinstall GD gd-2.0.11.
      Webalizer is now correctly installed ;-))

      My problem is to use it now ;-))

      I'm so bad at Unix ;-((

      My Apache Web server is running with 2 virtual hosts. Each has personnal log
      files with a customosed log format.
      I'm unable to analyze it with the tool....
      I took the sample.conf file in source dir and copy it in another dir, edited
      it to feet my logs file names but here is what I get when I run the :

      webalizer -c myconffile.conf

      Warning: Truncating oversized username
      Skipping bad record (5688)
      Warning: Truncating oversized username
      Skipping bad record (5689)
      Warning: Truncating oversized username
      Skipping bad record (5690)
      Warning: Truncating oversized username
      Skipping bad record (5691)
      Warning: Truncating oversized username
      Skipping bad record (5692)
      Warning: Truncating oversized userna
      .....
      ...
      ...
      ...

      Thank you for your help.

      Florent G.



      -----Message d'origine-----
      De : Bradford L. Barrett [mailto:brad@...]
      Envoye : jeudi 18 septembre 2003 17:39
      A : Florent Gilain
      Cc : webalizer@yahoogroups.com
      Objet : RE: [webalizer] make issue ?



      > I didn't install the GD library as a stand alone apps...in fact, here are
      > the softwares I have installed :
      [...]

      Ok, it appears that you do have the GD library, but apparently an older
      version that does not support PNG images.. I should have looked closer
      at the output of your ./configure run;

      > > checking for main in -lpng... (cached) yes
      > > checking for gdImagePng in -lgd... (cached) no <---
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
      > > checking for libgd.a... (cached) /usr/local/lib
      > > checking for gd.h... (cached) /usr/local/include
      [...]
      > > Undefined first referenced
      > > symbol in file
      > > gdImagePng graphs.o
      ^^^^^^^^^^

      Your version of GD doesn't support PNG images.

      --
      Bradford L. Barrett brad@...
      A free electron in a sea of neutrons DoD#1750 KD4NAW

      The only thing Micro$oft has done for society, is make people
      believe that computers are inherently unreliable.


      To unsubscribe from this group, send an email to:
      webalizer-unsubscribe@egroups.com
      Webalizer homepage: http://www.webalizer.org
      Webalizer for NT: http://www.medasys-lille.com/webalizer/




      Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/




      To unsubscribe from this group, send an email to:
      webalizer-unsubscribe@egroups.com
      Webalizer homepage: http://www.webalizer.org
      Webalizer for NT: http://www.medasys-lille.com/webalizer/




      Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
    • Show all 8 messages in this topic