Loading ...
Sorry, an error occurred while loading the content.
 

[patch] Make GUI's 'Replace All' work despite gdefault

Expand Messages
  • Jonathan del Strother
    Hi there - when using MacVim with gdefault enabled, trying to use the GUI to replace-all will only replace the first instance of the word on each line. What do
    Message 1 of 5 , Aug 11, 2014
      Hi there - when using MacVim with gdefault enabled, trying to use the
      GUI to replace-all will only replace the first instance of the word on
      each line.

      What do you think to the attached patch?

      -Jonathan

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Jonathan del Strother
      Noone else run into this problem? ... -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are
      Message 2 of 5 , Aug 15, 2014
        Noone else run into this problem?

        On 11 August 2014 11:17, Jonathan del Strother <maillist@...> wrote:
        > Hi there - when using MacVim with gdefault enabled, trying to use the
        > GUI to replace-all will only replace the first instance of the word on
        > each line.
        >
        > What do you think to the attached patch?
        >
        > -Jonathan

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • John Little
        ... Yes, /g acts as a toggle. Leave it off if gdefault is set, if you want all instances replaced. Your proposed patch would be an incompatible change, which
        Message 3 of 5 , Aug 16, 2014
          n 11 August 2014 11:17, Jonathan del Strother <maillist@...> wrote:
          >... with gdefault enabled, trying to use the
          > GUI to replace-all will only replace the first instance of the word on
          > each line.

          Yes, /g acts as a toggle. Leave it off if gdefault is set, if you want all instances replaced.

          Your proposed patch would be an incompatible change, which will bite someone somewhere sometime, and so (I would expect) unlikely to be accepted.

          IMO the option is more trouble than it's worth, an historical wart.

          Regards, John Little

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Jonathan del Strother
          ... I m curious which vim GUIs deal with this in a sane way. MacVim supplies this standard Find & Replace window -
          Message 4 of 5 , Aug 16, 2014
            On 16 August 2014 12:39, John Little <John.B.Little@...> wrote:
            > n 11 August 2014 11:17, Jonathan del Strother <maillist@...> wrote:
            >>... with gdefault enabled, trying to use the
            >> GUI to replace-all will only replace the first instance of the word on
            >> each line.
            >
            > Yes, /g acts as a toggle. Leave it off if gdefault is set, if you want all instances replaced.
            >

            I'm curious which vim GUIs deal with this in a sane way. MacVim
            supplies this standard Find & Replace window -
            https://www.dropbox.com/s/6lxhu4bf1wu8ifo/Screenshot%202014-08-16%2014.10.33.png
            - I doubt that anyone clicking "Replace All" expects it to only
            replace the first occurrence on each line when gdefault is set. And
            with gdefault set, there's no way to replace all occurrences of a word
            via that UI (other than by repeatedly clicking "Replace All", which
            might have unintended consequences depending on what you're replacing
            with what).

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Christian Brabandt
            ... I haven t said anything, because it just seems so clear to have it fixed as you did. Best, Christian -- Nicht alles, was totgeschwiegen wird, lebt. -- Karl
            Message 5 of 5 , Aug 16, 2014
              On Fr, 15 Aug 2014, Jonathan del Strother wrote:

              > Noone else run into this problem?

              I haven't said anything, because it just seems so clear to have it fixed
              as you did.

              Best,
              Christian
              --
              Nicht alles, was totgeschwiegen wird, lebt.
              -- Karl Kraus

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            Your message has been successfully submitted and would be delivered to recipients shortly.