Loading ...
Sorry, an error occurred while loading the content.

Issue 245 in vim: quickfix list should not process modelines

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 245 by justi...@gmail.com: quickfix list should not process modelines
    Message 1 of 7 , Aug 3 9:45 AM
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 245 by justi...@...: quickfix list should not process
      modelines
      http://code.google.com/p/vim/issues/detail?id=245

      What steps will reproduce the problem?
      1. open a quickfix list with the first entry having a string like "vim: foo"
      2. vim tries to process "foo" as a modeline


      What is the expected output? What do you see instead?

      There's no reason for the quickfix list to recognize modelines.


      What version of the product are you using? On what operating system?

      7.4, linux/mac/windows.




      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • vim@...
      Comment #1 on issue 245 by justi...@gmail.com: quickfix list should not process modelines http://code.google.com/p/vim/issues/detail?id=245 ... Vim reports
      Message 2 of 7 , Aug 3 9:47 AM
      • 0 Attachment
        Comment #1 on issue 245 by justi...@...: quickfix list should not
        process modelines
        http://code.google.com/p/vim/issues/detail?id=245

        Precise steps to reproduce:

        :expr ['vim: foo']

        Vim reports "E518: Unknown option: foo"

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • vim@...
        Comment #2 on issue 245 by justi...@gmail.com: quickfix list should not process modelines http://code.google.com/p/vim/issues/detail?id=245 ... Vim reports
        Message 3 of 7 , Aug 3 9:48 AM
        • 0 Attachment
          Comment #2 on issue 245 by justi...@...: quickfix list should not
          process modelines
          http://code.google.com/p/vim/issues/detail?id=245

          Precise steps to reproduce:

          :cexpr ['vim: foo']

          Vim reports "E518: Unknown option: foo"

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • vim@...
          Comment #3 on issue 245 by chrisbr...@googlemail.com: quickfix list should not process modelines http://code.google.com/p/vim/issues/detail?id=245 I am sorry,
          Message 4 of 7 , Aug 4 5:13 AM
          • 0 Attachment
            Comment #3 on issue 245 by chrisbr...@...: quickfix list should
            not process modelines
            http://code.google.com/p/vim/issues/detail?id=245

            I am sorry, but I don't see this problem. Running
            vim -u NONE -N -c 'cexpr ["vim: foo"]'
            Doesn't report an error message.

            --
            You received this message because this project is configured to send all
            issue notifications to this address.
            You may adjust your notification preferences at:
            https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • vim@...
            Comment #4 on issue 245 by justi...@gmail.com: quickfix list should not process modelines http://code.google.com/p/vim/issues/detail?id=245 You re right,
            Message 5 of 7 , Aug 4 7:03 AM
            • 0 Attachment
              Comment #4 on issue 245 by justi...@...: quickfix list should not
              process modelines
              http://code.google.com/p/vim/issues/detail?id=245

              You're right, there's some extra step that is needed. I see this issue
              often, but somehow I can't reproduce it at all now. I will report once I
              find the cause.

              --
              You received this message because this project is configured to send all
              issue notifications to this address.
              You may adjust your notification preferences at:
              https://code.google.com/hosting/settings

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • vim@...
              Updates: Status: Invalid Comment #5 on issue 245 by chrisbr...@googlemail.com: quickfix list should not process modelines
              Message 6 of 7 , Oct 2, 2014
              • 0 Attachment
                Updates:
                Status: Invalid

                Comment #5 on issue 245 by chrisbr...@...: quickfix list should
                not process modelines
                https://code.google.com/p/vim/issues/detail?id=245

                Closing as invalid. If you can reproduce the issue, feel free to open a new
                issue (or report at the vim-dev mailinglist) then.

                --
                You received this message because this project is configured to send all
                issue notifications to this address.
                You may adjust your notification preferences at:
                https://code.google.com/hosting/settings

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • vim@...
                Comment #6 on issue 245 by dhahler@gmail.com: quickfix list should not process modelines https://code.google.com/p/vim/issues/detail?id=245 This might happen
                Message 7 of 7 , Nov 20, 2014
                • 0 Attachment
                  Comment #6 on issue 245 by dhahler@...: quickfix list should not
                  process modelines
                  https://code.google.com/p/vim/issues/detail?id=245

                  This might happen when some plugin calls `doautocmd`, e.g. fugitive does
                  this for its `:Glog`:

                  BufRead Auto commands for "*"
                  cmd: call fugitive#detect(expand('<amatch>:p'))

                  (reported at https://github.com/tpope/vim-fugitive/issues/580)

                  Modelines currently get executed unconditionally in this case, but even
                  with the patch to only do so when commands have been called
                  (https://groups.google.com/d/msg/vim_dev/DidKMDAsppw/RHedJGM-G6EJ) this is
                  an issue.

                  It's not really a Vim issue though - except if Vim would decide to skip
                  modelines for &buftype != "".

                  --
                  You received this message because this project is configured to send all
                  issue notifications to this address.
                  You may adjust your notification preferences at:
                  https://code.google.com/hosting/settings

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                Your message has been successfully submitted and would be delivered to recipients shortly.