Loading ...
Sorry, an error occurred while loading the content.
 

Issue 243 in vim: Regex matching behaviour has changed in 7.4

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 243 by timothy....@ucdconnect.ie: Regex matching behaviour has changed in 7.4
    Message 1 of 7 , Jul 29, 2014
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 243 by timothy....@...: Regex matching behaviour has
      changed in 7.4
      http://code.google.com/p/vim/issues/detail?id=243

      What steps will reproduce the problem?
      1. Open 7.4
      2. View some html, ie : <b>test test</b>
      3. Search using the following regex:
      /\v%(\<\1\>)@<=.*%(\<\/(\w+)\>)@=

      What is the expected output? What do you see instead?
      In previous version (I have only confirmed for 7.1.42) the regex will
      correctly match the text between the html tags, following the behaviour in
      the regex documentation. In 7.4 it fails to match.

      What version of the product are you using? On what operating system?

      VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Aug 10 2013 14:38:33)
      MS-Windows 32-bit GUI version with OLE support
      Compiled by mool@tororo
      Big version with GUI. Features included (+) or not (-):
      +arabic +cmdline_hist +digraphs
      +float +libcall +mouseshape
      +printer +smartindent -tgetent +viminfo
      +autocmd +cmdline_info -dnd
      +folding +linebreak +multi_byte_ime/dyn
      -profile -sniff -termresponse +vreplace
      +balloon_eval +comments -ebcdic
      -footer +lispindent +multi_lang
      +python/dyn +startuptime +textobjects +wildignore
      +browse +conceal +emacs_tags
      +gettext/dyn +listcmds -mzscheme
      +python3/dyn +statusline +title +wildmenu
      ++builtin_terms +cryptv +eval
      -hangul_input +localmap +netbeans_intg
      +quickfix -sun_workshop +toolbar +windows
      +byte_offset +cscope +ex_extra
      +iconv/dyn -lua +ole
      +reltime +syntax +user_commands +writebackup
      +cindent +cursorbind +extra_search
      +insert_expand +menu +path_extra
      +rightleft +tag_binary +vertsplit -xfontset
      +clientserver +cursorshape +farsi
      +jumplist +mksession +perl/dyn
      +ruby/dyn +tag_old_static +virtualedit -xim
      +clipboard +dialog_con_gui +file_in_path
      +keymap +modify_fname +persistent_undo
      +scrollbind -tag_any_white +visual -xterm_save
      +cmdline_compl +diff +find_in_path
      +langmap +mouse -postscript
      +signs +tcl/dyn +visualextra +xpm_w32
      system vimrc file: "$VIM\vimrc"
      user vimrc file: "$HOME\_vimrc"
      2nd user vimrc file: "$HOME\vimfiles\vimrc"
      3rd user vimrc file: "$VIM\_vimrc"
      user exrc file: "$HOME\_exrc"
      2nd user exrc file: "$VIM\_exrc"
      system gvimrc file: "$VIM\gvimrc"
      user gvimrc file: "$HOME\_gvimrc"
      2nd user gvimrc file: "$HOME\vimfiles\gvimrc"
      3rd user gvimrc file: "$VIM\_gvimrc"
      system menu file: "$VIMRUNTIME\menu.vim"
      Compilation: cl -c /W3 /nologo -I. -Iproto -DHAVE_PATHDEF -DWIN32
      -DFEAT_CSCOPE -DFEAT_NETBEANS_INTG -DFEAT_XPM_W32 -DWINVER=0x0400
      -D_WIN32_WINNT=0x0400 /Fo.\ObjGOLYHTRi386/ /Ox /GL -DNDEBUG /Zl /MT
      -DFEAT_OLE -DFEAT_MBYTE_IME -DDYNAMIC_IME -DFEAT_GUI_W32 -DDYNAMIC_ICONV
      -DDYNAMIC_GETTEXT -DFEAT_TCL -DDYNAMIC_TCL -DDYNAMIC_TCL_DLL=\"tcl85.dll\"
      -DDYNAMIC_TCL_VER=\"8.5\" -DFEAT_PYTHON -DDYNAMIC_PYTHON
      -DDYNAMIC_PYTHON_DLL=\"python27.dll\" -DFEAT_PYTHON3 -DDYNAMIC_PYTHON3
      -DDYNAMIC_PYTHON3_DLL=\"python32.dll\" -DFEAT_PERL -DDYNAMIC_PERL
      -DDYNAMIC_PERL_DLL=\"perl514.dll\" -DFEAT_RUBY -DDYNAMIC_RUBY
      -DDYNAMIC_RUBY_VER=19 -DDYNAMIC_RUBY_DLL=\"msvcrt-ruby192.dll\" -DFEAT_BIG
      /Fd.\ObjGOLYHTRi386/ /Zi
      Linking: link /RELEASE /nologo /subsystem:windows /LTCG:STATUS oldnames.lib
      kernel32.lib advapi32.lib shell32.lib gdi32.lib comdlg32.lib ole32.lib
      uuid.lib /machine:i386 /nodefaultlib gdi32.lib version.lib winspool.lib
      comctl32.lib advapi32.lib shell32.lib /machine:i386 /nodefaultlib
      libcmt.lib oleaut32.lib user32.lib /nodefaultlib:python27.lib
      /nodefaultlib:python32.lib "E:\tcl\lib\tclstub85.lib" WSock32.lib
      xpm\x86\lib\libXpm.lib /PDB:gvim.pdb -debug


      Please provide any additional information below.
      I have repeated this with -u NONE and set nocompatible to rule out any
      issues with plugins or options.



      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • timothy.brosnan1@...
      ... This was my report, it has already been addressed here https://groups.google.com/forum/#!topic/vim_dev/6RjqNC6p9jU -- -- You received this message from the
      Message 2 of 7 , Jul 29, 2014
        On Tuesday, July 29, 2014 8:20:16 PM UTC+1, v...@... wrote:
        > Status: New
        >
        > Owner: ----
        >
        > Labels: Type-Defect Priority-Medium
        >
        >
        >
        > New issue 243 by timothy....@...: Regex matching behaviour has
        >
        > changed in 7.4
        >
        > http://code.google.com/p/vim/issues/detail?id=243
        >
        >
        >
        > What steps will reproduce the problem?
        >
        > 1. Open 7.4
        >
        > 2. View some html, ie : <b>test test</b>
        >
        > 3. Search using the following regex:
        >
        > /\v%(\<\1\>)@<=.*%(\<\/(\w+)\>)@=
        >
        >
        >
        > What is the expected output? What do you see instead?
        >
        > In previous version (I have only confirmed for 7.1.42) the regex will
        >
        > correctly match the text between the html tags, following the behaviour in
        >
        > the regex documentation. In 7.4 it fails to match.
        >
        >
        >
        > What version of the product are you using? On what operating system?
        >
        >
        >
        > VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Aug 10 2013 14:38:33)
        >
        > MS-Windows 32-bit GUI version with OLE support
        >
        > Compiled by mool@tororo
        >
        > Big version with GUI. Features included (+) or not (-):
        >
        > +arabic +cmdline_hist +digraphs
        >
        > +float +libcall +mouseshape
        >
        > +printer +smartindent -tgetent +viminfo
        >
        > +autocmd +cmdline_info -dnd
        >
        > +folding +linebreak +multi_byte_ime/dyn
        >
        > -profile -sniff -termresponse +vreplace
        >
        > +balloon_eval +comments -ebcdic
        >
        > -footer +lispindent +multi_lang
        >
        > +python/dyn +startuptime +textobjects +wildignore
        >
        > +browse +conceal +emacs_tags
        >
        > +gettext/dyn +listcmds -mzscheme
        >
        > +python3/dyn +statusline +title +wildmenu
        >
        > ++builtin_terms +cryptv +eval
        >
        > -hangul_input +localmap +netbeans_intg
        >
        > +quickfix -sun_workshop +toolbar +windows
        >
        > +byte_offset +cscope +ex_extra
        >
        > +iconv/dyn -lua +ole
        >
        > +reltime +syntax +user_commands +writebackup
        >
        > +cindent +cursorbind +extra_search
        >
        > +insert_expand +menu +path_extra
        >
        > +rightleft +tag_binary +vertsplit -xfontset
        >
        > +clientserver +cursorshape +farsi
        >
        > +jumplist +mksession +perl/dyn
        >
        > +ruby/dyn +tag_old_static +virtualedit -xim
        >
        > +clipboard +dialog_con_gui +file_in_path
        >
        > +keymap +modify_fname +persistent_undo
        >
        > +scrollbind -tag_any_white +visual -xterm_save
        >
        > +cmdline_compl +diff +find_in_path
        >
        > +langmap +mouse -postscript
        >
        > +signs +tcl/dyn +visualextra +xpm_w32
        >
        > system vimrc file: "$VIM\vimrc"
        >
        > user vimrc file: "$HOME\_vimrc"
        >
        > 2nd user vimrc file: "$HOME\vimfiles\vimrc"
        >
        > 3rd user vimrc file: "$VIM\_vimrc"
        >
        > user exrc file: "$HOME\_exrc"
        >
        > 2nd user exrc file: "$VIM\_exrc"
        >
        > system gvimrc file: "$VIM\gvimrc"
        >
        > user gvimrc file: "$HOME\_gvimrc"
        >
        > 2nd user gvimrc file: "$HOME\vimfiles\gvimrc"
        >
        > 3rd user gvimrc file: "$VIM\_gvimrc"
        >
        > system menu file: "$VIMRUNTIME\menu.vim"
        >
        > Compilation: cl -c /W3 /nologo -I. -Iproto -DHAVE_PATHDEF -DWIN32
        >
        > -DFEAT_CSCOPE -DFEAT_NETBEANS_INTG -DFEAT_XPM_W32 -DWINVER=0x0400
        >
        > -D_WIN32_WINNT=0x0400 /Fo.\ObjGOLYHTRi386/ /Ox /GL -DNDEBUG /Zl /MT
        >
        > -DFEAT_OLE -DFEAT_MBYTE_IME -DDYNAMIC_IME -DFEAT_GUI_W32 -DDYNAMIC_ICONV
        >
        > -DDYNAMIC_GETTEXT -DFEAT_TCL -DDYNAMIC_TCL -DDYNAMIC_TCL_DLL=\"tcl85.dll\"
        >
        > -DDYNAMIC_TCL_VER=\"8.5\" -DFEAT_PYTHON -DDYNAMIC_PYTHON
        >
        > -DDYNAMIC_PYTHON_DLL=\"python27.dll\" -DFEAT_PYTHON3 -DDYNAMIC_PYTHON3
        >
        > -DDYNAMIC_PYTHON3_DLL=\"python32.dll\" -DFEAT_PERL -DDYNAMIC_PERL
        >
        > -DDYNAMIC_PERL_DLL=\"perl514.dll\" -DFEAT_RUBY -DDYNAMIC_RUBY
        >
        > -DDYNAMIC_RUBY_VER=19 -DDYNAMIC_RUBY_DLL=\"msvcrt-ruby192.dll\" -DFEAT_BIG
        >
        > /Fd.\ObjGOLYHTRi386/ /Zi
        >
        > Linking: link /RELEASE /nologo /subsystem:windows /LTCG:STATUS oldnames.lib
        >
        > kernel32.lib advapi32.lib shell32.lib gdi32.lib comdlg32.lib ole32.lib
        >
        > uuid.lib /machine:i386 /nodefaultlib gdi32.lib version.lib winspool.lib
        >
        > comctl32.lib advapi32.lib shell32.lib /machine:i386 /nodefaultlib
        >
        > libcmt.lib oleaut32.lib user32.lib /nodefaultlib:python27.lib
        >
        > /nodefaultlib:python32.lib "E:\tcl\lib\tclstub85.lib" WSock32.lib
        >
        > xpm\x86\lib\libXpm.lib /PDB:gvim.pdb -debug
        >
        >
        >
        >
        >
        > Please provide any additional information below.
        >
        > I have repeated this with -u NONE and set nocompatible to rule out any
        >
        > issues with plugins or options.
        >
        >
        >
        >
        >
        >
        >
        > --
        >
        > You received this message because this project is configured to send all
        >
        > issue notifications to this address.
        >
        > You may adjust your notification preferences at:
        >
        > https://code.google.com/hosting/settings

        This was my report, it has already been addressed here https://groups.google.com/forum/#!topic/vim_dev/6RjqNC6p9jU

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • vim@...
        Updates: Status: Invalid Comment #1 on issue 243 by brammool...@gmail.com: Regex matching behaviour has changed in 7.4
        Message 3 of 7 , Jul 30, 2014
          Updates:
          Status: Invalid

          Comment #1 on issue 243 by brammool...@...: Regex matching behaviour
          has changed in 7.4
          http://code.google.com/p/vim/issues/detail?id=243

          You are using a backreference before the () group that defines it contents,
          that doesn't work. I'm surprised this works in the backtracking engine,
          that might be called a bug.

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • vim@...
          Comment #2 on issue 243 by timothy....@ucdconnect.ie: Regex matching behaviour has changed in 7.4 http://code.google.com/p/vim/issues/detail?id=243 Thanks. In
          Message 4 of 7 , Jul 30, 2014
            Comment #2 on issue 243 by timothy....@...: Regex matching
            behaviour has changed in 7.4
            http://code.google.com/p/vim/issues/detail?id=243

            Thanks. In future, should regexs be re-ordered such that backreferences
            always come after capture groups?

            --
            You received this message because this project is configured to send all
            issue notifications to this address.
            You may adjust your notification preferences at:
            https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • vim@...
            Comment #3 on issue 243 by barry.ar...@gmail.com: Regex matching behaviour has changed in 7.4 http://code.google.com/p/vim/issues/detail?id=243 I based that
            Message 5 of 7 , Jul 30, 2014
              Comment #3 on issue 243 by barry.ar...@...: Regex matching behaviour
              has changed in 7.4
              http://code.google.com/p/vim/issues/detail?id=243

              I based that regex on the information in :help /\@<= and the example:

              \1\@<=,\([a-z]\+\) ",abc" in "abc,abc"

              When it worked, I accepted it and moved on. :-)

              --
              You received this message because this project is configured to send all
              issue notifications to this address.
              You may adjust your notification preferences at:
              https://code.google.com/hosting/settings

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • vim@...
              Comment #4 on issue 243 by brammool...@gmail.com: Regex matching behaviour has changed in 7.4 http://code.google.com/p/vim/issues/detail?id=243 Thanks for the
              Message 6 of 7 , Jul 30, 2014
                Comment #4 on issue 243 by brammool...@...: Regex matching behaviour
                has changed in 7.4
                http://code.google.com/p/vim/issues/detail?id=243

                Thanks for the pointer to the help. I will add a note there that this only
                works with the old regexp engine, and show how to do it with \zs instead.

                --
                You received this message because this project is configured to send all
                issue notifications to this address.
                You may adjust your notification preferences at:
                https://code.google.com/hosting/settings

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • vim@...
                Comment #5 on issue 243 by barry.ar...@gmail.com: Regex matching behaviour has changed in 7.4 http://code.google.com/p/vim/issues/detail?id=243 Thanks for the
                Message 7 of 7 , Jul 30, 2014
                  Comment #5 on issue 243 by barry.ar...@...: Regex matching behaviour
                  has changed in 7.4
                  http://code.google.com/p/vim/issues/detail?id=243

                  Thanks for the \zs\ze version. I have added that to VimRegexTutor.

                  --
                  You received this message because this project is configured to send all
                  issue notifications to this address.
                  You may adjust your notification preferences at:
                  https://code.google.com/hosting/settings

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                Your message has been successfully submitted and would be delivered to recipients shortly.