Loading ...
Sorry, an error occurred while loading the content.

incorrect rendering with 'nolist' setting

Expand Messages
  • Kent Sibilev
    I ve found that some C code is incorrectly rendered when I use nolist option. In the attached file, lines 6-7 are incorrectly shifted to the right and when I
    Message 1 of 9 , Jul 29, 2014
    • 0 Attachment
      I've found that some C code is incorrectly rendered when I use 'nolist' option.

      In the attached file, lines 6-7 are incorrectly shifted to the right and when I press '$' the cursor doesn't move all the way to the end of the text.

      I wonder if it is something related to my environment or can be reproduced by others?

      Kent.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Kent Sibilev
      ... Just a bit of information. This problem is related to linebreak setting. If I set nolinebreak, the problem disappears. Kent. -- -- You received this
      Message 2 of 9 , Jul 29, 2014
      • 0 Attachment
        On Tuesday, July 29, 2014 11:12:05 AM UTC-4, Kent Sibilev wrote:
        > I've found that some C code is incorrectly rendered when I use 'nolist' option.
        >
        > In the attached file, lines 6-7 are incorrectly shifted to the right and when I press '$' the cursor doesn't move all the way to the end of the text.
        >
        > I wonder if it is something related to my environment or can be reproduced by others?
        >
        > Kent.

        Just a bit of information. This problem is related to 'linebreak' setting. If I set nolinebreak, the problem disappears.

        Kent.

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • John Little
        ... Yes, I see it. 7.4.383. The problem is not seen with 7.4.0, and not with -u NONE -N. I will try later to bisect my .vimrc to find minimal settings that
        Message 3 of 9 , Jul 30, 2014
        • 0 Attachment
          On Wednesday, July 30, 2014 3:12:05 AM UTC+12, Kent Sibilev wrote:
          > I've found that some C code is incorrectly rendered when I use 'nolist' option.

          Yes, I see it. 7.4.383. The problem is not seen with 7.4.0, and not with -u NONE -N. I will try later to bisect my .vimrc to find minimal settings that show the problem.

          Regards, John Little

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • John Little
          ... Tricky. vim -u NONE -c set lbr lcs=tab: ¶ t.c Note the second character in the tab string setting has to be not ASCII. If the character s codepoint
          Message 4 of 9 , Jul 30, 2014
          • 0 Attachment
            > On Wednesday, July 30, 2014 3:12:05 AM UTC+12, Kent Sibilev wrote:
            > > I've found that some C code is incorrectly rendered when I use 'nolist' option.
            >
            I replied:
            > Yes, I see it. 7.4.383. The problem is not seen with 7.4.0, and not with -u NONE -N. I will try later to bisect my .vimrc to find minimal settings ...

            Tricky.

            vim -u NONE -c "set lbr lcs=tab:>¶" t.c

            Note the second character in the tab "string setting" has to be not ASCII. If the character's codepoint fits in one byte, the lines in t.c are indented 7 extra spaces; if in two, 14 extra spaces, f.ex.

            vim -u NONE -c "set lbr lcs=tab:>‖" t.c

            Of course, the setting of listchars shouldn't be relevant with :set nolist.

            Regards, John Little

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Bram Moolenaar
            ... I cannot reprocuce it... -- Team-building exercises come in many forms but they all trace their roots back to the prison system. In your typical
            Message 5 of 9 , Jul 30, 2014
            • 0 Attachment
              John Little wrote:

              > > On Wednesday, July 30, 2014 3:12:05 AM UTC+12, Kent Sibilev wrote:
              > > > I've found that some C code is incorrectly rendered when I use 'nolist' option.
              > >
              > I replied:
              > > Yes, I see it. 7.4.383. The problem is not seen with 7.4.0, and not with -u NONE -N. I will try later to bisect my .vimrc to find minimal settings ...
              >
              > Tricky.
              >
              > vim -u NONE -c "set lbr lcs=tab:>¶" t.c
              >
              > Note the second character in the tab "string setting" has to be not ASCII. If the character's codepoint fits in one byte, the lines in t.c are indented 7 extra spaces; if in two, 14 extra spaces, f.ex.
              >
              > vim -u NONE -c "set lbr lcs=tab:>‖" t.c
              >
              > Of course, the setting of listchars shouldn't be relevant with :set nolist.

              I cannot reprocuce it...

              --
              Team-building exercises come in many forms but they all trace their roots back
              to the prison system. In your typical team-building exercise the employees
              are subjected to a variety of unpleasant situations until they become either a
              cohesive team or a ring of car jackers.
              (Scott Adams - The Dilbert principle)

              /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
              /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
              \\\ an exciting new programming language -- http://www.Zimbu.org ///
              \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Christian Brabandt
              Hi John! ... Probably 7.4.353 which changed the way list and linebreak worked together. I couldn t however reproduce it. I ll look into it. Best, Christian
              Message 6 of 9 , Jul 30, 2014
              • 0 Attachment
                Hi John!

                On Mi, 30 Jul 2014, John Little wrote:

                > On Wednesday, July 30, 2014 3:12:05 AM UTC+12, Kent Sibilev wrote:
                > > I've found that some C code is incorrectly rendered when I use 'nolist' option.
                >
                > Yes, I see it. 7.4.383. The problem is not seen with 7.4.0, and not with -u NONE -N. I will try later to bisect my .vimrc to find minimal settings that show the problem.

                Probably 7.4.353 which changed the way 'list' and 'linebreak' worked
                together. I couldn't however reproduce it. I'll look into it.

                Best,
                Christian
                --
                Wir müssen nicht nur arbeiten, sondern auch träumen, nicht nur
                handeln, sondern auch glauben.
                -- Anatole France

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • Christian Brabandt
                ... Attached patch fixes it for me and includes a test. I am not entirely sure, why I put the test for linebreak in there at all, but without it,
                Message 7 of 9 , Jul 30, 2014
                • 0 Attachment
                  On Mi, 30 Jul 2014, Christian Brabandt wrote:

                  > Hi John!
                  >
                  > On Mi, 30 Jul 2014, John Little wrote:
                  >
                  > > On Wednesday, July 30, 2014 3:12:05 AM UTC+12, Kent Sibilev wrote:
                  > > > I've found that some C code is incorrectly rendered when I use 'nolist' option.
                  > >
                  > > Yes, I see it. 7.4.383. The problem is not seen with 7.4.0, and not with -u NONE -N. I will try later to bisect my .vimrc to find minimal settings that show the problem.
                  >
                  > Probably 7.4.353 which changed the way 'list' and 'linebreak' worked
                  > together. I couldn't however reproduce it. I'll look into it.

                  Attached patch fixes it for me and includes a test.

                  I am not entirely sure, why I put the test for linebreak in there at
                  all, but without it, test_listlbr_utf8 fails, so it should probably
                  stay.

                  Best,
                  Christian
                  --
                  Jemanden zu sagen Idiot - das ist keine Beleidigung, sondern Diagnose.
                  -- Julian Tuwim

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                • Bram Moolenaar
                  ... Thanks. I verified the test fails before including the fix. -- At some point in the project somebody will start whining about the need to determine the
                  Message 8 of 9 , Jul 30, 2014
                  • 0 Attachment
                    Christian wrote:

                    > > Hi John!
                    > >
                    > > On Mi, 30 Jul 2014, John Little wrote:
                    > >
                    > > > On Wednesday, July 30, 2014 3:12:05 AM UTC+12, Kent Sibilev wrote:
                    > > > > I've found that some C code is incorrectly rendered when I use 'nolist' option.
                    > > >
                    > > > Yes, I see it. 7.4.383. The problem is not seen with 7.4.0, and not with -u NONE -N. I will try later to bisect my .vimrc to find minimal settings that show the problem.
                    > >
                    > > Probably 7.4.353 which changed the way 'list' and 'linebreak' worked
                    > > together. I couldn't however reproduce it. I'll look into it.
                    >
                    > Attached patch fixes it for me and includes a test.
                    >
                    > I am not entirely sure, why I put the test for linebreak in there at
                    > all, but without it, test_listlbr_utf8 fails, so it should probably
                    > stay.

                    Thanks. I verified the test fails before including the fix.

                    --
                    At some point in the project somebody will start whining about the need to
                    determine the project "requirements". This involves interviewing people who
                    don't know what they want but, curiously, know exactly when they need it.
                    (Scott Adams - The Dilbert principle)

                    /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                    /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                    \\\ an exciting new programming language -- http://www.Zimbu.org ///
                    \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/d/optout.
                  • Kent Sibilev
                    ... Thanks everyone. The patch 7.4.388 has fixed the problem. -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply
                    Message 9 of 9 , Jul 30, 2014
                    • 0 Attachment
                      On Wednesday, July 30, 2014 10:44:37 AM UTC-4, Bram Moolenaar wrote:
                      > Christian wrote:
                      >
                      >
                      >
                      > > > Hi John!
                      >
                      > > >
                      >
                      > > > On Mi, 30 Jul 2014, John Little wrote:
                      >
                      > > >
                      >
                      > > > > On Wednesday, July 30, 2014 3:12:05 AM UTC+12, Kent Sibilev wrote:
                      >
                      > > > > > I've found that some C code is incorrectly rendered when I use 'nolist' option.
                      >
                      > > > >
                      >
                      > > > > Yes, I see it. 7.4.383. The problem is not seen with 7.4.0, and not with -u NONE -N. I will try later to bisect my .vimrc to find minimal settings that show the problem.
                      >
                      > > >
                      >
                      > > > Probably 7.4.353 which changed the way 'list' and 'linebreak' worked
                      >
                      > > > together. I couldn't however reproduce it. I'll look into it.
                      >
                      > >
                      >
                      > > Attached patch fixes it for me and includes a test.
                      >
                      > >
                      >
                      > > I am not entirely sure, why I put the test for linebreak in there at
                      >
                      > > all, but without it, test_listlbr_utf8 fails, so it should probably
                      >
                      > > stay.
                      >
                      >
                      >
                      > Thanks. I verified the test fails before including the fix.
                      >
                      >


                      Thanks everyone. The patch 7.4.388 has fixed the problem.

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/d/optout.
                    Your message has been successfully submitted and would be delivered to recipients shortly.