Loading ...
Sorry, an error occurred while loading the content.

r in normal mode (= replace single character) does not respect insert mode mappings

Expand Messages
  • Enno
    Is this a feature or a bug? This occurs under a Vanilla gVim 7.4.326 under Windows 7 x64, or a Vanilla Vim 7.4.326 under CygWin. To reproduce: Start vim. Type
    Message 1 of 6 , Jun 29, 2014
    • 0 Attachment
      Is this a feature or a bug? This occurs under a Vanilla gVim 7.4.326 under Windows 7 x64, or a Vanilla Vim 7.4.326 under CygWin.

      To reproduce:

      Start vim. Type 'x', then type

      :inoremap ; /<CR>

      then type

      r;

      Expected: The buffer contains the single character '/'.
      What we got: The buffer contains the single character ';'.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Enno
      ... It should say: Start vim. Type ix ... -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you
      Message 2 of 6 , Jun 29, 2014
      • 0 Attachment
        Le dimanche 29 juin 2014 13:26:37 UTC+2, Enno a écrit :
        > Is this a feature or a bug? This occurs under a Vanilla gVim 7.4.326 under Windows 7 x64, or a Vanilla Vim 7.4.326 under CygWin.
        >
        > To reproduce:
        >
        > Start vim. Type 'x', then type
        >
        > :inoremap ; /<CR>
        >
        > then type
        >
        > r;
        >
        > Expected: The buffer contains the single character '/'.
        > What we got: The buffer contains the single character ';'.

        It should say: Start vim. Type ix<ESC>...

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Павлов Николай Алекса
        ... Hash: SHA512 ... Version: APG v1.1.1 iQI1BAEBCgAfBQJTsNQfGBxaeVggPHp5eC52aW1AZ21haWwuY29tPgAKCRCf3UKj
        Message 3 of 6 , Jun 29, 2014
        • 0 Attachment
          -----BEGIN PGP SIGNED MESSAGE-----
          Hash: SHA512

          :lmap mappings apply to r if &iminsert is set as documented. Documentation does not say about :imap mappings. I do not think it is a bug.

          On June 29, 2014 3:26:37 PM GMT+03:00, Enno <enno.nagel@...> wrote:
          >Is this a feature or a bug? This occurs under a Vanilla gVim 7.4.326
          >under Windows 7 x64, or a Vanilla Vim 7.4.326 under CygWin.
          >
          >To reproduce:
          >
          >Start vim. Type 'x', then type
          >
          >:inoremap ; /<CR>
          >
          >then type
          >
          >r;
          >
          >Expected: The buffer contains the single character '/'.
          >What we got: The buffer contains the single character ';'.
          >
          >--
          >--
          >You received this message from the "vim_dev" maillist.
          >Do not top-post! Type your reply below the text you are replying to.
          >For more information, visit http://www.vim.org/maillist.php
          >
          >---
          >You received this message because you are subscribed to the Google
          >Groups "vim_dev" group.
          >To unsubscribe from this group and stop receiving emails from it, send
          >an email to vim_dev+unsubscribe@....
          >For more options, visit https://groups.google.com/d/optout.
          -----BEGIN PGP SIGNATURE-----
          Version: APG v1.1.1

          iQI1BAEBCgAfBQJTsNQfGBxaeVggPHp5eC52aW1AZ21haWwuY29tPgAKCRCf3UKj
          HhHSvlRgD/0cVe8nUK6aqsrcJ6ca6rdmxbUNbtgSPHfT4MmprW4ktmKquB7UmRaW
          FBGzmbvoHxPT2lnATxwUwosTjevh2IVQjNsKL/RPKkr68Iqc9nRghQhsf1+al/SZ
          AF3A2K9ZXf+mFJYUTNQOViysQ6TtVqpNareVYnAoa9f1VRpfSx1Nvj8L87TrW7i5
          PddRf6L1iF1L2UEmHLzi5Qqk+cPVVPqIjvWI8azILMYKb7HgIcSl1s3/KS7W8YXG
          pvunuqHPYFVF5GxtM4LIYUxUFTshM9n8ITXpq4idnIHU9W6r3rq5Ojj57YZNbOry
          eFZ//AabEihOj+zdkjEvsPO1Mdl8L1hDmeKAGx8hWO12W3L6Co6RuzE5CYLr4yHP
          wo/g3gLU4A/U694fR/M7TZuZsFlQtPw7gztkcz0gJlyBjFGG79fae0Rx+KfgoVN3
          flqZNDnh8VmZFJ4DDRkYpAAj9ka/3I1Hyo4HU8KNuYdVrwzpt0bK4uhzsxXQK32D
          TzgWFWeXIM97O1W4o1TMPyH9SXXQrNcvA9mgYKsVYp7F4aBaUvrx/uEXkrTnScyw
          Ldp49DwYNM8sZx4ASjZD4EgoFSpdzZSCc7IGii/No5ONpzoJfao3Jyk6tdZGLro5
          LqTXT2MrqJTZx7KC5krqTU7v+O+Jd9rCjnQPjYAAGupYi7nuS4MT/Q==
          =UVDx
          -----END PGP SIGNATURE-----

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Enno
          ... Thank you for the hint to &iminsert. This brought me to the Lang-Arg mode (comprising the command line and insert mode). Now I suspected that lnoremap ;
          Message 4 of 6 , Jun 30, 2014
          • 0 Attachment
            Le lundi 30 juin 2014 05:06:27 UTC+2, ZyX a écrit :
            > -----BEGIN PGP SIGNED MESSAGE-----
            >
            > Hash: SHA512
            >
            >
            >
            > :lmap mappings apply to r if &iminsert is set as documented. Documentation does not say about :imap mappings. I do not think it is a bug.
            >
            >
            >
            > On June 29, 2014 3:26:37 PM GMT+03:00, Enno <enno.nagel@...> wrote:
            >
            > >Is this a feature or a bug? This occurs under a Vanilla gVim 7.4.326
            >
            > >under Windows 7 x64, or a Vanilla Vim 7.4.326 under CygWin.
            >
            > >
            >
            > >To reproduce:
            >
            > >
            >
            > >Start vim. Type 'x', then type
            >
            > >
            >
            > >:inoremap ; /<CR>
            >
            > >
            >
            > >then type
            >
            > >
            >
            > >r;
            >
            > >
            >
            > >Expected: The buffer contains the single character '/'.
            >
            > >What we got: The buffer contains the single character ';'.
            >
            > >
            >
            > >--
            >
            > >--
            >
            > >You received this message from the "vim_dev" maillist.
            >
            > >Do not top-post! Type your reply below the text you are replying to.
            >
            > >For more information, visit http://www.vim.org/maillist.php
            >
            > >
            >
            > >---
            >
            > >You received this message because you are subscribed to the Google
            >
            > >Groups "vim_dev" group.
            >
            > >To unsubscribe from this group and stop receiving emails from it, send
            >
            > >an email to vim_dev+unsubscribe@....
            >
            > >For more options, visit https://groups.google.com/d/optout.
            >
            > -----BEGIN PGP SIGNATURE-----
            >
            > Version: APG v1.1.1
            >
            >
            >
            > iQI1BAEBCgAfBQJTsNQfGBxaeVggPHp5eC52aW1AZ21haWwuY29tPgAKCRCf3UKj
            >
            > HhHSvlRgD/0cVe8nUK6aqsrcJ6ca6rdmxbUNbtgSPHfT4MmprW4ktmKquB7UmRaW
            >
            > FBGzmbvoHxPT2lnATxwUwosTjevh2IVQjNsKL/RPKkr68Iqc9nRghQhsf1+al/SZ
            >
            > AF3A2K9ZXf+mFJYUTNQOViysQ6TtVqpNareVYnAoa9f1VRpfSx1Nvj8L87TrW7i5
            >
            > PddRf6L1iF1L2UEmHLzi5Qqk+cPVVPqIjvWI8azILMYKb7HgIcSl1s3/KS7W8YXG
            >
            > pvunuqHPYFVF5GxtM4LIYUxUFTshM9n8ITXpq4idnIHU9W6r3rq5Ojj57YZNbOry
            >
            > eFZ//AabEihOj+zdkjEvsPO1Mdl8L1hDmeKAGx8hWO12W3L6Co6RuzE5CYLr4yHP
            >
            > wo/g3gLU4A/U694fR/M7TZuZsFlQtPw7gztkcz0gJlyBjFGG79fae0Rx+KfgoVN3
            >
            > flqZNDnh8VmZFJ4DDRkYpAAj9ka/3I1Hyo4HU8KNuYdVrwzpt0bK4uhzsxXQK32D
            >
            > TzgWFWeXIM97O1W4o1TMPyH9SXXQrNcvA9mgYKsVYp7F4aBaUvrx/uEXkrTnScyw
            >
            > Ldp49DwYNM8sZx4ASjZD4EgoFSpdzZSCc7IGii/No5ONpzoJfao3Jyk6tdZGLro5
            >
            > LqTXT2MrqJTZx7KC5krqTU7v+O+Jd9rCjnQPjYAAGupYi7nuS4MT/Q==
            >
            > =UVDx
            >
            > -----END PGP SIGNATURE-----

            Thank you for the hint to &iminsert. This brought me to the Lang-Arg mode (comprising the command line and insert mode).

            Now I suspected that 'lnoremap ; \' instead of 'inoremap ; \' would achieve the desired behavior, but it does not change anything. Does &iminsert need to be set to make lnoremap work, too?

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Павлов Николай Алекса
            ... Hash: SHA512 You should read documentation. I do not use this feature, only know that it exists. ... Version: APG v1.1.1
            Message 5 of 6 , Jun 30, 2014
            • 0 Attachment
              -----BEGIN PGP SIGNED MESSAGE-----
              Hash: SHA512

              You should read documentation. I do not use this feature, only know that it exists.

              On June 30, 2014 5:26:06 PM GMT+03:00, Enno <enno.nagel@...> wrote:
              >Le lundi 30 juin 2014 05:06:27 UTC+2, ZyX a écrit :
              >> -----BEGIN PGP SIGNED MESSAGE-----
              >>
              >> Hash: SHA512
              >>
              >>
              >>
              >> :lmap mappings apply to r if &iminsert is set as documented.
              >Documentation does not say about :imap mappings. I do not think it is a
              >bug.
              >>
              >>
              >>
              >> On June 29, 2014 3:26:37 PM GMT+03:00, Enno <enno.nagel@...>
              >wrote:
              >>
              >> >Is this a feature or a bug? This occurs under a Vanilla gVim 7.4.326
              >>
              >> >under Windows 7 x64, or a Vanilla Vim 7.4.326 under CygWin.
              >>
              >> >
              >>
              >> >To reproduce:
              >>
              >> >
              >>
              >> >Start vim. Type 'x', then type
              >>
              >> >
              >>
              >> >:inoremap ; /<CR>
              >>
              >> >
              >>
              >> >then type
              >>
              >> >
              >>
              >> >r;
              >>
              >> >
              >>
              >> >Expected: The buffer contains the single character '/'.
              >>
              >> >What we got: The buffer contains the single character ';'.
              >>
              >> >
              >>
              >> >--
              >>
              >> >--
              >>
              >> >You received this message from the "vim_dev" maillist.
              >>
              >> >Do not top-post! Type your reply below the text you are replying to.
              >>
              >> >For more information, visit http://www.vim.org/maillist.php
              >>
              >> >
              >>
              >> >---
              >>
              >> >You received this message because you are subscribed to the Google
              >>
              >> >Groups "vim_dev" group.
              >>
              >> >To unsubscribe from this group and stop receiving emails from it,
              >send
              >>
              >> >an email to vim_dev+unsubscribe@....
              >>
              >> >For more options, visit https://groups.google.com/d/optout.
              >>
              >> -----BEGIN PGP SIGNATURE-----
              >>
              >> Version: APG v1.1.1
              >>
              >>
              >>
              >> iQI1BAEBCgAfBQJTsNQfGBxaeVggPHp5eC52aW1AZ21haWwuY29tPgAKCRCf3UKj
              >>
              >> HhHSvlRgD/0cVe8nUK6aqsrcJ6ca6rdmxbUNbtgSPHfT4MmprW4ktmKquB7UmRaW
              >>
              >> FBGzmbvoHxPT2lnATxwUwosTjevh2IVQjNsKL/RPKkr68Iqc9nRghQhsf1+al/SZ
              >>
              >> AF3A2K9ZXf+mFJYUTNQOViysQ6TtVqpNareVYnAoa9f1VRpfSx1Nvj8L87TrW7i5
              >>
              >> PddRf6L1iF1L2UEmHLzi5Qqk+cPVVPqIjvWI8azILMYKb7HgIcSl1s3/KS7W8YXG
              >>
              >> pvunuqHPYFVF5GxtM4LIYUxUFTshM9n8ITXpq4idnIHU9W6r3rq5Ojj57YZNbOry
              >>
              >> eFZ//AabEihOj+zdkjEvsPO1Mdl8L1hDmeKAGx8hWO12W3L6Co6RuzE5CYLr4yHP
              >>
              >> wo/g3gLU4A/U694fR/M7TZuZsFlQtPw7gztkcz0gJlyBjFGG79fae0Rx+KfgoVN3
              >>
              >> flqZNDnh8VmZFJ4DDRkYpAAj9ka/3I1Hyo4HU8KNuYdVrwzpt0bK4uhzsxXQK32D
              >>
              >> TzgWFWeXIM97O1W4o1TMPyH9SXXQrNcvA9mgYKsVYp7F4aBaUvrx/uEXkrTnScyw
              >>
              >> Ldp49DwYNM8sZx4ASjZD4EgoFSpdzZSCc7IGii/No5ONpzoJfao3Jyk6tdZGLro5
              >>
              >> LqTXT2MrqJTZx7KC5krqTU7v+O+Jd9rCjnQPjYAAGupYi7nuS4MT/Q==
              >>
              >> =UVDx
              >>
              >> -----END PGP SIGNATURE-----
              >
              >Thank you for the hint to &iminsert. This brought me to the Lang-Arg
              >mode (comprising the command line and insert mode).
              >
              >Now I suspected that 'lnoremap ; \' instead of 'inoremap ; \' would
              >achieve the desired behavior, but it does not change anything. Does
              >&iminsert need to be set to make lnoremap work, too?
              >
              >--
              >--
              >You received this message from the "vim_dev" maillist.
              >Do not top-post! Type your reply below the text you are replying to.
              >For more information, visit http://www.vim.org/maillist.php
              >
              >---
              >You received this message because you are subscribed to the Google
              >Groups "vim_dev" group.
              >To unsubscribe from this group and stop receiving emails from it, send
              >an email to vim_dev+unsubscribe@....
              >For more options, visit https://groups.google.com/d/optout.
              -----BEGIN PGP SIGNATURE-----
              Version: APG v1.1.1

              iQI1BAEBCgAfBQJTsY5YGBxaeVggPHp5eC52aW1AZ21haWwuY29tPgAKCRCf3UKj
              HhHSvlPtD/9sjEq1agRstFHJacjT+1uxUZjwbN2moszOA4EwOxAXLgTFXR+CMIHc
              Tk8H/C0FDu4gSLNYVorh43xrjslQHX9pSAgrQEYf9noYcfbfv0ZO0nmJ3MMke6oE
              DeLwaUnjyKCd1bHqXVJoDCoWapNinSnvZK0H4/XqfWevHYSE42g95QyR6KSMFgS7
              BwWKS4bAF6SF6/TPcAOFTOiurgibGxZrRVRmlnKDMfCmvUV11A3RBAdvo1WwZtqS
              SXUQAGF9QihnuxNyu+btTIB5bYEGKghZrmNEf48dWl5QcQUCLJDoeNxsHu6FImZA
              dJEfKIVNiF+zmptr5wICdNeN6at83+li8NE3bNcXgSRSRIZFHKjTtcyO/46WQTJw
              SySDruj1Ud/gjjuu3qj+ZSq9m+YTYZ40bgLE69tDF/xMU1jB5lK+5hYuHlLK0Inl
              uzpdbH9cZO+iCITlEH3WeJ1TgaeHqJmMvGTh8U/BkLWJKNfudaU/9PK0nEWU97Y4
              4+lcs+R8ntFgaexQiW44Cxwrjh3SoEz704vOHhv3beFkzplCXFJB5KCpPjmbJpLZ
              t7zHy7cs3rCbUZPR7rSOBzQJx4xkajtJIsVJ4DJas0CzGU/7igy/Q5tm29G6B+tK
              ump5bzeATWf8FjKziwrPJXkjuR9G4dmg26hSoZm3k2h6IrOise6Dfw==
              =L8kk
              -----END PGP SIGNATURE-----

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Christian Brabandt
              ... Use R Best, Christian -- Diskussionen haben lediglich einen Wert, daß einem gute Gedanken hinterher einfallen. -- Charles-Louis de Montesquieu -- -- You
              Message 6 of 6 , Jun 30, 2014
              • 0 Attachment
                On So, 29 Jun 2014, Enno wrote:

                > Is this a feature or a bug? This occurs under a Vanilla gVim 7.4.326 under Windows 7 x64, or a Vanilla Vim 7.4.326 under CygWin.
                >
                > To reproduce:
                >
                > Start vim. Type 'x', then type
                >
                > :inoremap ; /<CR>
                >
                > then type
                >
                > r;
                >
                > Expected: The buffer contains the single character '/'.
                > What we got: The buffer contains the single character ';'.

                Use R

                Best,
                Christian
                --
                Diskussionen haben lediglich einen Wert, daß einem gute Gedanken
                hinterher einfallen.
                -- Charles-Louis de Montesquieu

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              Your message has been successfully submitted and would be delivered to recipients shortly.