Loading ...
Sorry, an error occurred while loading the content.

Compile error in Vim 7.4.324 on Solaris

Expand Messages
  • Benjamin Fritz
    I get this error from both make and make install when building on Solaris: Processing file zh_CN.cp936.po ... ERROR: Line 2899 (zh_CN.cp936.po): Invalid
    Message 1 of 6 , Jun 16, 2014
    • 0 Attachment
      I get this error from both "make" and "make install" when building on Solaris:

      Processing file "zh_CN.cp936.po"...
      ERROR: Line 2899 (zh_CN.cp936.po): Invalid character found.
      *** Error code 2
      make: Fatal error: Command failed for target `zh_CN.cp936.mo'

      I did notice a few warnings earlier in "make" about not being able to
      convert between encodings for some other language files.

      I seem to be able to use Vim fine even after the "make install" had
      this error, but I'm just using the English-language version.

      I do see that the $(GUI_BUNDLE) build target is after languages in the
      makefile, so I'm a little worried I might be missing something and I
      just haven't noticed yet.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Danek Duvall
      ... This has been the case since 7.4.296. As of 7.4.322, you can work around it with GNU msgfmt, by putting MSGFMT=gmsgfmt in the environment when running
      Message 2 of 6 , Jun 16, 2014
      • 0 Attachment
        On Mon, Jun 16, 2014 at 10:35:37AM -0500, Benjamin Fritz wrote:

        > I get this error from both "make" and "make install" when building on Solaris:
        >
        > Processing file "zh_CN.cp936.po"...
        > ERROR: Line 2899 (zh_CN.cp936.po): Invalid character found.
        > *** Error code 2
        > make: Fatal error: Command failed for target `zh_CN.cp936.mo'

        This has been the case since 7.4.296. As of 7.4.322, you can work around
        it with GNU msgfmt, by putting MSGFMT=gmsgfmt in the environment when
        running configure, assuming you have GNU gettext (text/gnu-gettext on S11
        or later) installed. Or just make sure that the first "msgfmt" in your
        $PATH is GNU.

        Danek

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Ben Fritz
        ... Thanks, that got me further. But the build still fails: OLD_PO_FILE_INPUT=yes gmsgfmt -v -o pl.mo pl.po headerfield `Language-Team missing in header found
        Message 3 of 6 , Jun 17, 2014
        • 0 Attachment
          On Monday, June 16, 2014 11:12:11 AM UTC-5, Danek Duvall wrote:
          > On Mon, Jun 16, 2014 at 10:35:37AM -0500, Benjamin Fritz wrote:
          >
          >
          >
          > > I get this error from both "make" and "make install" when building on Solaris:
          >
          > >
          >
          > > Processing file "zh_CN.cp936.po"...
          >
          > > ERROR: Line 2899 (zh_CN.cp936.po): Invalid character found.
          >
          > > *** Error code 2
          >
          > > make: Fatal error: Command failed for target `zh_CN.cp936.mo'
          >
          >
          >
          > This has been the case since 7.4.296. As of 7.4.322, you can work around
          >
          > it with GNU msgfmt, by putting MSGFMT=gmsgfmt in the environment when
          >
          > running configure, assuming you have GNU gettext (text/gnu-gettext on S11
          >
          > or later) installed. Or just make sure that the first "msgfmt" in your
          >
          > $PATH is GNU.
          >

          Thanks, that got me further. But the build still fails:

          OLD_PO_FILE_INPUT=yes gmsgfmt -v -o pl.mo pl.po
          headerfield `Language-Team' missing in header
          found 1 fatal errors
          *** Error code 1
          make: Fatal error: Command failed for target `pl.mo'

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Danek Duvall
          ... No idea; that doesn t happen for me. I m using GNU gettext 0.16.1, FWIW. Danek -- -- You received this message from the vim_dev maillist. Do not
          Message 4 of 6 , Jun 17, 2014
          • 0 Attachment
            Ben Fritz wrote:

            > Thanks, that got me further. But the build still fails:
            >
            > OLD_PO_FILE_INPUT=yes gmsgfmt -v -o pl.mo pl.po
            > headerfield `Language-Team' missing in header
            > found 1 fatal errors
            > *** Error code 1
            > make: Fatal error: Command failed for target `pl.mo'

            No idea; that doesn't happen for me. I'm using GNU gettext 0.16.1, FWIW.

            Danek

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Benjamin Fritz
            ... I can t tell what version of gettext I have, in /usr/bin/gettext, because it isn t respecting any of -v, --version, -h, or --help. I do have GNU gettext
            Message 5 of 6 , Jun 17, 2014
            • 0 Attachment
              On Tue, Jun 17, 2014 at 10:45 AM, Danek Duvall <duvall@...> wrote:
              > Ben Fritz wrote:
              >
              >> Thanks, that got me further. But the build still fails:
              >>
              >> OLD_PO_FILE_INPUT=yes gmsgfmt -v -o pl.mo pl.po
              >> headerfield `Language-Team' missing in header
              >> found 1 fatal errors
              >> *** Error code 1
              >> make: Fatal error: Command failed for target `pl.mo'
              >
              > No idea; that doesn't happen for me. I'm using GNU gettext 0.16.1, FWIW.
              >

              I can't tell what version of gettext I have, in /usr/bin/gettext,
              because it isn't respecting any of -v, --version, -h, or --help.

              I do have GNU gettext 0.10.35 as "ggettext" but I don't see a way to
              override gettext like you showed me with msgfmt.

              I looked into the configure script, and found the "--disable-nls"
              flag. I'm not sure what this does, but it seemed related to gettext,
              so I tried using it.

              The build and install both succeeded, and Vim seems to be working as I
              need it to.

              So what did I cripple by using "--disable-nls"? Did that just remove
              the translations or something?

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Danek Duvall
              ... Right; that s the Solaris version. ... You don t need to, you just need to override msgfmt with gmsgfmt, which you did. I m guessing that 0.10.35 is just
              Message 6 of 6 , Jun 17, 2014
              • 0 Attachment
                On Tue, Jun 17, 2014 at 12:34:25PM -0500, Benjamin Fritz wrote:

                > On Tue, Jun 17, 2014 at 10:45 AM, Danek Duvall <duvall@...> wrote:
                > > Ben Fritz wrote:
                > >
                > >> Thanks, that got me further. But the build still fails:
                > >>
                > >> OLD_PO_FILE_INPUT=yes gmsgfmt -v -o pl.mo pl.po
                > >> headerfield `Language-Team' missing in header
                > >> found 1 fatal errors
                > >> *** Error code 1
                > >> make: Fatal error: Command failed for target `pl.mo'
                > >
                > > No idea; that doesn't happen for me. I'm using GNU gettext 0.16.1, FWIW.
                > >
                >
                > I can't tell what version of gettext I have, in /usr/bin/gettext,
                > because it isn't respecting any of -v, --version, -h, or --help.

                Right; that's the Solaris version.

                > I do have GNU gettext 0.10.35 as "ggettext" but I don't see a way to
                > override gettext like you showed me with msgfmt.

                You don't need to, you just need to override msgfmt with gmsgfmt, which you
                did.

                I'm guessing that 0.10.35 is just too old, in which case you don't have any
                good options, with the Solaris version unable to handle the corrupt Chinese
                .po file and the GNU version unable to deal with the missing header in the
                Polish ones.

                You could either get a newer version of GNU gettext, edit the
                Polish .po files to add the header (any value ought to do), or edit the
                cp936 .po file to remove the bad bytes.

                > So what did I cripple by using "--disable-nls"? Did that just remove
                > the translations or something?

                That's what it's intended to do, yeah.

                Danek

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              Your message has been successfully submitted and would be delivered to recipients shortly.