Loading ...
Sorry, an error occurred while loading the content.

Setting wildignorecase does not ignore case when completing a file with :buffer on Xubuntu system

Expand Messages
  • Akshay H
    Hello, Recently I noticed that when I set wildignorecase , it does not ignore case when expanding a filename on a Xubuntu 12.04 system. (This is also
    Message 1 of 6 , May 30 7:57 PM
    • 0 Attachment
      Hello,

      Recently I noticed that when I set 'wildignorecase', it does not ignore case when expanding a filename on a Xubuntu 12.04 system. (This is also reproducible with Xubuntu 14.04)

      What I tried:

      1. touch ZoomTile.py archive.py
      2. vim -u NONE -N -c set\ wildignorecase
      3. :buffer z<TAB>

      After having pressed TAB after typing a lowercase 'z', it does not expand the filename to ZoomTile.py.

      However, doing the above steps on my OS X machine, it works as expected. Doing :buffer z<TAB> expands the filename to ZoomTile.py.

      Also, if I set 'fileignorecase' instead of 'wildignorecase' on my Xubuntu machine, it then expands the z to ZoomTile.py.

      Both my vim are vim 7.4.273, and both are compiled with the same options compiled (they both are HUGE versions with +wildignore)

      Is it possible I'm doing something wrong here? Why does setting 'wildignorecase' not ignore case only on my Xubuntu machine?

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Akshay H
      ... Sorry for a typo, #2 should say: vim -u NONE -N -c set wildignorecase *.py -- -- You received this message from the vim_dev maillist. Do not top-post!
      Message 2 of 6 , May 30 8:09 PM
      • 0 Attachment
        On Friday, May 30, 2014 7:57:55 PM UTC-7, Akshay H wrote:
        > Hello,
        >
        > Recently I noticed that when I set 'wildignorecase', it does not ignore case when expanding a filename on a Xubuntu 12.04 system. (This is also reproducible with Xubuntu 14.04)
        >
        > What I tried:
        >
        > 1. touch ZoomTile.py archive.py
        > 2. vim -u NONE -N -c set\ wildignorecase
        > 3. :buffer z<TAB>
        >
        > After having pressed TAB after typing a lowercase 'z', it does not expand the filename to ZoomTile.py.
        >
        > However, doing the above steps on my OS X machine, it works as expected. Doing :buffer z<TAB> expands the filename to ZoomTile.py.
        >
        > Also, if I set 'fileignorecase' instead of 'wildignorecase' on my Xubuntu machine, it then expands the z to ZoomTile.py.
        >
        > Both my vim are vim 7.4.273, and both are compiled with the same options compiled (they both are HUGE versions with +wildignore)
        >
        > Is it possible I'm doing something wrong here? Why does setting 'wildignorecase' not ignore case only on my Xubuntu machine?

        Sorry for a typo, #2 should say: vim -u NONE -N -c set\ wildignorecase *.py

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Bram Moolenaar
        ... buffers, try :ls! . Completion on :edit should work. -- A man is incomplete until he s married ... and then he s finished! /// Bram Moolenaar --
        Message 3 of 6 , May 31 4:43 AM
        • 0 Attachment
          Akshay wrote:

          > On Friday, May 30, 2014 7:57:55 PM UTC-7, Akshay H wrote:
          > > Hello,
          > >
          > > Recently I noticed that when I set 'wildignorecase', it does not ignore case when expanding a filename on a Xubuntu 12.04 system. (This is also reproducible with Xubuntu 14.04)
          > >
          > > What I tried:
          > >
          > > 1. touch ZoomTile.py archive.py
          > > 2. vim -u NONE -N -c set\ wildignorecase
          > > 3. :buffer z<TAB>
          > >
          > > After having pressed TAB after typing a lowercase 'z', it does not expand the filename to ZoomTile.py.
          > >
          > > However, doing the above steps on my OS X machine, it works as expected. Doing :buffer z<TAB> expands the filename to ZoomTile.py.
          > >
          > > Also, if I set 'fileignorecase' instead of 'wildignorecase' on my Xubuntu machine, it then expands the z to ZoomTile.py.
          > >
          > > Both my vim are vim 7.4.273, and both are compiled with the same options compiled (they both are HUGE versions with +wildignore)
          > >
          > > Is it possible I'm doing something wrong here? Why does setting 'wildignorecase' not ignore case only on my Xubuntu machine?
          >
          > Sorry for a typo, #2 should say: vim -u NONE -N -c set\ wildignorecase *.py

          :buffer will complete buffer names. In the example you haven't got any
          buffers, try ":ls!". Completion on :edit should work.

          --
          A man is incomplete until he's married ... and then he's finished!

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Akshay H
          Hi Bram, Opening vim with: vim -u NONE -N -c set wildignorecase *.py does open two buffers for me, the ones I touched earlier before opening vim. :ls! lists
          Message 4 of 6 , May 31 10:21 AM
          • 0 Attachment
            Hi Bram,

            Opening vim with:

            vim -u NONE -N -c set\ wildignorecase *.py

            does open two buffers for me, the ones I touched earlier before opening vim. :ls! lists two buffers for me: archive.py and zoomTile.py. If I'm on archive.py and then do :buffer z<Tab> Vim
            Does not autocomplete the file name to ZoomTile.py. It will only work if I do :buffer Z<tab> meaning it is not ignoring case even though wildignorecase is set. (':set wic?' says wildignorecase is on)

            This only happens when I'm on a Xubuntu system and not on my Mac OS X system so maybe someone running Xubuntu can give this a try?

            Thanks.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Bram Moolenaar
            ... OK, now I see the problem. On Mac case of files is (nearly) always ignored. It apperears that completion for :buf does not use wildignorecase . --
            Message 5 of 6 , May 31 2:07 PM
            • 0 Attachment
              Akshay H wrote:

              > Opening vim with:
              >
              > vim -u NONE -N -c set\ wildignorecase *.py
              >
              > does open two buffers for me, the ones I touched earlier before
              > opening vim. :ls! lists two buffers for me: archive.py and
              > zoomTile.py. If I'm on archive.py and then do :buffer z<Tab> Vim
              > Does not autocomplete the file name to ZoomTile.py. It will only work
              > if I do :buffer Z<tab> meaning it is not ignoring case even though
              > wildignorecase is set. (':set wic?' says wildignorecase is on)
              >
              > This only happens when I'm on a Xubuntu system and not on my Mac OS X
              > system so maybe someone running Xubuntu can give this a try?

              OK, now I see the problem. On Mac case of files is (nearly) always
              ignored. It apperears that completion for :buf does not use
              'wildignorecase'.

              --
              "After a few years of marriage a man can look right at a woman
              without seeing her and a woman can see right through a man
              without looking at him."
              - Helen Rowland

              /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
              /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
              \\\ an exciting new programming language -- http://www.Zimbu.org ///
              \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Akshay H
              ... Ah okay, yes I thought the problem must be because OS X defaults to a case insensitive (but case preserving) file system. Thanks for the help. Perhaps this
              Message 6 of 6 , May 31 3:53 PM
              • 0 Attachment
                On Saturday, May 31, 2014 2:07:40 PM UTC-7, Bram Moolenaar wrote:
                > Akshay H wrote:
                >
                >
                >
                > > Opening vim with:
                >
                > >
                >
                > > vim -u NONE -N -c set\ wildignorecase *.py
                >
                > >
                >
                > > does open two buffers for me, the ones I touched earlier before
                >
                > > opening vim. :ls! lists two buffers for me: archive.py and
                >
                > > zoomTile.py. If I'm on archive.py and then do :buffer z<Tab> Vim
                >
                > > Does not autocomplete the file name to ZoomTile.py. It will only work
                >
                > > if I do :buffer Z<tab> meaning it is not ignoring case even though
                >
                > > wildignorecase is set. (':set wic?' says wildignorecase is on)
                >
                > >
                >
                > > This only happens when I'm on a Xubuntu system and not on my Mac OS X
                >
                > > system so maybe someone running Xubuntu can give this a try?
                >
                >
                >
                > OK, now I see the problem. On Mac case of files is (nearly) always
                >
                > ignored. It apperears that completion for :buf does not use
                >
                > 'wildignorecase'.
                >
                >
                >
                > --
                >
                > "After a few years of marriage a man can look right at a woman
                >
                > without seeing her and a woman can see right through a man
                >
                > without looking at him."
                >
                > - Helen Rowland
                >
                >
                >
                > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                >
                > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                >
                > \\\ an exciting new programming language -- http://www.Zimbu.org ///
                >
                > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                Ah okay, yes I thought the problem must be because OS X defaults to a case insensitive (but case preserving) file system.

                Thanks for the help. Perhaps this can be mentioned in the help docs?

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              Your message has been successfully submitted and would be delivered to recipients shortly.