Loading ...
Sorry, an error occurred while loading the content.

[patch] The misreading of tabediting Session.vim

Expand Messages
  • Nobuhiro Takasaki
    Hi. I use a lot of mksession. I fixed an issue that occurs. Reproduce the problem: edit Makefile exe 10 normal! zt 20 tabnew tabnext 1 Open the Makefile, jump
    Message 1 of 4 , Apr 25, 2014
    • 0 Attachment
      Hi.

      I use a lot of mksession. I fixed an issue that occurs.
      Reproduce the problem:

      edit Makefile
      exe 10
      normal! zt
      20
      tabnew
      tabnext 1

      Open the Makefile, jump to line number 10,
      go to the top of the screen that line,
      line number 20 to move the cursor,
      open the tab, go back to the original screen.

      Scroll position will be shifted tabnew exists.
      The result is correct if there is no tabnew.

      I enclose a short patch.

      The world has chanded in Vim.
      Also my life.

      --------
      Thanks.
      Nobuhiro Takasaki

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Bram Moolenaar
      ... Thanks, I ll put it in the todo list. ... -- From know your smileys :
      Message 2 of 4 , Apr 25, 2014
      • 0 Attachment
        Nobuhiro Takasaki wrote:

        > I use a lot of mksession. I fixed an issue that occurs.
        > Reproduce the problem:
        >
        > edit Makefile
        > exe 10
        > normal! zt
        > 20
        > tabnew
        > tabnext 1
        >
        > Open the Makefile, jump to line number 10,
        > go to the top of the screen that line,
        > line number 20 to move the cursor,
        > open the tab, go back to the original screen.
        >
        > Scroll position will be shifted tabnew exists.
        > The result is correct if there is no tabnew.
        >
        > I enclose a short patch.

        Thanks, I'll put it in the todo list.

        > The world has chanded in Vim.
        > Also my life.

        --
        From "know your smileys":
        <<<:-{ Worf (Never smiles anyways, so he's a bad smiley)

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Bram Moolenaar
        ... I cannot reproduce this problem. You mention mksession, but the steps to reproduce the problem do not include a session. Please start with vim -u NONE
        Message 3 of 4 , Apr 29, 2014
        • 0 Attachment
          Nobuhiro Takasaki wrote:

          > I use a lot of mksession. I fixed an issue that occurs.
          > Reproduce the problem:
          >
          > edit Makefile
          > exe 10
          > normal! zt
          > 20
          > tabnew
          > tabnext 1
          >
          > Open the Makefile, jump to line number 10,
          > go to the top of the screen that line,
          > line number 20 to move the cursor,
          > open the tab, go back to the original screen.
          >
          > Scroll position will be shifted tabnew exists.
          > The result is correct if there is no tabnew.
          >
          > I enclose a short patch.

          I cannot reproduce this problem. You mention mksession, but the steps
          to reproduce the problem do not include a session.

          Please start with "vim -u NONE" so that none of your settings affect
          what happens.

          --
          From "know your smileys":
          :-| :-| Deja' vu!

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Nobuhiro Takasaki
          I have minimized the problem Session.vim out under me. I ve prepared a text file with line numbers here. Please do this operations: $ vim lines.txt ... 50j ...
          Message 4 of 4 , Apr 29, 2014
          • 0 Attachment
            I have minimized the problem Session.vim out under me.

            I've prepared a text file with line numbers here.

            Please do this operations:

            $ vim lines.txt
            :tabnew
            :tabnext 1
            50j
            :mksession!
            :qa
            $ vim -u NONE -S

            Line number 50 will be the top of the screen.
            Line number 01 at the top of the screen if there is no tabnew.

            It is difficult because I am using the tab copen.

            --------
            Thanks.
            Nobuhiro Takasaki

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          Your message has been successfully submitted and would be delivered to recipients shortly.