Loading ...
Sorry, an error occurred while loading the content.

Issue 221 in vim: Spelling not updated after 'spellfile' change

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 221 by walder...@gmx.net: Spelling not updated after spellfile change
    Message 1 of 3 , Apr 22 12:43 AM
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 221 by walder...@...: Spelling not updated after 'spellfile'
      change
      http://code.google.com/p/vim/issues/detail?id=221

      When activating 'spell' and afterwards updating 'spellfile', the content of
      the current screen is not updated. After updating the screen manually
      (using Ctrl+L), the newly added and/or removed words are highlighted
      correctly.

      I think it would make sense to automatically refresh the screen after the
      spellfile is updated, as it could always result in a change of the known
      words (except the changed spellfile is empty).

      I am currently working on Windows 7 64 bit, with the latest official gVim
      7.4 from 10th of August 2013.

      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • vim@...
      Comment #1 on issue 221 by chrisbr...@googlemail.com: Spelling not updated after spellfile change http://code.google.com/p/vim/issues/detail?id=221 Here is a
      Message 2 of 3 , Apr 30 7:41 AM
      • 0 Attachment
        Comment #1 on issue 221 by chrisbr...@...: Spelling not updated
        after 'spellfile' change
        http://code.google.com/p/vim/issues/detail?id=221

        Here is a patch:

        diff --git a/src/option.c b/src/option.c
        --- a/src/option.c
        +++ b/src/option.c
        @@ -6673,6 +6673,7 @@ did_set_string_option(opt_idx, varp, new
        if (wp->w_buffer == curbuf && wp->w_p_spell)
        {
        errmsg = did_set_spelllang(wp);
        + redraw_later(NOT_VALID);
        # ifdef FEAT_WINDOWS
        break;
        # endif


        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • vim@...
        Updates: Status: Fixed Comment #2 on issue 221 by chrisbr...@googlemail.com: Spelling not updated after spellfile change
        Message 3 of 3 , Oct 2, 2014
        • 0 Attachment
          Updates:
          Status: Fixed

          Comment #2 on issue 221 by chrisbr...@...: Spelling not updated
          after 'spellfile' change
          https://code.google.com/p/vim/issues/detail?id=221

          fixed by 7.4.288

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        Your message has been successfully submitted and would be delivered to recipients shortly.