Loading ...
Sorry, an error occurred while loading the content.

Bug for i_Ctrl-U

Expand Messages
  • Pine Wu
    Hello Vim devs: The online doc (7.3) says send bugs to bugs@vim.org , but in my vim 7.4 it says unless it s security issue just post it here. So here I am :-)
    Message 1 of 7 , Apr 20, 2014
    • 0 Attachment
      Hello Vim devs:
      The online doc (7.3) says "send bugs to bugs@...", but in my vim 7.4 it says unless it's security issue just post it here. So here I am :-)


      As for i_Ctrl-U, vim doc says:
      Delete all entered characters in the current line (see i_backspacing about joining lines).

      That is the case when you don't use arrow keys to move the cursor
      e.g.
      For a line:

      vim

      You type a, vim, Ctrl-U, what's left is

      vim

      That is what you'd expect, but
      If you type a, vim, <Left-Arrow>, the line would be

      vimvim

      Then Ctrl-U
      All text before cursor would be deleted, what's left is

      m

      I was expecting vim or vimm


      Best regards,
      Pine

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Christian Brabandt
      ... I was going to say, for me the first result wouldn t be expected. While the second one was. Turns out, I have mapped Ctrl-U to break the undo sequence (to
      Message 2 of 7 , Apr 23, 2014
      • 0 Attachment
        Am 2014-04-20 13:37, schrieb Pine Wu:
        > Hello Vim devs:
        > The online doc (7.3) says "send bugs to bugs@...", but in my vim
        > 7.4 it says unless it's security issue just post it here. So here I am
        > :-)
        >
        >
        > As for i_Ctrl-U, vim doc says:
        > Delete all entered characters in the current line (see i_backspacing
        > about joining lines).
        >
        > That is the case when you don't use arrow keys to move the cursor
        > e.g.
        > For a line:
        >
        > vim
        >
        > You type a, vim, Ctrl-U, what's left is
        >
        > vim
        >
        > That is what you'd expect, but
        > If you type a, vim, <Left-Arrow>, the line would be
        >
        > vimvim
        >
        > Then Ctrl-U
        > All text before cursor would be deleted, what's left is
        >
        > m
        >
        > I was expecting vim or vimm

        I was going to say, for me the first result wouldn't be expected. While
        the second one was.
        Turns out, I have mapped Ctrl-U to break the undo sequence (to be able
        to undo an accidental Ctrl-U)
        and this results in always deleting until the first column, and for the
        same reason, pressing
        arrow keys results in that unexpected manner.

        Turns out, because of patch 7.4.183, a fix is really simple, something
        like the attached patch.
        (I'll try to update that patch to include a test later today).

        Interestingly, this has gotten unnoticed for so long. It seems Ctrl-U in
        insert mode is
        just such an mysteric command, that one always expects it to be doing
        the wrong thing ;)

        Best,
        Christian

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Bram Moolenaar
        ... I also have trouble reproducing this. compatible matters. Anyway, can you please add some test for this to the patch? -- From know your smileys : O:-)
        Message 3 of 7 , Apr 23, 2014
        • 0 Attachment
          Christian Brabandt wrote:

          > Am 2014-04-20 13:37, schrieb Pine Wu:
          > > Hello Vim devs:
          > > The online doc (7.3) says "send bugs to bugs@...", but in my vim
          > > 7.4 it says unless it's security issue just post it here. So here I am
          > > :-)
          > >
          > >
          > > As for i_Ctrl-U, vim doc says:
          > > Delete all entered characters in the current line (see i_backspacing
          > > about joining lines).
          > >
          > > That is the case when you don't use arrow keys to move the cursor
          > > e.g.
          > > For a line:
          > >
          > > vim
          > >
          > > You type a, vim, Ctrl-U, what's left is
          > >
          > > vim
          > >
          > > That is what you'd expect, but
          > > If you type a, vim, <Left-Arrow>, the line would be
          > >
          > > vimvim
          > >
          > > Then Ctrl-U
          > > All text before cursor would be deleted, what's left is
          > >
          > > m
          > >
          > > I was expecting vim or vimm
          >
          > I was going to say, for me the first result wouldn't be expected. While
          > the second one was.
          > Turns out, I have mapped Ctrl-U to break the undo sequence (to be able
          > to undo an accidental Ctrl-U)
          > and this results in always deleting until the first column, and for the
          > same reason, pressing
          > arrow keys results in that unexpected manner.
          >
          > Turns out, because of patch 7.4.183, a fix is really simple, something
          > like the attached patch.
          > (I'll try to update that patch to include a test later today).
          >
          > Interestingly, this has gotten unnoticed for so long. It seems Ctrl-U
          > in insert mode is just such an mysteric command, that one always
          > expects it to be doing the wrong thing ;)

          I also have trouble reproducing this. 'compatible' matters.

          Anyway, can you please add some test for this to the patch?


          --
          From "know your smileys":
          O:-) Saint

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Christian Brabandt
          Hi Bram! ... Here we go. I added some more usage of i_Ctrl-U Best, Christian -- Fällt der Speicher aus dem Tower, sind die Daten nicht von Dauer. -- -- You
          Message 4 of 7 , Apr 23, 2014
          • 0 Attachment
            Hi Bram!

            On Mi, 23 Apr 2014, Bram Moolenaar wrote:

            >
            > Christian Brabandt wrote:
            >
            > > Am 2014-04-20 13:37, schrieb Pine Wu:
            > > > Hello Vim devs:
            > > > The online doc (7.3) says "send bugs to bugs@...", but in my vim
            > > > 7.4 it says unless it's security issue just post it here. So here I am
            > > > :-)
            > > >
            > > >
            > > > As for i_Ctrl-U, vim doc says:
            > > > Delete all entered characters in the current line (see i_backspacing
            > > > about joining lines).
            > > >
            > > > That is the case when you don't use arrow keys to move the cursor
            > > > e.g.
            > > > For a line:
            > > >
            > > > vim
            > > >
            > > > You type a, vim, Ctrl-U, what's left is
            > > >
            > > > vim
            > > >
            > > > That is what you'd expect, but
            > > > If you type a, vim, <Left-Arrow>, the line would be
            > > >
            > > > vimvim
            > > >
            > > > Then Ctrl-U
            > > > All text before cursor would be deleted, what's left is
            > > >
            > > > m
            > > >
            > > > I was expecting vim or vimm
            > >
            > > I was going to say, for me the first result wouldn't be expected. While
            > > the second one was.
            > > Turns out, I have mapped Ctrl-U to break the undo sequence (to be able
            > > to undo an accidental Ctrl-U)
            > > and this results in always deleting until the first column, and for the
            > > same reason, pressing
            > > arrow keys results in that unexpected manner.
            > >
            > > Turns out, because of patch 7.4.183, a fix is really simple, something
            > > like the attached patch.
            > > (I'll try to update that patch to include a test later today).
            > >
            > > Interestingly, this has gotten unnoticed for so long. It seems Ctrl-U
            > > in insert mode is just such an mysteric command, that one always
            > > expects it to be doing the wrong thing ;)
            >
            > I also have trouble reproducing this. 'compatible' matters.
            >
            > Anyway, can you please add some test for this to the patch?

            Here we go. I added some more usage of i_Ctrl-U

            Best,
            Christian
            --
            Fällt der Speicher aus dem Tower, sind die Daten nicht von Dauer.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Christian Brabandt
            ... I think, it is actually reasonable, to expect an attachment. So let s try that again. Best, Christian -- Es sind aber die Schmutzigsten, von denen man
            Message 5 of 7 , Apr 23, 2014
            • 0 Attachment
              On Mi, 23 Apr 2014, Christian Brabandt wrote:

              > Hi Bram!
              >
              > On Mi, 23 Apr 2014, Bram Moolenaar wrote:
              >
              > >
              > > Christian Brabandt wrote:
              > >
              > > > Am 2014-04-20 13:37, schrieb Pine Wu:
              > > > > Hello Vim devs:
              > > > > The online doc (7.3) says "send bugs to bugs@...", but in my vim
              > > > > 7.4 it says unless it's security issue just post it here. So here I am
              > > > > :-)
              > > > >
              > > > >
              > > > > As for i_Ctrl-U, vim doc says:
              > > > > Delete all entered characters in the current line (see i_backspacing
              > > > > about joining lines).
              > > > >
              > > > > That is the case when you don't use arrow keys to move the cursor
              > > > > e.g.
              > > > > For a line:
              > > > >
              > > > > vim
              > > > >
              > > > > You type a, vim, Ctrl-U, what's left is
              > > > >
              > > > > vim
              > > > >
              > > > > That is what you'd expect, but
              > > > > If you type a, vim, <Left-Arrow>, the line would be
              > > > >
              > > > > vimvim
              > > > >
              > > > > Then Ctrl-U
              > > > > All text before cursor would be deleted, what's left is
              > > > >
              > > > > m
              > > > >
              > > > > I was expecting vim or vimm
              > > >
              > > > I was going to say, for me the first result wouldn't be expected. While
              > > > the second one was.
              > > > Turns out, I have mapped Ctrl-U to break the undo sequence (to be able
              > > > to undo an accidental Ctrl-U)
              > > > and this results in always deleting until the first column, and for the
              > > > same reason, pressing
              > > > arrow keys results in that unexpected manner.
              > > >
              > > > Turns out, because of patch 7.4.183, a fix is really simple, something
              > > > like the attached patch.
              > > > (I'll try to update that patch to include a test later today).
              > > >
              > > > Interestingly, this has gotten unnoticed for so long. It seems Ctrl-U
              > > > in insert mode is just such an mysteric command, that one always
              > > > expects it to be doing the wrong thing ;)
              > >
              > > I also have trouble reproducing this. 'compatible' matters.
              > >
              > > Anyway, can you please add some test for this to the patch?
              >
              > Here we go. I added some more usage of i_Ctrl-U

              I think, it is actually reasonable, to expect an attachment. So let's
              try that again.

              Best,
              Christian
              --
              Es sind aber die Schmutzigsten, von denen man sagt, daß sie mit allen Wassern
              gewaschen sind.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Christian Brabandt
              ... Okay, this is becoming ridiculous now. Perhaps I need a couple of more attempts ;) Best, Christian -- -- You received this message from the vim_dev
              Message 6 of 7 , Apr 23, 2014
              • 0 Attachment
                On Mi, 23 Apr 2014, Christian Brabandt wrote:

                > > Here we go. I added some more usage of i_Ctrl-U
                >
                > I think, it is actually reasonable, to expect an attachment. So let's
                > try that again.

                Okay, this is becoming ridiculous now.

                Perhaps I need a couple of more attempts ;)

                Best,
                Christian

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • Bram Moolenaar
                ... Or more coffee :-). Worked now, thanks. -- You are only young once, but you can stay immature indefinitely. /// Bram Moolenaar -- Bram@Moolenaar.net --
                Message 7 of 7 , Apr 23, 2014
                • 0 Attachment
                  Christian Brabandt wrote:

                  > On Mi, 23 Apr 2014, Christian Brabandt wrote:
                  >
                  > > > Here we go. I added some more usage of i_Ctrl-U
                  > >
                  > > I think, it is actually reasonable, to expect an attachment. So let's
                  > > try that again.
                  >
                  > Okay, this is becoming ridiculous now.
                  >
                  > Perhaps I need a couple of more attempts ;)

                  Or more coffee :-). Worked now, thanks.

                  --
                  You are only young once, but you can stay immature indefinitely.

                  /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                  /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                  \\\ an exciting new programming language -- http://www.Zimbu.org ///
                  \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                Your message has been successfully submitted and would be delivered to recipients shortly.