Loading ...
Sorry, an error occurred while loading the content.

VIM 7.4.244 Fails to Compile on Red Hat Enterprise Linux Server release 5.9 (Tikanga)

Expand Messages
  • Ed Brown
    I m not an autotools expert by any stretch of the imagination. I ve not included a patch. But here are the details: undefining HAVE_SMACK in config.h does fix
    Message 1 of 6 , Apr 3, 2014
    • 0 Attachment
      I'm not an autotools expert by any stretch of the imagination. I've not included a patch. But here are the details:


      undefining HAVE_SMACK in config.h does fix the issue.

      ./configure --prefix=/usr/local --enable-perlinterp --enable-tclinterp --enable-pythoninterp --with-python-config-dir=/usr/local/lib/python2.7/config --with-features=huge


      gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12     -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1       -o objects/os_unix.o os_unix.c
      os_unix.c: In function ‘mch_copy_sec’:
      os_unix.c:2820: error: ‘XATTR_NAME_SMACK’ undeclared (first use in this function)
      os_unix.c:2820: error: (Each undeclared identifier is reported only once
      os_unix.c:2820: error: for each function it appears in.)
      os_unix.c:2821: error: ‘XATTR_NAME_SMACKEXEC’ undeclared (first use in this function)
      os_unix.c:2822: error: ‘XATTR_NAME_SMACKMMAP’ undeclared (first use in this function)
      make[1]: *** [objects/os_unix.o] Error 1
      make[1]: Leaving directory `/users/wcadmin/eb15792/vim-7.4.244/src'
      make: *** [first] Error 2



      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Inyeol Lee
      Use configure option --disable-smack. -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are
      Message 2 of 6 , Apr 4, 2014
      • 0 Attachment
        Use configure option --disable-smack.

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Bram Moolenaar
        ... Configure checks for the linux/xattr.h file to exist. Does yours not contain XATTR_NAME_SMACK, XATTR_NAME_SMACKEXEC and XATTR_NAME_SMACKMMAP? What does it
        Message 3 of 6 , Apr 5, 2014
        • 0 Attachment
          Ed Brown wrote:

          > I'm not an autotools expert by any stretch of the imagination. I've not
          > included a patch. But here are the details:
          >
          >
          > undefining HAVE_SMACK in config.h does fix the issue.
          >
          > ./configure --prefix=/usr/local --enable-perlinterp --enable-tclinterp
          > --enable-pythoninterp
          > --with-python-config-dir=/usr/local/lib/python2.7/config
          > --with-features=huge
          >
          >
          > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/include/gtk-2.0
          > -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
          > -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
          > -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2
          > -I/usr/include/libpng12 -g -O2 -U_FORTIFY_SOURCE
          > -D_FORTIFY_SOURCE=1 -o objects/os_unix.o os_unix.c
          > os_unix.c: In function ‘mch_copy_sec’:
          > os_unix.c:2820: error: ‘XATTR_NAME_SMACK’ undeclared (first use in this
          > function)
          > os_unix.c:2820: error: (Each undeclared identifier is reported only once
          > os_unix.c:2820: error: for each function it appears in.)
          > os_unix.c:2821: error: ‘XATTR_NAME_SMACKEXEC’ undeclared (first use in this
          > function)
          > os_unix.c:2822: error: ‘XATTR_NAME_SMACKMMAP’ undeclared (first use in this
          > function)
          > make[1]: *** [objects/os_unix.o] Error 1
          > make[1]: Leaving directory `/users/wcadmin/eb15792/vim-7.4.244/src'
          > make: *** [first] Error 2

          Configure checks for the linux/xattr.h file to exist. Does yours not
          contain XATTR_NAME_SMACK, XATTR_NAME_SMACKEXEC and XATTR_NAME_SMACKMMAP?
          What does it define then? Or what other include file defines them?

          --
          If you put 7 of the most talented OSS developers in a room for a week
          and asked them to fix a bug in a spreadsheet program, in 1 week
          you'd have 2 new mail readers and a text-based web browser.

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Matthew Russell
          ... I have the same problem on Scientific Linux 6.4 (based on RHEL 6.4). I have attached my /usr/include/linux/xattr.h file, which doesn t define the macros
          Message 4 of 6 , Apr 9, 2014
          • 0 Attachment
            On Saturday, 5 April 2014 20:02:23 UTC+1, Bram Moolenaar wrote:
            > Ed Brown wrote:
            >
            >
            >
            > > I'm not an autotools expert by any stretch of the imagination. I've not
            >
            > > included a patch. But here are the details:
            >
            > >
            >
            > >
            >
            > > undefining HAVE_SMACK in config.h does fix the issue.
            >
            > >
            >
            > > ./configure --prefix=/usr/local --enable-perlinterp --enable-tclinterp
            >
            > > --enable-pythoninterp
            >
            > > --with-python-config-dir=/usr/local/lib/python2.7/config
            >
            > > --with-features=huge
            >
            > >
            >
            > >
            >
            > > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/include/gtk-2.0
            >
            > > -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
            >
            > > -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
            >
            > > -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2
            >
            > > -I/usr/include/libpng12 -g -O2 -U_FORTIFY_SOURCE
            >
            > > -D_FORTIFY_SOURCE=1 -o objects/os_unix.o os_unix.c
            >
            > > os_unix.c: In function ‘mch_copy_sec’:
            >
            > > os_unix.c:2820: error: ‘XATTR_NAME_SMACK’ undeclared (first use in this
            >
            > > function)
            >
            > > os_unix.c:2820: error: (Each undeclared identifier is reported only once
            >
            > > os_unix.c:2820: error: for each function it appears in.)
            >
            > > os_unix.c:2821: error: ‘XATTR_NAME_SMACKEXEC’ undeclared (first use in this
            >
            > > function)
            >
            > > os_unix.c:2822: error: ‘XATTR_NAME_SMACKMMAP’ undeclared (first use in this
            >
            > > function)
            >
            > > make[1]: *** [objects/os_unix.o] Error 1
            >
            > > make[1]: Leaving directory `/users/wcadmin/eb15792/vim-7.4.244/src'
            >
            > > make: *** [first] Error 2
            >
            >
            >
            > Configure checks for the linux/xattr.h file to exist. Does yours not
            >
            > contain XATTR_NAME_SMACK, XATTR_NAME_SMACKEXEC and XATTR_NAME_SMACKMMAP?
            >
            > What does it define then? Or what other include file defines them?
            >
            >
            >
            > --
            >
            > If you put 7 of the most talented OSS developers in a room for a week
            >
            > and asked them to fix a bug in a spreadsheet program, in 1 week
            >
            > you'd have 2 new mail readers and a text-based web browser.
            >
            >
            >
            > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
            >
            > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
            >
            > \\\ an exciting new programming language -- http://www.Zimbu.org ///
            >
            > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

            I have the same problem on Scientific Linux 6.4 (based on RHEL 6.4). I have attached my /usr/include/linux/xattr.h file, which doesn't define the macros you referenced. A quick grep in this directory suggests that these macros are not defined anywhere...

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Charles Campbell
            ... Scientific Linux 6.4 has three xattr.h entries: /usr/include/linux/xattr.h /usr/include/attr/xattr.h /usr/include/sys/xattr.h However, no file under
            Message 5 of 6 , Apr 9, 2014
            • 0 Attachment
              Bram Moolenaar wrote:
              > Ed Brown wrote:
              >
              >> I'm not an autotools expert by any stretch of the imagination. I've not
              >> included a patch. But here are the details:
              >>
              >>
              >> undefining HAVE_SMACK in config.h does fix the issue.
              >>
              >> ./configure --prefix=/usr/local --enable-perlinterp --enable-tclinterp
              >> --enable-pythoninterp
              >> --with-python-config-dir=/usr/local/lib/python2.7/config
              >> --with-features=huge
              >>
              >>
              >> gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/include/gtk-2.0
              >> -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
              >> -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
              >> -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2
              >> -I/usr/include/libpng12 -g -O2 -U_FORTIFY_SOURCE
              >> -D_FORTIFY_SOURCE=1 -o objects/os_unix.o os_unix.c
              >> os_unix.c: In function ‘mch_copy_sec’:
              >> os_unix.c:2820: error: ‘XATTR_NAME_SMACK’ undeclared (first use in this
              >> function)
              >> os_unix.c:2820: error: (Each undeclared identifier is reported only once
              >> os_unix.c:2820: error: for each function it appears in.)
              >> os_unix.c:2821: error: ‘XATTR_NAME_SMACKEXEC’ undeclared (first use in this
              >> function)
              >> os_unix.c:2822: error: ‘XATTR_NAME_SMACKMMAP’ undeclared (first use in this
              >> function)
              >> make[1]: *** [objects/os_unix.o] Error 1
              >> make[1]: Leaving directory `/users/wcadmin/eb15792/vim-7.4.244/src'
              >> make: *** [first] Error 2
              > Configure checks for the linux/xattr.h file to exist. Does yours not
              > contain XATTR_NAME_SMACK, XATTR_NAME_SMACKEXEC and XATTR_NAME_SMACKMMAP?
              > What does it define then? Or what other include file defines them?
              >
              Scientific Linux 6.4 has three xattr.h entries:

              /usr/include/linux/xattr.h
              /usr/include/attr/xattr.h
              /usr/include/sys/xattr.h

              However, no file under /usr/include has the word "SMACK" in it.

              Regards,
              Chip Campbell


              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Ed Brown
              I thought I d have time to take a look. Instead, I ve been chasing the Hearbleed bug around. Looks like commits 5595506b985a and 251acc686ca4 have resolved the
              Message 6 of 6 , Apr 11, 2014
              • 0 Attachment
                I thought I'd have time to take a look. Instead, I've been chasing the Hearbleed bug around. Looks like commits 5595506b985a and 251acc686ca4 have resolved the problem for me. 

                Thanks,

                Ed


                On Wed, Apr 9, 2014 at 10:32 AM, Matthew Russell <matthewjohnrussell@...> wrote:
                On Saturday, 5 April 2014 20:02:23 UTC+1, Bram Moolenaar  wrote:
                > Ed Brown wrote:
                >
                >
                >
                > > I'm not an autotools expert by any stretch of the imagination. I've not
                >
                > > included a patch. But here are the details:
                >
                > >
                >
                > >
                >
                > > undefining HAVE_SMACK in config.h does fix the issue.
                >
                > >
                >
                > > ./configure --prefix=/usr/local --enable-perlinterp --enable-tclinterp
                >
                > > --enable-pythoninterp
                >
                > > --with-python-config-dir=/usr/local/lib/python2.7/config
                >
                > > --with-features=huge
                >
                > >
                >
                > >
                >
                > > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -I/usr/include/gtk-2.0
                >
                > > -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
                >
                > > -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
                >
                > > -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2
                >
                > > -I/usr/include/libpng12     -g -O2 -U_FORTIFY_SOURCE
                >
                > > -D_FORTIFY_SOURCE=1       -o objects/os_unix.o os_unix.c
                >
                > > os_unix.c: In function ‘mch_copy_sec’:
                >
                > > os_unix.c:2820: error: ‘XATTR_NAME_SMACK’ undeclared (first use in this
                >
                > > function)
                >
                > > os_unix.c:2820: error: (Each undeclared identifier is reported only once
                >
                > > os_unix.c:2820: error: for each function it appears in.)
                >
                > > os_unix.c:2821: error: ‘XATTR_NAME_SMACKEXEC’ undeclared (first use in this
                >
                > > function)
                >
                > > os_unix.c:2822: error: ‘XATTR_NAME_SMACKMMAP’ undeclared (first use in this
                >
                > > function)
                >
                > > make[1]: *** [objects/os_unix.o] Error 1
                >
                > > make[1]: Leaving directory `/users/wcadmin/eb15792/vim-7.4.244/src'
                >
                > > make: *** [first] Error 2
                >
                >
                >
                > Configure checks for the linux/xattr.h file to exist.  Does yours not
                >
                > contain XATTR_NAME_SMACK, XATTR_NAME_SMACKEXEC and XATTR_NAME_SMACKMMAP?
                >
                > What does it define then?  Or what other include file defines them?
                >
                >
                >
                > --
                >
                > If you put 7 of the most talented OSS developers in a room for a week
                >
                > and asked them to fix a bug in a spreadsheet program, in 1 week
                >
                > you'd have 2 new mail readers and a text-based web browser.
                >
                >
                >
                >  /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net   \\\
                >
                > ///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                >
                > \\\  an exciting new programming language -- http://www.Zimbu.org        ///
                >
                >  \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///

                I have the same problem on Scientific Linux 6.4 (based on RHEL 6.4). I have attached my /usr/include/linux/xattr.h file, which doesn't define the macros you referenced. A quick grep in this directory suggests that these macros are not defined anywhere...

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              Your message has been successfully submitted and would be delivered to recipients shortly.