Loading ...
Sorry, an error occurred while loading the content.

Spellchecking and typographical quotes

Expand Messages
  • Ron Aaron
    I ve been bothered by the spellchecker highlighting as incorrect, words with a typographically correct quotation mark, for example it’s instead of it s .
    Message 1 of 5 , Apr 1, 2014
    • 0 Attachment
      I've been bothered by the spellchecker highlighting as incorrect, words with a typographically correct quotation mark, for example "it’s" instead of "it's".

      After much gnashing of teeth, I decided to download an updated spell file (from openoffice) and generate a new dictionary.

      My first attempt was to make the AFF file include a 'MIDWORD' phrase, but that didn't work; and when I thought about it I realized that it probably shouldn't work. So instead, I modified the .dic file so that any words with "'" in them appear also with the "’" character.

      I wonder if there isn't (or shouldn't be) an easier way to accomplish this than what I ended up doing.

      BTW, the edit of the .dic file took only a second or so:

      : g /'/ co . | s/'/’/

      (yes, vim is very cool!)

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Ron Aaron
      On another spell-related issue: is there some reasonable way to tell vim s spell engine to ignore combining characters? In Hebrew, the spellchecker always
      Message 2 of 5 , Apr 1, 2014
      • 0 Attachment
        On another spell-related issue: is there some reasonable way to tell vim's spell engine to ignore combining characters?

        In Hebrew, the spellchecker always flags "vowelled" text as incorrect, which is annoying when I am dealing with large chunks of (correct) vowelled text. I don't see a way to tell vim that those combining characters (or call them accents if you like, or vowel marks) are not important to the spelling.

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • James McCoy
        ... Could you provide some text that demonstrates the problem? Cheers, -- James GPG Key: 4096R/331BA3DB 2011-12-05 James McCoy -- --
        Message 3 of 5 , Apr 1, 2014
        • 0 Attachment
          On Tue, Apr 01, 2014 at 11:17:18AM -0700, Ron Aaron wrote:
          > In Hebrew, the spellchecker always flags "vowelled" text as incorrect,
          > which is annoying when I am dealing with large chunks of (correct)
          > vowelled text.

          Could you provide some text that demonstrates the problem?

          Cheers,
          --
          James
          GPG Key: 4096R/331BA3DB 2011-12-05 James McCoy <jamessan@...>

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Ron Aaron
          ... Sure! Here is the same word, shalom , with and without vowels: שלום שלוֹם the second version is flagged as incorrect , but differs in only the
          Message 4 of 5 , Apr 1, 2014
          • 0 Attachment
            On Wednesday, April 2, 2014 3:09:00 AM UTC+3, James McCoy wrote:

            >
            > Could you provide some text that demonstrates the problem?
            >

            Sure! Here is the same word, "shalom", with and without vowels:

            שלום

            שלוֹם


            the second version is flagged as 'incorrect', but differs in only the vowel-point 0x05b9

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Bram Moolenaar
            ... MIDWORD is only to tell the spell checker which characters are word characters. It s used for locating the word, not for checking it against the word
            Message 5 of 5 , Apr 2, 2014
            • 0 Attachment
              Ron Aaron wrote:

              > I've been bothered by the spellchecker highlighting as incorrect,
              > words with a typographically correct quotation mark, for example
              > "it’s" instead of "it's".
              >
              > After much gnashing of teeth, I decided to download an updated spell
              > file (from openoffice) and generate a new dictionary.
              >
              > My first attempt was to make the AFF file include a 'MIDWORD' phrase,
              > but that didn't work; and when I thought about it I realized that it
              > probably shouldn't work. So instead, I modified the .dic file so that
              > any words with "'" in them appear also with the "’" character.

              MIDWORD is only to tell the spell checker which characters are word
              characters. It's used for locating the word, not for checking it
              against the word list.

              > I wonder if there isn't (or shouldn't be) an easier way to accomplish
              > this than what I ended up doing.
              >
              > BTW, the edit of the .dic file took only a second or so:
              >
              > : g /'/ co . | s/'/’/
              >
              > (yes, vim is very cool!)

              That should be the right solution. We could add something in the affix
              file to say "convert this character to that character before spell
              checking". Perhaps:

              CONV ’ '

              But, that's quite a bit of work to implement.

              Please send me your updated spell files when it's working. I rarely get
              updates for spell files.

              --
              hundred-and-one symptoms of being an internet addict:
              23. You can't call your mother...she doesn't have a modem.

              /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
              /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
              \\\ an exciting new programming language -- http://www.Zimbu.org ///
              \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            Your message has been successfully submitted and would be delivered to recipients shortly.