Loading ...
Sorry, an error occurred while loading the content.

back- and forwardslash Inconsistency for viminfo

Expand Messages
  • Enno
    Under Windows, the undo-, backup- and swapdir-settings accept back- or forward-slashes, but viminfo only the backslash variant. -- -- You received this message
    Message 1 of 5 , Mar 29, 2014
    • 0 Attachment
      Under Windows, the undo-, backup- and swapdir-settings accept back- or forward-slashes, but viminfo only the backslash variant.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Bram Moolenaar
      ... That s strange. What value do you use and what is the error you experience? -- I learned the customs and mannerisms of engineers by observing them, much
      Message 2 of 5 , Mar 30, 2014
      • 0 Attachment
        Enno Nagel wrote:

        > Under Windows, the undo-, backup- and swapdir-settings accept back- or
        > forward-slashes, but viminfo only the backslash variant.

        That's strange. What value do you use and what is the error you
        experience?

        --
        I learned the customs and mannerisms of engineers by observing them, much the
        way Jane Goodall learned about the great apes, but without the hassle of
        grooming.
        (Scott Adams - The Dilbert principle)

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Enno
        ... It was let s:tmpdir=$HOME. /.vim/tmp/ and let &viminfo= !, 10, 100,:20,h,n .s:tmpdir. .viminfo This did not restore the cursor position in the last
        Message 3 of 5 , Mar 31, 2014
        • 0 Attachment
          Am Samstag, 29. März 2014 18:42:35 UTC+1 schrieb Enno:
          > Under Windows, the undo-, backup- and swapdir-settings accept back- or forward-slashes, but viminfo only the backslash variant.

          It was

          let s:tmpdir=$HOME.'/.vim/tmp/'

          and

          let &viminfo="!,\'10,\"100,:20,h,n".s:tmpdir.'.viminfo'

          This did not restore the cursor position in the last edited files.

          It works fine now since I changed the topmost line to

          let s:tmpdir=$HOME.'\.vim\tmp\'

          I am wondering why, with either one of these settings, gvim still produces a _viminfo file in the home directory.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Bram Moolenaar
          ... Perhaps you need to reset the shellslash option? -- hundred-and-one symptoms of being an internet addict: 13. You refer to going to the bathroom as
          Message 4 of 5 , Apr 1, 2014
          • 0 Attachment
            Enno Nagel wrote:

            > Am Samstag, 29. März 2014 18:42:35 UTC+1 schrieb Enno:
            > > Under Windows, the undo-, backup- and swapdir-settings accept back- or forward-slashes, but viminfo only the backslash variant.
            >
            > It was
            >
            > let s:tmpdir=$HOME.'/.vim/tmp/'
            >
            > and
            >
            > let &viminfo="!,\'10,\"100,:20,h,n".s:tmpdir.'.viminfo'
            >
            > This did not restore the cursor position in the last edited files.
            >
            > It works fine now since I changed the topmost line to
            >
            > let s:tmpdir=$HOME.'\.vim\tmp\'
            >
            > I am wondering why, with either one of these settings, gvim still
            > produces a _viminfo file in the home directory.

            Perhaps you need to reset the 'shellslash' option?

            --
            hundred-and-one symptoms of being an internet addict:
            13. You refer to going to the bathroom as downloading.

            /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
            /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
            \\\ an exciting new programming language -- http://www.Zimbu.org ///
            \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Enno
            ... Ok, I had Viewoptions+=slash set. Other than that Set shellslash yields Noshellslash, as is the default. -- -- You received this message from the vim_dev
            Message 5 of 5 , Apr 4, 2014
            • 0 Attachment
              Le samedi 29 mars 2014 18:42:35 UTC+1, Enno a écrit :
              > Under Windows, the undo-, backup- and swapdir-settings accept back- or forward-slashes, but viminfo only the backslash variant.

              Ok, I had Viewoptions+=slash set. Other than that Set shellslash yields Noshellslash, as is the default.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            Your message has been successfully submitted and would be delivered to recipients shortly.