Loading ...
Sorry, an error occurred while loading the content.
 

Issue 204 in vim: Please add BiDi support to Vim

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 204 by casey.be...@gmail.com: Please add BiDi support to Vim
    Message 1 of 3 , Mar 9, 2014
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 204 by casey.be...@...: Please add BiDi support to Vim
      http://code.google.com/p/vim/issues/detail?id=204

      For those who love using Vim, but need to work in multiple languages at the
      same time, the lack of bi-directional support for working with
      right-to-left languages is a significant drawback. I understand that this
      may be difficult to implement, but please do consider it as a significant
      feature for a future release of vim and gvim, especially as Unicode use and
      support is growing in popularity. Thanks for making Vim.

      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • vim@...
      Comment #1 on issue 204 by mattn.jp: Please add BiDi support to Vim http://code.google.com/p/vim/issues/detail?id=204 Did you try?: set rightleft -- You
      Message 2 of 3 , Mar 9, 2014
        Comment #1 on issue 204 by mattn.jp: Please add BiDi support to Vim
        http://code.google.com/p/vim/issues/detail?id=204

        Did you try?: set rightleft

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • vim@...
        Comment #2 on issue 204 by casey.be...@gmail.com: Please add BiDi support to Vim http://code.google.com/p/vim/issues/detail?id=204 That is what I m using, yes.
        Message 3 of 3 , Mar 10, 2014
          Comment #2 on issue 204 by casey.be...@...: Please add BiDi support
          to Vim
          http://code.google.com/p/vim/issues/detail?id=204

          That is what I'm using, yes. But notice here:

          http://en.wikipedia.org/wiki/Comparison_of_text_editors#Right-to-left_and_bidirectional_text

          Support for right-to-left text is not the same as bidirectional text
          support. If I have a file with English and Hebrew in the same file, I can
          only read one language at a time, depending on the direction of the text.
          Bidirectional support would mean that I would be able to read both
          languages at the same time (the text for both languages displays correctly).

          I won't pretend to know how this should be implemented, but this article
          might give a bit more detail on how it works:

          http://en.wikipedia.org/wiki/Bi-directional_text#Unicode_support

          Thanks.

          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        Your message has been successfully submitted and would be delivered to recipients shortly.