Loading ...
Sorry, an error occurred while loading the content.

Issue 185 in vim: When executing a recent version of make from within vim, a change in directory is not recognised

Expand Messages
  • vim@...
    Status: New Owner: ---- Labels: Type-Defect Priority-Medium New issue 185 by kno0...@gmail.com: When executing a recent version of make from within vim, a
    Message 1 of 5 , Dec 3, 2013
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 185 by kno0...@...: When executing a recent version of make
      from within vim, a change in directory is not recognised
      http://code.google.com/p/vim/issues/detail?id=185

      What steps will reproduce the problem?
      1. Open vim from within the root directory of a project that makes use of
      recursive make files
      2. Run :make from within vim

      What is the expected output? What do you see instead?
      If any directory changes were made, vim should recognise these and append
      the appropriate information to the quickfix-directory-stack

      What version of the product are you using? On what operating system?
      (g)vim 7.4 with patches 1 to 86
      gnu make 4.0
      OS Arch Linux

      Please provide any additional information below.
      It seems that the output of gnu make for entering a directory
      has changed from:

      make[1]: Entering directory `/path/to/directory'

      to

      make[1]: Entering directory '/path/to/directory'

      Note the change from ` to ' at the beginning of the path name. I suspect
      the same has happened for the Leaving directory string as well.

      This should be a simple fix one of the patterns within the 'errorformat'
      variable in 'runtime/compiler/gcc.vim' or perhaps it may be a good idea to
      duplicate that pattern and modify the duplicate (to retain backwards
      compatibility)

      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • vim@...
      Comment #1 on issue 185 by kno0...@gmail.com: When executing a recent version of make from within vim, a change in directory is not recognised
      Message 2 of 5 , Dec 3, 2013
      • 0 Attachment
        Comment #1 on issue 185 by kno0...@...: When executing a recent
        version of make from within vim, a change in directory is not recognised
        http://code.google.com/p/vim/issues/detail?id=185

        I suppose something like this may be fine.

        Attachments:
        gcc.vim 1.3 KB

        --
        You received this message because this project is configured to send all
        issue notifications to this address.
        You may adjust your notification preferences at:
        https://code.google.com/hosting/settings

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • vim@...
        Comment #2 on issue 185 by brammool...@gmail.com: When executing a recent version of make from within vim, a change in directory is not recognised
        Message 3 of 5 , Dec 4, 2013
        • 0 Attachment
          Comment #2 on issue 185 by brammool...@...: When executing a recent
          version of make from within vim, a change in directory is not recognised
          http://code.google.com/p/vim/issues/detail?id=185

          Does it work to do it like this:
          \%D%*\\a[%*\\d]:\ Entering\ directory\ [`']%f',
          \%X%*\\a[%*\\d]:\ Leaving\ directory\ [`']%f',


          --
          You received this message because this project is configured to send all
          issue notifications to this address.
          You may adjust your notification preferences at:
          https://code.google.com/hosting/settings

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • vim@...
          Comment #3 on issue 185 by kno0...@gmail.com: When executing a recent version of make from within vim, a change in directory is not recognised
          Message 4 of 5 , Dec 4, 2013
          • 0 Attachment
            Comment #3 on issue 185 by kno0...@...: When executing a recent
            version of make from within vim, a change in directory is not recognised
            http://code.google.com/p/vim/issues/detail?id=185

            That looks like a smarter way of doing it (as in no line duplication) but
            unfortunately it's not working for me, however duplicating the lines does
            work. By the way, on closer inspection there may be other files that need
            to be changed to provide sane defaults when using make with other
            languages. Here is a complete list of all files that may need to be changed:
            runtime/compiler/fortran_g77.vim
            runtime/compiler/gcc.vim
            runtime/compiler/msc.vim
            runtime/compiler/ocaml.vim
            runtime/compiler/rst.vim
            runtime/compiler/splint.vim
            runtime/tools/ccfilter.c
            src/option.h

            --
            You received this message because this project is configured to send all
            issue notifications to this address.
            You may adjust your notification preferences at:
            https://code.google.com/hosting/settings

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • vim@...
            Updates: Labels: Runtime Comment #4 on issue 185 by chrisbr...@googlemail.com: When executing a recent version of make from within vim, a change in directory
            Message 5 of 5 , Oct 3, 2014
            • 0 Attachment
              Updates:
              Labels: Runtime

              Comment #4 on issue 185 by chrisbr...@...: When executing a
              recent version of make from within vim, a change in directory is not
              recognised
              https://code.google.com/p/vim/issues/detail?id=185

              This seems to be fixed for the gcc compiler. For the other compiler files,
              you should get in contact with their maintainers to have it fixed there.
              They will then send updated compiler plugins for inclusion with Vim to Bram.

              --
              You received this message because this project is configured to send all
              issue notifications to this address.
              You may adjust your notification preferences at:
              https://code.google.com/hosting/settings

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            Your message has been successfully submitted and would be delivered to recipients shortly.