Loading ...
Sorry, an error occurred while loading the content.

Patch 7.4.061

Expand Messages
  • Bram Moolenaar
    Patch 7.4.061 (after 7.4.055 and 7.4.056) Problem: Availability macros configure check in wrong place. Solution: Also check when not using Darwin. Remove
    Message 1 of 10 , Nov 2, 2013
    • 0 Attachment
      Patch 7.4.061 (after 7.4.055 and 7.4.056)
      Problem: Availability macros configure check in wrong place.
      Solution: Also check when not using Darwin. Remove version check.
      Files: src/configure.in, src/auto/configure, src/os_unix.c


      *** ../vim-7.4.060/src/configure.in 2013-11-02 21:04:32.000000000 +0100
      --- src/configure.in 2013-11-03 00:34:07.000000000 +0100
      ***************
      *** 206,215 ****
      dnl TODO: use -arch i386 on Intel machines
      CPPFLAGS="$CPPFLAGS -DMACOS_X_UNIX -no-cpp-precomp"

      - dnl Mac OS X 10.9+ no longer include AvailabilityMacros.h in Carbon
      - dnl so we need to include it to have access to version macros.
      - AC_CHECK_HEADER(AvailabilityMacros.h, [AC_DEFINE(HAVE_AVAILABILITYMACROS_H, 1, [ Define if we have AvailabilityMacros.h on Mac OS X ])])
      -
      dnl If Carbon is found, assume we don't want X11
      dnl unless it was specifically asked for (--with-x)
      dnl or Motif, Athena or GTK GUI is used.
      --- 206,211 ----
      ***************
      *** 232,237 ****
      --- 228,237 ----
      AC_MSG_RESULT(no)
      fi

      + dnl Mac OS X 10.9+ no longer include AvailabilityMacros.h in Carbon
      + dnl so we need to include it to have access to version macros.
      + AC_CHECK_HEADER(AvailabilityMacros.h, HAVE_AVAILABILITYMACROS_H=1)
      +
      AC_SUBST(OS_EXTRA_SRC)
      AC_SUBST(OS_EXTRA_OBJ)

      *** ../vim-7.4.060/src/auto/configure 2013-11-02 21:04:32.000000000 +0100
      --- src/auto/configure 2013-11-03 00:36:20.000000000 +0100
      ***************
      *** 4223,4229 ****
      OS_EXTRA_OBJ="objects/os_macosx.o objects/os_mac_conv.o"
      CPPFLAGS="$CPPFLAGS -DMACOS_X_UNIX -no-cpp-precomp"

      ! # On IRIX 5.3, sys/types and inttypes.h are conflicting.
      for ac_header in sys/types.h sys/stat.h stdlib.h string.h memory.h strings.h \
      inttypes.h stdint.h unistd.h
      do :
      --- 4223,4229 ----
      OS_EXTRA_OBJ="objects/os_macosx.o objects/os_mac_conv.o"
      CPPFLAGS="$CPPFLAGS -DMACOS_X_UNIX -no-cpp-precomp"

      ! # On IRIX 5.3, sys/types and inttypes.h are conflicting.
      for ac_header in sys/types.h sys/stat.h stdlib.h string.h memory.h strings.h \
      inttypes.h stdint.h unistd.h
      do :
      ***************
      *** 4241,4256 ****
      done


      ! ac_fn_c_check_header_mongrel "$LINENO" "AvailabilityMacros.h" "ac_cv_header_AvailabilityMacros_h" "$ac_includes_default"
      ! if test "x$ac_cv_header_AvailabilityMacros_h" = x""yes; then :
      !
      ! $as_echo "#define HAVE_AVAILABILITYMACROS_H 1" >>confdefs.h
      !
      ! fi
      !
      !
      !
      ! ac_fn_c_check_header_mongrel "$LINENO" "Carbon/Carbon.h" "ac_cv_header_Carbon_Carbon_h" "$ac_includes_default"
      if test "x$ac_cv_header_Carbon_Carbon_h" = x""yes; then :
      CARBON=yes
      fi
      --- 4241,4247 ----
      done


      ! ac_fn_c_check_header_mongrel "$LINENO" "Carbon/Carbon.h" "ac_cv_header_Carbon_Carbon_h" "$ac_includes_default"
      if test "x$ac_cv_header_Carbon_Carbon_h" = x""yes; then :
      CARBON=yes
      fi
      ***************
      *** 4272,4277 ****
      --- 4263,4275 ----
      $as_echo "no" >&6; }
      fi

      + ac_fn_c_check_header_mongrel "$LINENO" "AvailabilityMacros.h" "ac_cv_header_AvailabilityMacros_h" "$ac_includes_default"
      + if test "x$ac_cv_header_AvailabilityMacros_h" = x""yes; then :
      + HAVE_AVAILABILITYMACROS_H=1
      + fi
      +
      +
      +



      *** ../vim-7.4.060/src/os_unix.c 2013-11-02 21:49:28.000000000 +0100
      --- src/os_unix.c 2013-11-03 00:34:29.000000000 +0100
      ***************
      *** 804,812 ****
      * completely full.
      */

      ! #if defined(HAVE_AVAILABILITYMACROS_H) \
      ! && defined(__ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__) \
      ! && (__ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ >= 1090)
      # include <AvailabilityMacros.h>
      #endif

      --- 804,810 ----
      * completely full.
      */

      ! #if defined(HAVE_AVAILABILITYMACROS_H)
      # include <AvailabilityMacros.h>
      #endif

      *** ../vim-7.4.060/src/version.c 2013-11-03 00:28:20.000000000 +0100
      --- src/version.c 2013-11-03 00:37:02.000000000 +0100
      ***************
      *** 740,741 ****
      --- 740,743 ----
      { /* Add new patch number below this line */
      + /**/
      + 61,
      /**/

      --
      It is illegal to rob a bank and then shoot at the bank teller with a water
      pistol.
      [real standing law in Louisana, United States of America]

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Hisashi T Fujinaka
      I ve been chasing this around and around, but on OS X 10.9 I don t get HAVE_AVAILABILITY_MACROS_H set in os_unix.c, so there s no #include
      Message 2 of 10 , Nov 2, 2013
      • 0 Attachment
        I've been chasing this around and around, but on OS X 10.9 I don't get
        HAVE_AVAILABILITY_MACROS_H set in os_unix.c, so there's no #include
        <AvailabilityMacros.h> and my compile dies withthe following:

        os_unix.c:834:46: warning: declaration of 'struct sigaltstack' will not be visible outside of this function [-Wvisibility]
        extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
        ^
        ./os_unix.h:88:21: note: expanded from macro '__ARGS'
        # define __ARGS(x) x
        ^
        os_unix.c:834:13: error: conflicting types for 'sigaltstack'
        extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
        ^
        /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/signal.h:85:5: note:
        previous declaration is here
        int sigaltstack(const stack_t * __restrict, stack_t * __restrict) __DARWIN_ALIAS(sigaltstack);
        ^
        1 warning and 1 error generated.
        make: *** [objects/os_unix.o] Error 1

        --
        Hisashi T Fujinaka - htodd@...
        BSEE(6/86) + BSChem(3/95) + BAEnglish(8/95) + MSCS(8/03) + $2.50 = latte

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Bram Moolenaar
        ... Have you checked in src/auto/config.log why AvailabilityMacros.h is not found? You did do make reconfigure or make distclean ? -- Biting someone with
        Message 3 of 10 , Nov 2, 2013
        • 0 Attachment
          Hisashi T Fujinaka wrote:

          > I've been chasing this around and around, but on OS X 10.9 I don't get
          > HAVE_AVAILABILITY_MACROS_H set in os_unix.c, so there's no #include
          > <AvailabilityMacros.h> and my compile dies withthe following:
          >
          > os_unix.c:834:46: warning: declaration of 'struct sigaltstack' will not be visible outside of this function [-Wvisibility]
          > extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
          > ^
          > ./os_unix.h:88:21: note: expanded from macro '__ARGS'
          > # define __ARGS(x) x
          > ^
          > os_unix.c:834:13: error: conflicting types for 'sigaltstack'
          > extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
          > ^
          > /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/signal.h:85:5: note:
          > previous declaration is here
          > int sigaltstack(const stack_t * __restrict, stack_t * __restrict) __DARWIN_ALIAS(sigaltstack);
          > ^
          > 1 warning and 1 error generated.
          > make: *** [objects/os_unix.o] Error 1

          Have you checked in src/auto/config.log why AvailabilityMacros.h is not
          found?
          You did do "make reconfigure" or "make distclean"?

          --
          Biting someone with your natural teeth is "simple assault," while biting
          someone with your false teeth is "aggravated assault."
          [real standing law in Louisana, United States of America]

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ an exciting new programming language -- http://www.Zimbu.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Hisashi T Fujinaka
          ... AvailabilityMacros.h is found, and HAVE_AVAILABILITY_MACROS_H should be set. It just isn t when I get to line 807 in os_unix.c. This looks like a typo
          Message 4 of 10 , Nov 2, 2013
          • 0 Attachment
            On Sun, 3 Nov 2013, Bram Moolenaar wrote:

            >
            > Hisashi T Fujinaka wrote:
            >
            >> I've been chasing this around and around, but on OS X 10.9 I don't get
            >> HAVE_AVAILABILITY_MACROS_H set in os_unix.c, so there's no #include
            >> <AvailabilityMacros.h> and my compile dies with the following:
            >>
            >> os_unix.c:834:46: warning: declaration of 'struct sigaltstack' will not be visible outside of this function [-Wvisibility]
            >> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
            >> ^
            >> ./os_unix.h:88:21: note: expanded from macro '__ARGS'
            >> # define __ARGS(x) x
            >> ^
            >> os_unix.c:834:13: error: conflicting types for 'sigaltstack'
            >> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
            >> ^
            >> /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/signal.h:85:5: note:
            >> previous declaration is here
            >> int sigaltstack(const stack_t * __restrict, stack_t * __restrict) __DARWIN_ALIAS(sigaltstack);
            >> ^
            >> 1 warning and 1 error generated.
            >> make: *** [objects/os_unix.o] Error 1
            >
            > Have you checked in src/auto/config.log why AvailabilityMacros.h is not
            > found?
            > You did do "make reconfigure" or "make distclean"?

            AvailabilityMacros.h is found, and HAVE_AVAILABILITY_MACROS_H should be
            set. It just isn't when I get to line 807 in os_unix.c. This looks like
            a typo somewhere, but autoconf is not my forte.

            In config.log:

            206 configure:4266: checking AvailabilityMacros.h usability
            207 configure:4266: gcc -c -g -O2 -I/sw/include conftest.c >&5
            208 configure:4266: $? = 0
            209 configure:4266: result: yes
            210 configure:4266: checking AvailabilityMacros.h presence
            211 configure:4266: gcc -E -I/sw/include conftest.c
            212 configure:4266: $? = 0
            213 configure:4266: result: yes
            214 configure:4266: checking for AvailabilityMacros.h
            215 configure:4266: result: yes

            And every build is a clean build, so I shouldn't have to make
            reconfigure.

            --
            Hisashi T Fujinaka - htodd@...
            BSEE(6/86) + BSChem(3/95) + BAEnglish(8/95) + MSCS(8/03) + $2.50 = latte

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Kazunobu Kuriyama
            ... Thank you for your work, but unfortunately I have to say this. The same thing as Hisashi T Fujinaka experienced happened to me, and neither re-creation nor
            Message 5 of 10 , Nov 3, 2013
            • 0 Attachment
              On Nov 3, 2013, at 11:58 AM, Bram Moolenaar <Bram@...> wrote:

              >
              > Hisashi T Fujinaka wrote:
              >
              >> I've been chasing this around and around, but on OS X 10.9 I don't get
              >> HAVE_AVAILABILITY_MACROS_H set in os_unix.c, so there's no #include
              >> <AvailabilityMacros.h> and my compile dies withthe following:
              >>
              >> os_unix.c:834:46: warning: declaration of 'struct sigaltstack' will not be visible outside of this function [-Wvisibility]
              >> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
              >> ^
              >> ./os_unix.h:88:21: note: expanded from macro '__ARGS'
              >> # define __ARGS(x) x
              >> ^
              >> os_unix.c:834:13: error: conflicting types for 'sigaltstack'
              >> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
              >> ^
              >> /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/signal.h:85:5: note:
              >> previous declaration is here
              >> int sigaltstack(const stack_t * __restrict, stack_t * __restrict) __DARWIN_ALIAS(sigaltstack);
              >> ^
              >> 1 warning and 1 error generated.
              >> make: *** [objects/os_unix.o] Error 1
              >
              > Have you checked in src/auto/config.log why AvailabilityMacros.h is not
              > found?
              > You did do "make reconfigure" or "make distclean”?

              Thank you for your work, but unfortunately I have to say this.

              The same thing as Hisashi T Fujinaka experienced happened to me, and neither re-creation nor cleanup of the autoconf stuff helped me.

              The new configure script actually succeeded to detect AvailabilitMacros.h, and both of resulting config.log and config.cache acknowledged the existence and presence of the header file in question; however, config.status didn’t have a line which should look like D[“HAVE_AVAILABILITYMACROS_H"]=“ 1”, which was supposed to be placed there automatically by (the product of) autoconf. (Again, script re-creation/cleanup couldn't improve the situation for me.)

              Because of that, config.status failed to define and set HAVE_AVAILABILITYMACROS_H to 1 in config.h; instead, it simply added the line /* #undef HAVE_AVAILABILITYMACROS_H */ at the very end of the file. Too conservative for us to compile os_unix.c.

              Consequently, os_unix.c couldn’t be compiled with the latest patch, as Hisashi T Fujinaka reported.

              Hopefully, this note may help to fix the problem.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • niederstrasser@...
              ... The attached patch applied on top of patch 7.4.61 makes sure that HAVE_AVAILABILITYMACROS_H is in fact defined in config.h. The current
              Message 6 of 10 , Nov 3, 2013
              • 0 Attachment
                On Sunday, November 3, 2013 4:00:16 AM UTC-5, Kazunobu Kuriyama wrote:
                > On Nov 3, 2013, at 11:58 AM, Bram Moolenaar wrote:
                >
                >
                >
                > >
                >
                > > Hisashi T Fujinaka wrote:
                >
                > >
                >
                > >> I've been chasing this around and around, but on OS X 10.9 I don't get
                >
                > >> HAVE_AVAILABILITY_MACROS_H set in os_unix.c, so there's no #include
                >
                > >> <AvailabilityMacros.h> and my compile dies withthe following:
                >
                > >>
                >
                > >> os_unix.c:834:46: warning: declaration of 'struct sigaltstack' will not be visible outside of this function [-Wvisibility]
                >
                > >> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
                >
                > >> ^
                >
                > >> ./os_unix.h:88:21: note: expanded from macro '__ARGS'
                >
                > >> # define __ARGS(x) x
                >
                > >> ^
                >
                > >> os_unix.c:834:13: error: conflicting types for 'sigaltstack'
                >
                > >> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
                >
                > >> ^
                >
                > >> /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/signal.h:85:5: note:
                >
                > >> previous declaration is here
                >
                > >> int sigaltstack(const stack_t * __restrict, stack_t * __restrict) __DARWIN_ALIAS(sigaltstack);
                >
                > >> ^
                >
                > >> 1 warning and 1 error generated.
                >
                > >> make: *** [objects/os_unix.o] Error 1
                >
                > >
                >
                > > Have you checked in src/auto/config.log why AvailabilityMacros.h is not
                >
                > > found?
                >
                > > You did do "make reconfigure" or "make distclean”?
                >
                >
                >
                > Thank you for your work, but unfortunately I have to say this.
                >
                >
                >
                > The same thing as Hisashi T Fujinaka experienced happened to me, and neither re-creation nor cleanup of the autoconf stuff helped me.
                >
                >
                >
                > The new configure script actually succeeded to detect AvailabilitMacros.h, and both of resulting config.log and config.cache acknowledged the existence and presence of the header file in question; however, config.status didn’t have a line which should look like D[“HAVE_AVAILABILITYMACROS_H"]=“ 1”, which was supposed to be placed there automatically by (the product of) autoconf. (Again, script re-creation/cleanup couldn't improve the situation for me.)
                >
                >
                >
                > Because of that, config.status failed to define and set HAVE_AVAILABILITYMACROS_H to 1 in config.h; instead, it simply added the line /* #undef HAVE_AVAILABILITYMACROS_H */ at the very end of the file. Too conservative for us to compile os_unix.c.
                >
                >
                >
                > Consequently, os_unix.c couldn’t be compiled with the latest patch, as Hisashi T Fujinaka reported.
                >
                >
                >
                > Hopefully, this note may help to fix the problem.

                The attached patch applied on top of patch 7.4.61 makes sure that HAVE_AVAILABILITYMACROS_H is in fact defined in config.h.

                The current "AC_CHECK_HEADER(AvailabilityMacros.h, HAVE_AVAILABILITYMACROS_H=1)" directive in src/configure.in just runs "HAVE_AVAILABILITYMACROS_H=1" if AvailabilityMacros.h is found, which is not very useful. Using AC_CHECK_HEADERS and removing the second parameter allows the HAVE_AVAILABILITYMACROS_H define to be properly set.

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Kazunobu Kuriyama
                ... I ve just confirmed that this patch fixes the problem. I highly appreciate the patch and IÆm deeply grateful to niederstrasser@gmail.com, the contributor,
                Message 7 of 10 , Nov 3, 2013
                • 0 Attachment
                  On Nov 4, 2013, at 1:47 AM, niederstrasser@... wrote:

                  > On Sunday, November 3, 2013 4:00:16 AM UTC-5, Kazunobu Kuriyama wrote:
                  >> On Nov 3, 2013, at 11:58 AM, Bram Moolenaar wrote:
                  >>
                  >>
                  >>
                  >>>
                  >>
                  >>> Hisashi T Fujinaka wrote:
                  >>
                  >>>
                  >>
                  >>>> I've been chasing this around and around, but on OS X 10.9 I don't get
                  >>
                  >>>> HAVE_AVAILABILITY_MACROS_H set in os_unix.c, so there's no #include
                  >>
                  >>>> <AvailabilityMacros.h> and my compile dies withthe following:
                  >>
                  >>>>
                  >>
                  >>>> os_unix.c:834:46: warning: declaration of 'struct sigaltstack' will not be visible outside of this function [-Wvisibility]
                  >>
                  >>>> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
                  >>
                  >>>> ^
                  >>
                  >>>> ./os_unix.h:88:21: note: expanded from macro '__ARGS'
                  >>
                  >>>> # define __ARGS(x) x
                  >>
                  >>>> ^
                  >>
                  >>>> os_unix.c:834:13: error: conflicting types for 'sigaltstack'
                  >>
                  >>>> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
                  >>
                  >>>> ^
                  >>
                  >>>> /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/signal.h:85:5: note:
                  >>
                  >>>> previous declaration is here
                  >>
                  >>>> int sigaltstack(const stack_t * __restrict, stack_t * __restrict) __DARWIN_ALIAS(sigaltstack);
                  >>
                  >>>> ^
                  >>
                  >>>> 1 warning and 1 error generated.
                  >>
                  >>>> make: *** [objects/os_unix.o] Error 1
                  >>
                  >>>
                  >>
                  >>> Have you checked in src/auto/config.log why AvailabilityMacros.h is not
                  >>
                  >>> found?
                  >>
                  >>> You did do "make reconfigure" or "make distclean”?
                  >>
                  >>
                  >>
                  >> Thank you for your work, but unfortunately I have to say this.
                  >>
                  >>
                  >>
                  >> The same thing as Hisashi T Fujinaka experienced happened to me, and neither re-creation nor cleanup of the autoconf stuff helped me.
                  >>
                  >>
                  >>
                  >> The new configure script actually succeeded to detect AvailabilitMacros.h, and both of resulting config.log and config.cache acknowledged the existence and presence of the header file in question; however, config.status didn’t have a line which should look like D[“HAVE_AVAILABILITYMACROS_H"]=“ 1”, which was supposed to be placed there automatically by (the product of) autoconf. (Again, script re-creation/cleanup couldn't improve the situation for me.)
                  >>
                  >>
                  >>
                  >> Because of that, config.status failed to define and set HAVE_AVAILABILITYMACROS_H to 1 in config.h; instead, it simply added the line /* #undef HAVE_AVAILABILITYMACROS_H */ at the very end of the file. Too conservative for us to compile os_unix.c.
                  >>
                  >>
                  >>
                  >> Consequently, os_unix.c couldn’t be compiled with the latest patch, as Hisashi T Fujinaka reported.
                  >>
                  >>
                  >>
                  >> Hopefully, this note may help to fix the problem.
                  >
                  > The attached patch applied on top of patch 7.4.61 makes sure that HAVE_AVAILABILITYMACROS_H is in fact defined in config.h.
                  >
                  > The current "AC_CHECK_HEADER(AvailabilityMacros.h, HAVE_AVAILABILITYMACROS_H=1)" directive in src/configure.in just runs "HAVE_AVAILABILITYMACROS_H=1" if AvailabilityMacros.h is found, which is not very useful. Using AC_CHECK_HEADERS and removing the second parameter allows the HAVE_AVAILABILITYMACROS_H define to be properly set.<vim_fix_HAVE_AVAILABILITYMACROS_H.patch>

                  I've just confirmed that this patch fixes the problem.

                  I highly appreciate the patch and I’m deeply grateful to niederstrasser@..., the contributor, for that.

                  With best regards,
                  Kazunobu Kuriyama

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Bram Moolenaar
                  ... Yeah, it s because of the unusual way AC_CHECK_HEADER() is used. We should just use AC_CHECK_HEADERS(). -- Close your shells, or I ll kill -9 you Tomorrow
                  Message 8 of 10 , Nov 3, 2013
                  • 0 Attachment
                    Kazunobu Kuriyama wrote:

                    > On Nov 3, 2013, at 11:58 AM, Bram Moolenaar <Bram@...> wrote:
                    >
                    > >
                    > > Hisashi T Fujinaka wrote:
                    > >
                    > >> I've been chasing this around and around, but on OS X 10.9 I don't get
                    > >> HAVE_AVAILABILITY_MACROS_H set in os_unix.c, so there's no #include
                    > >> <AvailabilityMacros.h> and my compile dies withthe following:
                    > >>
                    > >> os_unix.c:834:46: warning: declaration of 'struct sigaltstack' will not be visible outside of this function [-Wvisibility]
                    > >> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
                    > >> ^
                    > >> ./os_unix.h:88:21: note: expanded from macro '__ARGS'
                    > >> # define __ARGS(x) x
                    > >> ^
                    > >> os_unix.c:834:13: error: conflicting types for 'sigaltstack'
                    > >> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
                    > >> ^
                    > >> /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/signal.h:85:5: note:
                    > >> previous declaration is here
                    > >> int sigaltstack(const stack_t * __restrict, stack_t * __restrict) __DARWIN_ALIAS(sigaltstack);
                    > >> ^
                    > >> 1 warning and 1 error generated.
                    > >> make: *** [objects/os_unix.o] Error 1
                    > >
                    > > Have you checked in src/auto/config.log why AvailabilityMacros.h is not
                    > > found?
                    > > You did do "make reconfigure" or "make distclean”?
                    >
                    > Thank you for your work, but unfortunately I have to say this.
                    >
                    > The same thing as Hisashi T Fujinaka experienced happened to me, and neither re-creation nor cleanup of the autoconf stuff helped me.
                    >
                    > The new configure script actually succeeded to detect AvailabilitMacros.h, and both of resulting config.log and config.cache acknowledged the existence and presence of the header file in question; however, config.status didn’t have a line which should look like D[“HAVE_AVAILABILITYMACROS_H"]=“ 1”, which was supposed to be placed there automatically by (the product of) autoconf. (Again, script re-creation/cleanup couldn't improve the situation for me.)
                    >
                    > Because of that, config.status failed to define and set HAVE_AVAILABILITYMACROS_H to 1 in config.h; instead, it simply added the line /* #undef HAVE_AVAILABILITYMACROS_H */ at the very end of the file. Too conservative for us to compile os_unix.c.
                    >
                    > Consequently, os_unix.c couldn’t be compiled with the latest patch, as Hisashi T Fujinaka reported.
                    >
                    > Hopefully, this note may help to fix the problem.

                    Yeah, it's because of the unusual way AC_CHECK_HEADER() is used.
                    We should just use AC_CHECK_HEADERS().

                    --
                    Close your shells, or I'll kill -9 you
                    Tomorrow I'll quota you
                    Remember the disks'll always be full
                    And then while I'm away
                    I'll write ~ everyday
                    And I'll send-pr all my buggings to you.
                    [ CVS log "Beatles style" for FreeBSD ports/INDEX, Satoshi Asami ]

                    /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                    /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                    \\\ an exciting new programming language -- http://www.Zimbu.org ///
                    \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Bram Moolenaar
                    ... Thanks, I figured out the same (your message came in a bit later). Patch 7.4.062 has this fix. Hopefully it finally works. -- A programmer s wife asks him:
                    Message 9 of 10 , Nov 3, 2013
                    • 0 Attachment
                      Niederstrasser wrote:

                      > The attached patch applied on top of patch 7.4.61 makes sure that
                      > HAVE_AVAILABILITYMACROS_H is in fact defined in config.h.
                      >
                      > The current "AC_CHECK_HEADER(AvailabilityMacros.h,
                      > HAVE_AVAILABILITYMACROS_H=1)" directive in src/configure.in just runs
                      > "HAVE_AVAILABILITYMACROS_H=1" if AvailabilityMacros.h is found, which
                      > is not very useful. Using AC_CHECK_HEADERS and removing the second
                      > parameter allows the HAVE_AVAILABILITYMACROS_H define to be properly
                      > set.

                      Thanks, I figured out the same (your message came in a bit later).
                      Patch 7.4.062 has this fix.
                      Hopefully it finally works.

                      --
                      A programmer's wife asks him: "Please run to the store and pick up a loaf of
                      bread. If they have eggs, get a dozen". The programmer comes home with 12
                      loafs of bread.

                      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
                      \\\ an exciting new programming language -- http://www.Zimbu.org ///
                      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

                      --
                      --
                      You received this message from the "vim_dev" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_dev" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Kazunobu Kuriyama
                      ... Oh my... I thought this sort of mistakes was made only by those who speak a language which doesn t have grammatical plural forms in nouns, like Japanese
                      Message 10 of 10 , Nov 3, 2013
                      • 0 Attachment
                        On Nov 4, 2013, at 4:23 AM, Bram Moolenaar <Bram@...> wrote:

                        >
                        > Kazunobu Kuriyama wrote:
                        >
                        >> On Nov 3, 2013, at 11:58 AM, Bram Moolenaar <Bram@...> wrote:
                        >>
                        >>>
                        >>> Hisashi T Fujinaka wrote:
                        >>>
                        >>>> I've been chasing this around and around, but on OS X 10.9 I don't get
                        >>>> HAVE_AVAILABILITY_MACROS_H set in os_unix.c, so there's no #include
                        >>>> <AvailabilityMacros.h> and my compile dies withthe following:
                        >>>>
                        >>>> os_unix.c:834:46: warning: declaration of 'struct sigaltstack' will not be visible outside of this function [-Wvisibility]
                        >>>> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
                        >>>> ^
                        >>>> ./os_unix.h:88:21: note: expanded from macro '__ARGS'
                        >>>> # define __ARGS(x) x
                        >>>> ^
                        >>>> os_unix.c:834:13: error: conflicting types for 'sigaltstack'
                        >>>> extern int sigaltstack __ARGS((const struct sigaltstack *ss, struct sigaltstack *oss));
                        >>>> ^
                        >>>> /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/usr/include/signal.h:85:5: note:
                        >>>> previous declaration is here
                        >>>> int sigaltstack(const stack_t * __restrict, stack_t * __restrict) __DARWIN_ALIAS(sigaltstack);
                        >>>> ^
                        >>>> 1 warning and 1 error generated.
                        >>>> make: *** [objects/os_unix.o] Error 1
                        >>>
                        >>> Have you checked in src/auto/config.log why AvailabilityMacros.h is not
                        >>> found?
                        >>> You did do "make reconfigure" or "make distclean”?
                        >>
                        >> Thank you for your work, but unfortunately I have to say this.
                        >>
                        >> The same thing as Hisashi T Fujinaka experienced happened to me, and neither re-creation nor cleanup of the autoconf stuff helped me.
                        >>
                        >> The new configure script actually succeeded to detect AvailabilitMacros.h, and both of resulting config.log and config.cache acknowledged the existence and presence of the header file in question; however, config.status didn’t have a line which should look like D[“HAVE_AVAILABILITYMACROS_H"]=“ 1”, which was supposed to be placed there automatically by (the product of) autoconf. (Again, script re-creation/cleanup couldn't improve the situation for me.)
                        >>
                        >> Because of that, config.status failed to define and set HAVE_AVAILABILITYMACROS_H to 1 in config.h; instead, it simply added the line /* #undef HAVE_AVAILABILITYMACROS_H */ at the very end of the file. Too conservative for us to compile os_unix.c.
                        >>
                        >> Consequently, os_unix.c couldn’t be compiled with the latest patch, as Hisashi T Fujinaka reported.
                        >>
                        >> Hopefully, this note may help to fix the problem.
                        >
                        > Yeah, it's because of the unusual way AC_CHECK_HEADER() is used.
                        > We should just use AC_CHECK_HEADERS().

                        Oh my... I thought this sort of mistakes was made only by those who speak a language which doesn't have grammatical plural forms in nouns, like Japanese language, and that European people were free from it. OK, I see again there’s a subtle but big difference between singular and plural forms... :-)

                        --
                        --
                        You received this message from the "vim_dev" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_dev" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      Your message has been successfully submitted and would be delivered to recipients shortly.