Loading ...
Sorry, an error occurred while loading the content.

Operator-pending cursor in GUI with custom map

Expand Messages
  • Anatoli Sakhnik
    Hello, vim developers! I ve noticed that the operator-pending mode cursor in GUI may be delayed according to timeoutlen when a custom map is defined. Judge
    Message 1 of 4 , Oct 22, 2013
    • 0 Attachment
      Hello, vim developers!

      I've noticed that the operator-pending mode cursor in GUI may be delayed according to 'timeoutlen' when a custom map is defined. Judge by yourself:

      $ gvim -u NONE -N

      :map cs <nop>
      :set timeoutlen=1000
      iHello<esc>
      d

      Behold! The cursor stays full height for another second, and only then shrinks by a half. Should cs be unmapped, the cursor responds promptly.

      Is that a bug?

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Christian Brabandt
      ... I see that only, when d is mapped and one is using the normal mode d command, which is clear, since Vim needs to wait if you are using the map or the
      Message 2 of 4 , Oct 22, 2013
      • 0 Attachment
        On Tue, October 22, 2013 14:07, Anatoli Sakhnik wrote:
        > Hello, vim developers!
        >
        > I've noticed that the operator-pending mode cursor in GUI may be delayed
        > according to 'timeoutlen' when a custom map is defined. Judge by yourself:
        >
        > $ gvim -u NONE -N
        >
        > :map cs <nop>
        > :set timeoutlen=1000
        > iHello<esc>
        > d
        >
        > Behold! The cursor stays full height for another second, and only then
        > shrinks by a half. Should cs be unmapped, the cursor responds promptly.
        >
        > Is that a bug?

        I see that only, when d is mapped and one is using the normal mode 'd'
        command, which is clear, since Vim needs to wait if you are using the map
        or the normal 'd' command.

        Do you really see that with the normal mode 'd' command, while
        you mapped 'cs'?

        Best,
        Christian

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Anatolii Sakhnik
        ... Of course, I mistook and ment map ds . Well then, let it be. -- -- You received this message from the vim_dev maillist. Do not top-post! Type your
        Message 3 of 4 , Oct 22, 2013
        • 0 Attachment
          ÷¦×ÔÏÒÏË, 22 ÖÏ×ÔÎÑ 2013 Ò. 15:32:13 UTC+3 ËÏÒÉÓÔÕ×ÁÞ Christian Brabandt ÎÁÐÉÓÁ×:
          >
          >
          > I see that only, when d is mapped and one is using the normal mode 'd'
          >
          > command, which is clear, since Vim needs to wait if you are using the map
          >
          > or the normal 'd' command.
          >
          >
          >
          > Do you really see that with the normal mode 'd' command, while
          >
          > you mapped 'cs'?
          >
          >

          Of course, I mistook and ment 'map ds <nop>'. Well then, let it be.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          ... No bug. Because Vim *must* wait for another character to be able to tell, whether it should expand the mapping or whether you actually meant the normal
          Message 4 of 4 , Oct 22, 2013
          • 0 Attachment
            On Di, 22 Okt 2013, Anatolii Sakhnik wrote:

            > Вівторок, 22 жовтня 2013 р. 15:32:13 UTC+3 користувач Christian Brabandt написав:
            > >
            > >
            > > I see that only, when d is mapped and one is using the normal mode 'd'
            > >
            > > command, which is clear, since Vim needs to wait if you are using the map
            > >
            > > or the normal 'd' command.
            > >
            > >
            > >
            > > Do you really see that with the normal mode 'd' command, while
            > >
            > > you mapped 'cs'?
            > >
            > >
            >
            > Of course, I mistook and ment 'map ds <nop>'. Well then, let it be.

            No bug. Because Vim *must* wait for another character to be able to
            tell, whether it should expand the mapping or whether you actually meant
            the normal mode 'd' command followed by a motion specifier. It can't
            tell from just looking at the single 'd' char.

            regards,
            Christian
            --
            Das wahre Vaterland ist das Land, wo man die meisten Menschen trifft,
            die einem gleichen.
            -- Stendhal (eig. Marie-Henri Beyle)

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.