Loading ...
Sorry, an error occurred while loading the content.

--remote-silent ignores -R (and possibly other switches) if the server is already up

Expand Messages
  • Axel Bender
    gvim 7.4.052, compiled with MinGW64 on Windows7, 64bit With an instance of the gvim server up, the following command line will not work as expected: gvim -R
    Message 1 of 3 , Oct 13, 2013
    • 0 Attachment
      gvim 7.4.052, compiled with MinGW64 on Windows7, 64bit

      With an instance of the gvim server up, the following command line will not work as expected:

      gvim -R --remote-silent <file>

      The command will open <file>, but it will not set the RO attribute accordingly.
      The same command line, w/o the server being up, will correctly open <file> as RO.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... That s an issue already in the TODO list, and it s caused because the Vim that runs your command is a different Vim than actually edits the file.
      Message 2 of 3 , Oct 13, 2013
      • 0 Attachment
        On Sunday, October 13, 2013 7:51:41 AM UTC-5, Axel Bender wrote:
        > gvim 7.4.052, compiled with MinGW64 on Windows7, 64bit
        >
        > With an instance of the gvim server up, the following command line will not work as expected:
        >
        > gvim -R --remote-silent <file>
        >
        > The command will open <file>, but it will not set the RO attribute accordingly.
        > The same command line, w/o the server being up, will correctly open <file> as RO.

        That's an issue already in the TODO list, and it's caused because the Vim that runs your command is a different Vim than actually edits the file. --remote-silent works by launching a new Vim, and if there is an existing Vim, sending a message to that Vim telling it to open the file. None of the command-line parameters like -R are sent over to that new Vim.

        According to the todo list, the issue was reported by YOU back in May 2012 :-)

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Axel Bender
        ... Seems I m getting old then ;-) -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are
        Message 3 of 3 , Oct 13, 2013
        • 0 Attachment
          > According to the todo list, the issue was reported by YOU back in May 2012 :-)

          Seems I'm getting old then ;-)

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.