Loading ...
Sorry, an error occurred while loading the content.
 

'[(' doesn't work from inside string

Expand Messages
  • Wiktor Ruben
    Hello, The subject is self-explanatory. I use Vim 7.4.052. Steps to reproduce: vim -u NONE Enter the text below: (foo foo bar ) Put cursor on the first foo
    Message 1 of 2 , Oct 9, 2013
      Hello,
      The subject is self-explanatory. I use Vim 7.4.052. Steps to
      reproduce:

      vim -u NONE

      Enter the text below:

      (foo "foo bar")

      Put cursor on the first 'foo' and try '[('. It works. Put cursor on the
      second foo and try '[(' once again. It still works. Let's switch to
      'nocompatible' mode:

      :set nocp

      Observe that '[(' on the second 'foo' is broken now.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Christian Brabandt
      ... That is caused by the % flag in cpo (or rather by the flag being absent in your cpo settings) and is supposed to be a feature ;) regards, Christian --
      Message 2 of 2 , Oct 9, 2013
        On Mi, 09 Okt 2013, Wiktor Ruben wrote:

        > Hello,
        > The subject is self-explanatory. I use Vim 7.4.052. Steps to
        > reproduce:
        >
        > vim -u NONE
        >
        > Enter the text below:
        >
        > (foo "foo bar")
        >
        > Put cursor on the first 'foo' and try '[('. It works. Put cursor on the
        > second foo and try '[(' once again. It still works. Let's switch to
        > 'nocompatible' mode:
        >
        > :set nocp
        >
        > Observe that '[(' on the second 'foo' is broken now.

        That is caused by the '%' flag in cpo (or rather by the flag being
        absent in your cpo settings) and is supposed to be a feature ;)

        regards,
        Christian
        --
        Zwei Zahnstocher gehen im Wald spazieren und sehen einen
        Igel vorbeilaufen. Sagt der eine zum anderen:
        "Ich wußte gar nicht, daß hier Busse fahren."

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.