Loading ...
Sorry, an error occurred while loading the content.
 

Re: [patch] breakindent patch for 7.4.x

Expand Messages
  • Charles
    ... Thanks. Just want to add note that the patch line ending is in DOS, so anyone applying the patch may want to convert the line endings first. -- -- You
    Message 1 of 5 , Oct 6, 2013
      On Sat, Oct 5, 2013 at 5:39 PM, Ken Takata <kentkt@...> wrote:
      Hi,

      The breakindent patch was originally written by Václav Šmilauer and it is
      currently maintained at https://retracile.net/wiki/VimBreakIndent .
      The latest version is for 7.3.944 and it can't be applied to 7.4.x.
      There is an updated version by Taylor Hedberg but it also can't be applied
      to 7.4.x. (https://groups.google.com/d/msg/vim_dev/JfbTedtmSuc/KIkfD9cRhgYJ)

      So I have updated the breakindent patch for 7.4.x. I also fixed coding style.
      There were many lines that exceeds 80 columns. And I also fixed a TODO in
      strdisplaywidth(). Now strdisplaywidth() has the third parameter which can
      specify a line number.
      Attached patch can be applied to 7.4.035 and 7.4.050.

      Regards,
      Ken Takata

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.

      Thanks.

      Just want to add note that the patch line ending is in DOS, so anyone applying the patch may want to convert the line endings first.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ken Takata
      Hi Amadeus, ... It seems that it is caused by this #if defined(FEAT_TRANSPARENCY) block:
      Message 2 of 5 , Oct 6, 2013
        Hi Amadeus,

        2013/10/07 Mon 5:59:13 UTC+9 Amadeus Demarzi wrote:
        > I am interested in this patch for MacVim, unfortunately when I apply it, I get the following errors.
        >
        > Non verbose output:
        > ~/Development/macvim: git apply file.patch
        > error: patch failed: src/option.c:8501
        > error: src/option.c: patch does not apply

        It seems that it is caused by this "#if defined(FEAT_TRANSPARENCY)" block:
        https://github.com/b4winckler/macvim/blob/9fc84fb9b0cb8abaf3bce42f82bb956b255a9120/src/option.c#L8613

        Reducing context lines may solve this problem.
        Please try the attached patch.

        The difference from the previous patch is:
        $ diff vim-7.4.035-breakindent.patch vim-7.4.035-breakindent-macvim.patch
        775c775
        < @@ -8501,6 +8533,16 @@
        ---
        > @@ -8501,5 +8533,15 @@
        791d790
        < else if (pp == &curbuf->b_p_tw)

        Regards,
        Ken Takata

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Amadeus Demarzi
        Awesome, works like a charm, thanks! ... -- -- You received this message from the vim_dev maillist. Do not top-post! Type your reply below the text you are
        Message 3 of 5 , Oct 6, 2013
          Awesome, works like a charm, thanks!

          On Sunday, October 6, 2013 8:17:36 PM UTC-7, Ken Takata wrote:
          > Hi Amadeus,
          >
          > 2013/10/07 Mon 5:59:13 UTC+9 Amadeus Demarzi wrote:
          > > I am interested in this patch for MacVim, unfortunately when I apply it, I get the following errors.
          > >
          > > Non verbose output:
          > > ~/Development/macvim: git apply file.patch
          > > error: patch failed: src/option.c:8501
          > > error: src/option.c: patch does not apply
          >
          > It seems that it is caused by this "#if defined(FEAT_TRANSPARENCY)" block:
          > https://github.com/b4winckler/macvim/blob/9fc84fb9b0cb8abaf3bce42f82bb956b255a9120/src/option.c#L8613
          >
          > Reducing context lines may solve this problem.
          > Please try the attached patch.
          >
          > The difference from the previous patch is:
          > $ diff vim-7.4.035-breakindent.patch vim-7.4.035-breakindent-macvim.patch
          > 775c775
          > < @@ -8501,6 +8533,16 @@
          > ---
          > > @@ -8501,5 +8533,15 @@
          > 791d790
          > < else if (pp == &curbuf->b_p_tw)
          >
          > Regards,
          > Ken Takata

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.