Loading ...
Sorry, an error occurred while loading the content.
 

possible search bug

Expand Messages
  • Nachum Kanovsky
    I am using gvim 7.3.547, but I also compiled 7.4.52 and the issue persists there. bugreport.txt is generated from 7.3.547. I also tested this after removing
    Message 1 of 3 , Oct 6, 2013
      I am using gvim 7.3.547, but I also compiled 7.4.52 and the issue persists there. bugreport.txt is generated from 7.3.547. I also tested this after removing .vim and .vimrc. I am running on Debian 3.2.

      With this text:
      blah
      end
      endmodule
      endcase

      If you search using:
      /\<\(end\|endcase\>\)\@!\k\+

      It should find blah and endmodule as it doesn't match end, or endcase. Only blah is found.

      This does find blah and endmodule:
      /\<\(endcase\|end\>\)\@!\k\+

      Is this appropriate behavior?

      Thanks,
      Nachum

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • James McCoy
      ... I think what you intended to use for a pattern was something like ) @! k + or ) @! k + In your pattern the
      Message 2 of 3 , Oct 6, 2013
        On Sun, Oct 06, 2013 at 04:00:38PM -0700, Nachum Kanovsky wrote:
        > I am using gvim 7.3.547, but I also compiled 7.4.52 and the issue
        > persists there. bugreport.txt is generated from 7.3.547. I also tested
        > this after removing .vim and .vimrc. I am running on Debian 3.2.
        >
        >
        >
        > With this text:
        > blah
        >
        > end
        > endmodule
        > endcase
        >
        > If you search using:
        >
        > /\<\(end\|endcase\>\)\@!\k\+

        I think what you intended to use for a pattern was something like

        \<\(end\%(case\)\=\>\)\@!\k\+

        or

        \<\(\%(end\|endcase\)\>\)\@!\k\+

        In your pattern the \> is only applied to one of the words, which is why
        it doesn't match endmodule. \<\(end\)\@!\k\+ prevents the match.

        Cheers,
        --
        James
        GPG Key: 4096R/331BA3DB 2011-12-05 James McCoy <jamessan@...>

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • nkanovsky@...
        Thanks James. Lesson learned about submitting bugs for syntax that I don t understand well enough. Nachum -- -- You received this message from the vim_dev
        Message 3 of 3 , Oct 6, 2013
          Thanks James. Lesson learned about submitting bugs for syntax that I don't understand well enough.
          Nachum

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.