Loading ...
Sorry, an error occurred while loading the content.

Re: spellcheckcap after an ellipsis

Expand Messages
  • David Woodfall
    ... Ah. That came from #vim. ... No, it doesn t work for me either. I guess I will have to resort to using ldots{} in tex, which is the correct way. In the
    Message 1 of 6 , Sep 21, 2013
    • 0 Attachment
      On (21/09/13 16:37), Ingo Karkat <swdev@...> put forth the proposition:
      >On 21-Sep-2013 05:38 +0200, David Woodfall wrote:
      >
      >> I've noticed that the default spellcheckcap setting marks words as bad
      >> after an ellipsis if they are not capitalised.
      >>
      >> In fiction writing at least it is common to have an ellipsis and a
      >> non-capitalised next word.
      >>
      >> This is the setting that I'm currently using to fix this:
      >>
      >> set spellcapcheck="[.?!]\_[\])'"' \t...]\+")
      >>
      >> Might I suggest that this is used for the default? There may be better
      >> ways of doing it but my regexp is not strong.
      >>
      >
      >Apart from the syntax errors, that expression doesn't work. You're just
      >including the "." character thrice in the [] collection. Rather,
      >something like the following is needed:

      Ah. That came from #vim.

      >:let &spellcapcheck='\%(\.\@<!\.\|[?!]\)\_[\])''"^I ]\+'
      >
      >However, this doesn't work for me (Vim 7.3.823). I still get the
      >SpellCap highlighting on following words, even though there are no
      >matches after a "foo... bar" when I do :let @/ = &spc

      No, it doesn't work for me either.

      I guess I will have to resort to using \ldots{} in tex, which is the
      correct way.

      In the meantime if any solutions are forthcoming I'd be glad to see
      them.

      D.


      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ingo Karkat
      ... Another observation: (With the default settings,) when there s an empty line before a lowercase word, e.g. That word
      Message 2 of 6 , Sep 21, 2013
      • 0 Attachment
        On 21-Sep-2013 19:48 +0200, David Woodfall wrote:

        > On (21/09/13 16:37), Ingo Karkat <swdev@...> put forth the
        > proposition:
        >> On 21-Sep-2013 05:38 +0200, David Woodfall wrote:
        >>
        >>> I've noticed that the default spellcheckcap setting marks words as bad
        >>> after an ellipsis if they are not capitalised.
        >>>
        >>> In fiction writing at least it is common to have an ellipsis and a
        >>> non-capitalised next word.
        >>>
        >>> This is the setting that I'm currently using to fix this:
        >>>
        >>> set spellcapcheck="[.?!]\_[\])'"' \t...]\+")
        >>>
        >>> Might I suggest that this is used for the default? There may be better
        >>> ways of doing it but my regexp is not strong.
        >>>
        >>
        >> Apart from the syntax errors, that expression doesn't work. You're just
        >> including the "." character thrice in the [] collection. Rather,
        >> something like the following is needed:
        >
        > Ah. That came from #vim.
        >
        >> :let &spellcapcheck='\%(\.\@<!\.\|[?!]\)\_[\])''"^I ]\+'
        >>
        >> However, this doesn't work for me (Vim 7.3.823). I still get the
        >> SpellCap highlighting on following words, even though there are no
        >> matches after a "foo... bar" when I do :let @/ = &spc
        >
        > No, it doesn't work for me either.
        > I guess I will have to resort to using \ldots{} in tex, which is the
        > correct way.
        >
        > In the meantime if any solutions are forthcoming I'd be glad to see
        > them.

        Another observation: (With the default settings,) when there's an empty
        line before a lowercase word, e.g. That

        word <--, it always gets highlighted (except when 'spellcapcheck' is
        completely empty, but also when it's set to something inapplicable like
        :set spellcapcheck=x). How can I disable / influence that? It seems
        there's an undocumented rule besides 'spellcapcheck' (btw, my
        'spelllang' is "en_us"). Can please someone shed some light on this?!

        -- regards, ingo

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        Hi Ingo! ... The algorithm, to set the SpellCap highlighting seems a little strange, since it doesn t use the spc setting. I haven t fully understand this
        Message 3 of 6 , Sep 24, 2013
        • 0 Attachment
          Hi Ingo!

          On Sa, 21 Sep 2013, Ingo Karkat wrote:

          > On 21-Sep-2013 05:38 +0200, David Woodfall wrote:
          >
          > > I've noticed that the default spellcheckcap setting marks words as bad
          > > after an ellipsis if they are not capitalised.
          > >
          > > In fiction writing at least it is common to have an ellipsis and a
          > > non-capitalised next word.
          > >
          > > This is the setting that I'm currently using to fix this:
          > >
          > > set spellcapcheck="[.?!]\_[\])'"' \t...]\+")
          > >
          > > Might I suggest that this is used for the default? There may be better
          > > ways of doing it but my regexp is not strong.
          > >
          >
          > Apart from the syntax errors, that expression doesn't work. You're just
          > including the "." character thrice in the [] collection. Rather,
          > something like the following is needed:
          >
          > :let &spellcapcheck='\%(\.\@<!\.\|[?!]\)\_[\])''"^I ]\+'
          >
          > However, this doesn't work for me (Vim 7.3.823). I still get the
          > SpellCap highlighting on following words, even though there are no
          > matches after a "foo... bar" when I do :let @/ = &spc

          The algorithm, to set the SpellCap highlighting seems a little strange,
          since it doesn't use the 'spc' setting. I haven't fully understand this
          yet, so I can't propose a change yet. (Check the spell_check() and
          win_line() function, that calls spell_check()).

          regards,
          Christian
          --
          Den guten Steuermann lernt man erst im Sturme kennen.
          -- Lucius Annaeus Seneca (4-65 n.Chr.)

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          ... I think this happens, because Vim always assumes, a new paragraph must start with an upper case character (if spellcapcheck is set). regards, Christian --
          Message 4 of 6 , Sep 24, 2013
          • 0 Attachment
            On Sat, September 21, 2013 21:02, Ingo Karkat wrote:
            > Another observation: (With the default settings,) when there's an empty
            > line before a lowercase word, e.g. That
            >
            > word <--, it always gets highlighted (except when 'spellcapcheck' is
            > completely empty, but also when it's set to something inapplicable like
            > :set spellcapcheck=x). How can I disable / influence that? It seems
            > there's an undocumented rule besides 'spellcapcheck' (btw, my
            > 'spelllang' is "en_us"). Can please someone shed some light on this?!

            I think this happens, because Vim always assumes, a new paragraph
            must start with an upper case character (if spellcapcheck is set).

            regards,
            Christian

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.