Loading ...
Sorry, an error occurred while loading the content.
 

A double sourcing problem when opening 'help' type files.

Expand Messages
  • Bohr Shaw
    I have tested the problem with this command: vim -Nu NONE --cmd filetype plugin indent on --cmd syntax enable --startuptime t +h `cat t` and I got: ...
    Message 1 of 5 , Sep 18, 2013
      I have tested the problem with this command:

      vim -Nu NONE --cmd 'filetype plugin indent on' --cmd 'syntax enable' --startuptime t +h

      `cat t` and I got:

      ...
      201.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\scripts.vim
      206.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
      211.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
      217.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
      222.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
      ...

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bohr Shaw
      ... These file are just duplicate and there are more duplicates when I run including bundles. ...... 4473.000 001.000 001.000: sourcing
      Message 2 of 5 , Sep 18, 2013
        On Wednesday, September 18, 2013 3:14:09 PM UTC+8, Bohr Shaw wrote:
        > I have tested the problem with this command:
        >
        > vim -Nu NONE --cmd 'filetype plugin indent on' --cmd 'syntax enable' --startuptime t +h
        >
        > `cat t` and I got:
        >
        > ...
        > 201.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\scripts.vim
        > 206.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
        > 211.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
        > 217.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
        > 222.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
        > ...

        These file are just duplicate and there are more duplicates when I run including bundles.
        ......
        4473.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\scripts.vim
        4833.000 002.000 002.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
        4949.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
        5008.000 006.000 006.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\vb.vim
        5067.000 009.000 009.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\css.vim
        5093.000 175.000 159.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\html.vim
        5167.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
        5193.000 053.000 053.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\syntax\coffee.vim
        5221.000 108.000 055.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\after\syntax\html.vim
        5227.000 340.000 057.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\syntax\scala.vim
        5253.000 390.000 050.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\after\syntax\help.vim
        5326.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
        5330.000 000.000 000.000: sourcing C:\Users\Bohr\.vim\after\ftplugin\help.vim
        5716.000 002.000 002.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
        5832.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
        5889.000 006.000 006.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\vb.vim
        5947.000 007.000 007.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\css.vim
        5973.000 172.000 158.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\html.vim
        6047.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
        6070.000 051.000 051.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\syntax\coffee.vim
        6099.000 106.000 055.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\after\syntax\html.vim
        6105.000 334.000 056.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\syntax\scala.vim
        6130.000 386.000 052.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\after\syntax\help.vim
        6196.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
        6201.000 000.000 000.000: sourcing C:\Users\Bohr\.vim\after\ftplugin\help.vim
        ......

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Ben Fritz
        ... ftplugin and syntax files will be sourced every time you apply a filetype. For the help files, this probably happens because Vim sets them as help
        Message 3 of 5 , Sep 18, 2013
          On Wednesday, September 18, 2013 4:54:57 AM UTC-5, Bohr Shaw wrote:
          > On Wednesday, September 18, 2013 3:14:09 PM UTC+8, Bohr Shaw wrote:
          > > I have tested the problem with this command:
          > >
          > > vim -Nu NONE --cmd 'filetype plugin indent on' --cmd 'syntax enable' --startuptime t +h
          > >
          > > `cat t` and I got:
          > >
          > > ...
          > > 201.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\scripts.vim
          > > 206.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
          > > 211.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
          > > 217.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
          > > 222.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
          > > ...
          >
          > These file are just duplicate and there are more duplicates when I run including bundles.
          > ......
          > 4473.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\scripts.vim
          > 4833.000 002.000 002.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
          > 4949.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
          > 5008.000 006.000 006.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\vb.vim
          > 5067.000 009.000 009.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\css.vim
          > 5093.000 175.000 159.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\html.vim
          > 5167.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
          > 5193.000 053.000 053.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\syntax\coffee.vim
          > 5221.000 108.000 055.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\after\syntax\html.vim
          > 5227.000 340.000 057.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\syntax\scala.vim
          > 5253.000 390.000 050.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\after\syntax\help.vim
          > 5326.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
          > 5330.000 000.000 000.000: sourcing C:\Users\Bohr\.vim\after\ftplugin\help.vim
          > 5716.000 002.000 002.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
          > 5832.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
          > 5889.000 006.000 006.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\vb.vim
          > 5947.000 007.000 007.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\css.vim
          > 5973.000 172.000 158.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\html.vim
          > 6047.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
          > 6070.000 051.000 051.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\syntax\coffee.vim
          > 6099.000 106.000 055.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\after\syntax\html.vim
          > 6105.000 334.000 056.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\syntax\scala.vim
          > 6130.000 386.000 052.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\after\syntax\help.vim
          > 6196.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
          > 6201.000 000.000 000.000: sourcing C:\Users\Bohr\.vim\after\ftplugin\help.vim
          > ......

          ftplugin and syntax files will be sourced every time you apply a filetype.

          For the help files, this probably happens because Vim sets them as 'help' filetype when using the :help command, and then after the file is loaded, there is also a modeline in each help file which sets the filetype to 'help' a second time.

          I don't know why this would happen for your html/etc. files. Are you editing multiple files? Do you have a modeline on those? An autocmd to set filetype? Do you reload the file after detecting encoding, etc.? Any of these could cause the filetype to be applied a second time.

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Bram Moolenaar
          ... This is not abnormal. The script contains a check if syntax was already set and then finishes quickly. -- hundred-and-one symptoms of being an internet
          Message 4 of 5 , Sep 18, 2013
            Bohr Shaw wrote:

            > On Wednesday, September 18, 2013 3:14:09 PM UTC+8, Bohr Shaw wrote:
            > > I have tested the problem with this command:
            > >
            > > vim -Nu NONE --cmd 'filetype plugin indent on' --cmd 'syntax enable' --startuptime t +h
            > >
            > > `cat t` and I got:
            > >
            > > ...
            > > 201.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\scripts.vim
            > > 206.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
            > > 211.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
            > > 217.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
            > > 222.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
            > > ...
            >
            > These file are just duplicate and there are more duplicates when I run
            > including bundles.

            This is not abnormal. The script contains a check if syntax was already
            set and then finishes quickly.


            --
            hundred-and-one symptoms of being an internet addict:
            225. You sign up for free subscriptions for all the computer magazines

            /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
            /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
            \\\ an exciting new programming language -- http://www.Zimbu.org ///
            \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Bohr Shaw
            ... Thanks. And I m wondering if it s necessary to set the filetype twice. Although as Bram said it finishes quickly, it s still a speed improvement. And as
            Message 5 of 5 , Sep 18, 2013
              On Wednesday, September 18, 2013 9:45:00 PM UTC+8, Ben Fritz wrote:
              > On Wednesday, September 18, 2013 4:54:57 AM UTC-5, Bohr Shaw wrote:
              > > On Wednesday, September 18, 2013 3:14:09 PM UTC+8, Bohr Shaw wrote:
              > > > I have tested the problem with this command:
              > > >
              > > > vim -Nu NONE --cmd 'filetype plugin indent on' --cmd 'syntax enable' --startuptime t +h
              > > >
              > > > `cat t` and I got:
              > > >
              > > > ...
              > > > 201.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\scripts.vim
              > > > 206.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
              > > > 211.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
              > > > 217.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
              > > > 222.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
              > > > ...
              > >
              > > These file are just duplicate and there are more duplicates when I run including bundles.
              > > ......
              > > 4473.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\scripts.vim
              > > 4833.000 002.000 002.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
              > > 4949.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
              > > 5008.000 006.000 006.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\vb.vim
              > > 5067.000 009.000 009.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\css.vim
              > > 5093.000 175.000 159.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\html.vim
              > > 5167.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
              > > 5193.000 053.000 053.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\syntax\coffee.vim
              > > 5221.000 108.000 055.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\after\syntax\html.vim
              > > 5227.000 340.000 057.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\syntax\scala.vim
              > > 5253.000 390.000 050.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\after\syntax\help.vim
              > > 5326.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
              > > 5330.000 000.000 000.000: sourcing C:\Users\Bohr\.vim\after\ftplugin\help.vim
              > > 5716.000 002.000 002.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\help.vim
              > > 5832.000 001.000 001.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
              > > 5889.000 006.000 006.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\vb.vim
              > > 5947.000 007.000 007.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\css.vim
              > > 5973.000 172.000 158.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\html.vim
              > > 6047.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\syntax\javascript.vim
              > > 6070.000 051.000 051.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\syntax\coffee.vim
              > > 6099.000 106.000 055.000: sourcing C:\Users\Bohr\.vim\bundle\vim-coffee-script\after\syntax\html.vim
              > > 6105.000 334.000 056.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\syntax\scala.vim
              > > 6130.000 386.000 052.000: sourcing C:\Users\Bohr\.vim\bundle\vim-scala\after\syntax\help.vim
              > > 6196.000 000.000 000.000: sourcing D:\ProgramsPortable\Vim\vim74\ftplugin\help.vim
              > > 6201.000 000.000 000.000: sourcing C:\Users\Bohr\.vim\after\ftplugin\help.vim
              > > ......
              >
              > ftplugin and syntax files will be sourced every time you apply a filetype.
              >
              > For the help files, this probably happens because Vim sets them as 'help' filetype when using the :help command, and then after the file is loaded, there is also a modeline in each help file which sets the filetype to 'help' a second time.
              >
              > I don't know why this would happen for your html/etc. files. Are you editing multiple files? Do you have a modeline on those? An autocmd to set filetype? Do you reload the file after detecting encoding, etc.? Any of these could cause the filetype to be applied a second time.

              Thanks. And I'm wondering if it's necessary to set the filetype twice. Although as Bram said it finishes quickly, it's still a speed improvement.

              And as for the abnormal behavior sourcing other syntax files, I finally find it's due to the 'vim-scala' bundle which contains a 'help' syntax file.

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.