Loading ...
Sorry, an error occurred while loading the content.
 

text wrapping regression?

Expand Messages
  • Matthew Woehlke
    I just discovered that text wrapping has changed at least between vim-enhanced-7.3.1314-2.fc18.x86_64 and vim-enhanced-7.4.016-1.fc18.x86_64 (so probably
    Message 1 of 4 , Sep 17, 2013
      I just discovered that text wrapping has changed at least between
      vim-enhanced-7.3.1314-2.fc18.x86_64 and
      vim-enhanced-7.4.016-1.fc18.x86_64 (so probably between 7.3.x and 7.4.0).

      It used to be the case that if I typed some text that was almost long
      enough to wrap, then went to the beginning of the line and added some
      text, then went to the end of the (now over-length) line and typed some
      more text, vim would wrap the text when I typed at the end.

      It has stopped doing this. Was this change intended? It is very annoying
      when writing git commit messages; I have had to newly enable fo+=a as a
      work-around.

      --
      Matthew

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Do you have l in your formatoptions? In 7.4.0 I see your expected behavior with set fo=t unless I then do set fo+=l . -- -- You received this message
      Message 2 of 4 , Sep 17, 2013
        On Tuesday, September 17, 2013 12:17:57 PM UTC-5, Matthew Woehlke wrote:
        > I just discovered that text wrapping has changed at least between
        >
        > vim-enhanced-7.3.1314-2.fc18.x86_64 and
        >
        > vim-enhanced-7.4.016-1.fc18.x86_64 (so probably between 7.3.x and 7.4.0).
        >
        >
        >
        > It used to be the case that if I typed some text that was almost long
        >
        > enough to wrap, then went to the beginning of the line and added some
        >
        > text, then went to the end of the (now over-length) line and typed some
        >
        > more text, vim would wrap the text when I typed at the end.
        >
        >
        >
        > It has stopped doing this. Was this change intended? It is very annoying
        >
        > when writing git commit messages; I have had to newly enable fo+=a as a
        >
        > work-around.
        >

        Do you have 'l' in your formatoptions? In 7.4.0 I see your expected behavior with "set fo=t" unless I then do "set fo+=l".

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Matthew Woehlke
        ... Ah, I do... apparently this is now on for gitcommit where it used to be off? Still, I m not sure fo+=l is working correctly. The documentation says When a
        Message 3 of 4 , Sep 17, 2013
          On 2013-09-17 15:59, Ben Fritz wrote:
          > On Tuesday, September 17, 2013 12:17:57 PM UTC-5, Matthew Woehlke wrote:
          >> I just discovered that text wrapping has changed at least between
          >> vim-enhanced-7.3.1314-2.fc18.x86_64 and
          >> vim-enhanced-7.4.016-1.fc18.x86_64 (so probably between 7.3.x and 7.4.0).
          >>
          >> It used to be the case that if I typed some text that was almost long
          >> enough to wrap, then went to the beginning of the line and added some
          >> text, then went to the end of the (now over-length) line and typed some
          >> more text, vim would wrap the text when I typed at the end.
          >>
          >> It has stopped doing this. Was this change intended? It is very annoying
          >> when writing git commit messages; I have had to newly enable fo+=a as a
          >> work-around.
          >
          > Do you have 'l' in your formatoptions? In 7.4.0 I see your expected
          > behavior with "set fo=t" unless I then do "set fo+=l".

          Ah, I do... apparently this is now on for gitcommit where it used to be off?

          Still, I'm not sure fo+=l is working correctly. The documentation says
          "When a line was longer than 'textwidth' when the insert command
          started, Vim does not automatically format it." But I am seeing this
          even when I enter insert mode with an initially empty document and never
          leave insert mode?

          --
          Matthew

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Ben Fritz
          ... It s probably not very clear in the :help for the format options values, but the insert command can be stopped without leaving insert mode. See :help
          Message 4 of 4 , Sep 17, 2013
            On Tuesday, September 17, 2013 3:14:01 PM UTC-5, Matthew Woehlke wrote:
            >
            > Still, I'm not sure fo+=l is working correctly. The documentation says
            >
            > "When a line was longer than 'textwidth' when the insert command
            >
            > started, Vim does not automatically format it." But I am seeing this
            >
            > even when I enter insert mode with an initially empty document and never
            >
            > leave insert mode?
            >

            It's probably not very clear in the :help for the format options values, but "the insert command" can be stopped without leaving insert mode. See :help ins-special-special. Basically anything that moves the cursor currently starts a new insert.

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.