Loading ...
Sorry, an error occurred while loading the content.

Re: Trailing whitespace left at end of comment lines that wrap in the PHP filetype

Expand Messages
  • Duncan de Wet
    ... I already have those options set, hence why I noticed the bug in the first place. I cannot find any options in :h fo-table relating to leaving whitespace
    Message 1 of 10 , Sep 16, 2013
    • 0 Attachment
      On Monday, 16 September 2013 21:47:32 UTC+12, ZyX wrote:
      > On Sep 16, 2013 11:15 AM, "Duncan de Wet" <dunca...@...> wrote:
      >
      > >
      >
      > > In the PHP filetype (and possibly others) trailing whitespace is left at the end of comment lines that are wrapped as a result of the textwidth setting.
      >
      > This is controlled by formatoptions settings, see :h fo-table. Set 'list' with 'listchars' containing 'trail:-' to make them easy to spot.

      I already have those options set, hence why I noticed the bug in the first place. I cannot find any options in :h fo-table relating to leaving whitespace at the end of lines when wrapping occurs; reasonably so as there is no reason you would want to anyway.

      > Note that it is not a vim issue. If you take this as a problem it is problem in your configuration.

      It seems like a vim issue to me as it occurs in the PHP filetype but not others, under identical configurations.

      > And also please do not include 1.5 MiB files as attachements. To show a problem you should write a script that starts with omitting your user configuration (e.g. 'vim -u attached-vimrc' (that contains &rtp setting that omits non-standard plugins) or 'vim -u NONE').

      OK sorry, just thought a video would demonstrate the problem well.

      >
      > > The attached video demonstrates the problem, and how it is not evident in other filetypes such as C.
      >
      > >
      >
      > > --
      >
      > > --
      >
      > > You received this message from the "vim_dev" maillist.
      >
      > > Do not top-post! Type your reply below the text you are replying to.
      >
      > > For more information, visit http://www.vim.org/maillist.php
      >
      > >
      >
      > > ---
      >
      > > You received this message because you are subscribed to the Google Groups "vim_dev" group.
      >
      > > To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+u...@....
      >
      > > For more options, visit https://groups.google.com/groups/opt_out.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Adnan Zafar
      ... Specifically the w flag causes this behavior. It makes Vim leave trailing whitespace alone, which allows the user to have some flexibility when it comes to
      Message 2 of 10 , Sep 17, 2013
      • 0 Attachment
        On Tue, Sep 17, 2013 at 12:24 AM, Duncan de Wet <duncandewet@...> wrote:
        > On Monday, 16 September 2013 21:47:32 UTC+12, ZyX wrote:
        >
        > > This is controlled by formatoptions settings, see :h fo-table. Set 'list' with 'listchars' containing 'trail:-' to make them easy to spot.
        >
        > I already have those options set, hence why I noticed the bug in the first place. I cannot find any options in :h fo-table relating to leaving whitespace at the end of lines when wrapping occurs; reasonably so as there is no reason you would want to anyway.

        Specifically the w flag causes this behavior. It makes Vim leave
        trailing whitespace alone, which allows the user to have some
        flexibility when it comes to formatting and Vim's rigid notions of
        what a paragraph is.

        > > Note that it is not a vim issue. If you take this as a problem it is problem in your configuration.
        >
        > It seems like a vim issue to me as it occurs in the PHP filetype but not others, under identical configurations.

        Editing a PHP file and checking from where and to what formatoptions
        is set with `:verbose set fo?`, I see that w is indeed included, and
        it's set from indent/php.vim. So it would appear that you should
        contact the maintainer of that file.


        --Adnan Zafar

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Duncan de Wet
        ... list with listchars containing trail:- to make them easy to spot. ... first place. I cannot find any options in :h fo-table relating to leaving
        Message 3 of 10 , Sep 17, 2013
        • 0 Attachment

          On 17 Sep 2013 21:21, "Adnan Zafar" <adnanjzafar@...> wrote:

          >
          > On Tue, Sep 17, 2013 at 12:24 AM, Duncan de Wet <duncandewet@...> wrote:
          > > On Monday, 16 September 2013 21:47:32 UTC+12, ZyX  wrote:
          > >
          > > > This is controlled by formatoptions settings, see :h fo-table. Set 'list' with 'listchars' containing 'trail:-' to make them easy to spot.
          > >
          > > I already have those options set, hence why I noticed the bug in the first place. I cannot find any options in :h fo-table relating to leaving whitespace at the end of lines when wrapping occurs; reasonably so as there is no reason you would want to anyway.
          >
          > Specifically the w flag causes this behavior. It makes Vim leave
          > trailing whitespace alone, which allows the user to have some
          > flexibility when it comes to formatting and Vim's rigid notions of
          > what a paragraph is.
          >
          > > > Note that it is not a vim issue. If you take this as a problem it is problem in your configuration.
          > >
          > > It seems like a vim issue to me as it occurs in the PHP filetype but not others, under identical configurations.
          >
          > Editing a PHP file and checking from where and to what formatoptions
          > is set with `:verbose set fo?`, I see that w is indeed included, and
          > it's set from indent/php.vim. So it would appear that you should
          > contact the maintainer of that file.
          >
          >
          > --Adnan Zafar

          Is this not the right place to contact the maintainer of that file?

          | Duncan de Wet

          --
          --
          You received this message from the "vim_dev" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_dev" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Duncan de Wet
          ... Never mind, I have found the Github page for that filetype so have done a pull request there. -- --
          Message 4 of 10 , Sep 17, 2013
          • 0 Attachment
            On Wed, Sep 18, 2013 at 07:56:55AM +1200, Duncan de Wet wrote:
            > On 17 Sep 2013 21:21, "Adnan Zafar" <adnanjzafar@...> wrote:
            > >
            > > On Tue, Sep 17, 2013 at 12:24 AM, Duncan de Wet <duncandewet@...>
            > wrote:
            > > > On Monday, 16 September 2013 21:47:32 UTC+12, ZyX wrote:
            > > >
            > > > > This is controlled by formatoptions settings, see :h fo-table. Set
            > 'list' with 'listchars' containing 'trail:-' to make them easy to spot.
            > > >
            > > > I already have those options set, hence why I noticed the bug in the
            > first place. I cannot find any options in :h fo-table relating to leaving
            > whitespace at the end of lines when wrapping occurs; reasonably so as there
            > is no reason you would want to anyway.
            > >
            > > Specifically the w flag causes this behavior. It makes Vim leave
            > > trailing whitespace alone, which allows the user to have some
            > > flexibility when it comes to formatting and Vim's rigid notions of
            > > what a paragraph is.
            > >
            > > > > Note that it is not a vim issue. If you take this as a problem it is
            > problem in your configuration.
            > > >
            > > > It seems like a vim issue to me as it occurs in the PHP filetype but
            > not others, under identical configurations.
            > >
            > > Editing a PHP file and checking from where and to what formatoptions
            > > is set with `:verbose set fo?`, I see that w is indeed included, and
            > > it's set from indent/php.vim. So it would appear that you should
            > > contact the maintainer of that file.
            > >
            > >
            > > --Adnan Zafar
            >
            > Is this not the right place to contact the maintainer of that file?
            >
            > | Duncan de Wet

            Never mind, I have found the Github page for that filetype so have done a pull
            request there.

            <https://github.com/2072/PHP-Indenting-for-VIm/pull/20>

            --
            --
            You received this message from the "vim_dev" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_dev" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • David Fishburn
            ... Typically the Vim files have contact information at the top of them. That is the way the maintainer should be contacted, not everyone subscribes to vim_use
            Message 5 of 10 , Sep 18, 2013
            • 0 Attachment



              On Tue, Sep 17, 2013 at 8:33 PM, Duncan de Wet <duncandewet@...> wrote:
              ...
               
              >
              > Is this not the right place to contact the maintainer of that file?
              >
              > | Duncan de Wet

              Never mind, I have found the Github page for that filetype so have done a pull
              request there.

              Typically the Vim files have contact information at the top of them.
              That is the way the maintainer should be contacted, not everyone subscribes to vim_use or vim_dev.

              I have seen my plugins on github and I have no idea how they get there.
              So, if you did a "pull request" on github for any of my plugins, that would certainly not make it to me.

              HTH,
              David

              --
              --
              You received this message from the "vim_dev" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_dev" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Peter Aronoff
              ... I have a question about process. I wrote this list with a patch for Vim s shell indentation and got no response. I then realized that it was better to
              Message 6 of 10 , Sep 18, 2013
              • 0 Attachment
                On Wed Sep 09/18/13 at 9:23, David Fishburn wrote:
                > Typically the Vim files have contact information at the top of them.
                > That is the way the maintainer should be contacted, not everyone
                > subscribes to vim_use or vim_dev.

                I have a question about process.

                I wrote this list with a patch for Vim's shell indentation and got no
                response. I then realized that it was better to contact the maintainer, and
                I did so. I haven't heard anything there either.

                I understand that this is not especially high-priority (and the patch may
                be rejected for lots of reasons), but is there any procedure for what to do
                when a maintainer doesn't respond at all?


                Thanks, Peter
                --
                We have not been faced with the need to satisfy someone else's
                requirements, and for this freedom we are grateful.
                Dennis Ritchie and Ken Thompson, The UNIX Time-Sharing System

                --
                --
                You received this message from the "vim_dev" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_dev" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Nikolay Pavlov
                ... a pull ... subscribes to vim_use or vim_dev. ... would certainly not make it to me. There is a mirror for all scripts on github. It is populated
                Message 7 of 10 , Sep 18, 2013
                • 0 Attachment


                  On Sep 18, 2013 5:23 PM, "David Fishburn" <dfishburn.vim@...> wrote:
                  >
                  >
                  >
                  >
                  > On Tue, Sep 17, 2013 at 8:33 PM, Duncan de Wet <duncandewet@...> wrote:
                  >>
                  >> ...
                  >
                  >  
                  >>
                  >> >
                  >> > Is this not the right place to contact the maintainer of that file?
                  >> >
                  >> > | Duncan de Wet
                  >>
                  >> Never mind, I have found the Github page for that filetype so have done a pull
                  >> request there.
                  >
                  >
                  > Typically the Vim files have contact information at the top of them.
                  > That is the way the maintainer should be contacted, not everyone subscribes to vim_use or vim_dev.
                  >
                  > I have seen my plugins on github and I have no idea how they get there.
                  > So, if you did a "pull request" on github for any of my plugins, that would certainly not make it to me.

                  There is a mirror for all scripts on github. It is populated automatically from www.vim.org contents.

                  > HTH,
                  > David
                  >
                  > --
                  > --
                  > You received this message from the "vim_dev" maillist.
                  > Do not top-post! Type your reply below the text you are replying to.
                  > For more information, visit http://www.vim.org/maillist.php
                  >  
                  > ---
                  > You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  > To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  > For more options, visit https://groups.google.com/groups/opt_out.

                  --
                  --
                  You received this message from the "vim_dev" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                   
                  ---
                  You received this message because you are subscribed to the Google Groups "vim_dev" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Duncan de Wet
                  ... (Sorry for the previous empty email, I m still trying to figure out mutt. In this case the github URL I did find from the file, so I know it was the file
                  Message 8 of 10 , Sep 18, 2013
                  • 0 Attachment
                    On Wed, Sep 18, 2013 at 09:23:29AM -0400, David Fishburn wrote:
                    > On Tue, Sep 17, 2013 at 8:33 PM, Duncan de Wet <duncandewet@...>wrote:
                    >
                    > > ...
                    > >
                    >
                    >
                    > > >
                    > > > Is this not the right place to contact the maintainer of that file?
                    > > >
                    > > > | Duncan de Wet
                    > >
                    > > Never mind, I have found the Github page for that filetype so have done a
                    > > pull
                    > > request there.
                    > >
                    >
                    > Typically the Vim files have contact information at the top of them.
                    > That is the way the maintainer should be contacted, not everyone subscribes
                    > to vim_use or vim_dev.
                    >
                    > I have seen my plugins on github and I have no idea how they get there.
                    > So, if you did a "pull request" on github for any of my plugins, that would
                    > certainly not make it to me.

                    (Sorry for the previous empty email, I'm still trying to figure out mutt.

                    In this case the github URL I did find from the file, so I know it was the file
                    maintainer's repository.

                    He did accept my pull request so the fix to this bug will get to vim soon I
                    guess.

                    >
                    > HTH,
                    > David
                    >
                    > --
                    > --
                    > You received this message from the "vim_dev" maillist.
                    > Do not top-post! Type your reply below the text you are replying to.
                    > For more information, visit http://www.vim.org/maillist.php
                    >
                    > ---
                    > You received this message because you are subscribed to a topic in the Google Groups "vim_dev" group.
                    > To unsubscribe from this topic, visit https://groups.google.com/d/topic/vim_dev/Q_KGrMevqW0/unsubscribe.
                    > To unsubscribe from this group and all its topics, send an email to vim_dev+unsubscribe@....
                    > For more options, visit https://groups.google.com/groups/opt_out.

                    --
                    --
                    You received this message from the "vim_dev" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_dev" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  Your message has been successfully submitted and would be delivered to recipients shortly.