Loading ...
Sorry, an error occurred while loading the content.
 

Re: [patch] File test92.in and test93.in become empty. When run test on 80x20 terminal.

Expand Messages
  • Bram Moolenaar
    ... Thanks for solving this! That s a nasty problem. -- hundred-and-one symptoms of being an internet addict: 204. You re being audited because you mailed
    Message 1 of 2 , Sep 13, 2013
      Hirohito Higashi wrote:

      > Hi Bram and Vim developers,
      >
      > How to reproduce. (on linux)
      > - set terminal size to 80x20
      > - make test
      > - test92 and test93 fail.
      > - test92.in and test93.in become empty. <--- unexpected!
      >
      > Expect behavior
      > - test92.in and test93.in keep the contents of file.
      >
      > Investigation result
      > Line 34th of test92.in
      > :new test.out
      > failed (E36: Not enough room).
      > and line 36th
      > :w
      > is update to test92.in empty.
      > (test93.in is similar)
      >
      > ...and some test requires a certain height or more.
      > (e.g. test37 and test47 requires height 20)
      >
      > I wrote two patches.
      > #1 test92_93_empty.patch
      > Fixed above problem.
      >
      > #2 check_term_size_at_1st_test.patch
      > Adding check terminal size 80x24 or higher at first test.
      >
      > Please check this.

      Thanks for solving this! That's a nasty problem.


      --
      hundred-and-one symptoms of being an internet addict:
      204. You're being audited because you mailed your tax return to the IRC.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.