Loading ...
Sorry, an error occurred while loading the content.

Re: BufEnter and echomsg

Expand Messages
  • Bram Moolenaar
    ... Did you try putting unsilent before echomsg ? -- panic( Foooooooood fight! ); -- In the kernel source aha1542.c, after detecting a bad segment list ///
    Message 1 of 4 , Sep 12, 2013
    • 0 Attachment
      Charles Campbell wrote:

      > I'm having a problem exemplified by the following code snippet: (lets
      > call this prblm.vim)
      >
      > au BufEnter * sil! call Prblm(expand("<amatch>"))
      > fun! Prblm(fname)
      > let g:junk= 1
      > echomsg "TESTING<".a:fname.">"
      > endfun
      > vsplit
      >
      >
      > Use vim -u NONE prblm.vim
      > :so %
      > :echo g:junk
      >
      > At this point, we get E121 and E15. Expected.
      >
      > :mess
      >
      > No messages other than the error messages from before.
      >
      > :enew
      > :echo g:junk
      >
      > Note that g:junk is now equal to 1. OK so far...
      >
      > :mess
      >
      > The "TESTING..." message is missing, but since g:junk both exists and is
      > equal to 1, obviously the Prblm() function was called. (scientific linux
      > 6.3; vim 7.4.25, huge).

      Did you try putting "unsilent" before "echomsg" ?

      --
      panic("Foooooooood fight!");
      -- In the kernel source aha1542.c, after detecting a bad segment list

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Charles Campbell
      ... No, first I heard of that command - and, naturally, it works. Thank you! Glad it wasn t a vim bug. Chip Campbell -- -- You received this message from the
      Message 2 of 4 , Sep 12, 2013
      • 0 Attachment
        Bram Moolenaar wrote:
        > Charles Campbell wrote:
        >
        >> I'm having a problem exemplified by the following code snippet: (lets
        >> call this prblm.vim)
        >>
        >> au BufEnter * sil! call Prblm(expand("<amatch>"))
        >> fun! Prblm(fname)
        >> let g:junk= 1
        >> echomsg "TESTING<".a:fname.">"
        >> endfun
        >> vsplit
        >>
        >>
        >> Use vim -u NONE prblm.vim
        >> :so %
        >> :echo g:junk
        >>
        >> At this point, we get E121 and E15. Expected.
        >>
        >> :mess
        >>
        >> No messages other than the error messages from before.
        >>
        >> :enew
        >> :echo g:junk
        >>
        >> Note that g:junk is now equal to 1. OK so far...
        >>
        >> :mess
        >>
        >> The "TESTING..." message is missing, but since g:junk both exists and is
        >> equal to 1, obviously the Prblm() function was called. (scientific linux
        >> 6.3; vim 7.4.25, huge).
        > Did you try putting "unsilent" before "echomsg" ?
        >
        No, first I heard of that command - and, naturally, it works. Thank
        you! Glad it wasn't a vim bug.
        Chip Campbell

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.