Loading ...
Sorry, an error occurred while loading the content.

Re: Small addition to syntax/vim.vim

Expand Messages
  • Manuel Ortega
    On Wed, Aug 21, 2013 at 1:50 PM, Charles Campbell
    Message 1 of 5 , Aug 21, 2013
    • 0 Attachment
      On Wed, Aug 21, 2013 at 1:50 PM, Charles Campbell <Charles.E.Campbell@...> wrote:
      Bram Moolenaar wrote:

      So Dr. Chip, please add this attribute to the syntax file.

      And Bram, please note this in the docs about "-buffer" too.
      This is not really intended to work that way.  It happens that because
      the code uses the length of the typed argument to compare that it
      happens to work.  But I really would prefer everybody to use the whole
      name.  One might call it a bug, but since some scripts rely on it we
      probably won't fix it.

      I have two (visIncr, vimball) that use -ra= and -na= ... so I'll make them use full names.  Should I have syntax/vim.vim flag short option names as errors?

      Dr. Chip, don't forget that there is no support for the *full-length* cmd attribute "-buffer" in syntax/vim.vim :)

      -Manny

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... I would only highlight the full name as a proper argument. I suppose that implies highlighting the shorter name as an error. -- hundred-and-one symptoms
      Message 2 of 5 , Aug 22, 2013
      • 0 Attachment
        Charles Campbell wrote:

        > Bram Moolenaar wrote:
        > > Manuel Ortega wrote:
        > >
        > >> As noted in an earlier thread, I discovered that most attributes to
        > >> ":command" can be abbreviated. I discovered this only by accident, looking
        > >> in syntax/vim.vim.
        > >>
        > >> Turns out, in that syntax file (a) there is no support for the attribute
        > >> "-buffer" (for buflocal commands), and (b) trial and error indicates that
        > >> the attribute "-buffer" CAN be abbreviated all the way down to "-b".
        > >>
        > >> So Dr. Chip, please add this attribute to the syntax file.
        > >>
        > >> And Bram, please note this in the docs about "-buffer" too.
        > > This is not really intended to work that way. It happens that because
        > > the code uses the length of the typed argument to compare that it
        > > happens to work. But I really would prefer everybody to use the whole
        > > name. One might call it a bug, but since some scripts rely on it we
        > > probably won't fix it.
        > >
        > I have two (visIncr, vimball) that use -ra= and -na= ... so I'll make
        > them use full names. Should I have syntax/vim.vim flag short option
        > names as errors?

        I would only highlight the full name as a proper argument. I suppose
        that implies highlighting the shorter name as an error.

        --
        hundred-and-one symptoms of being an internet addict:
        108. While reading a magazine, you look for the Zoom icon for a better
        look at a photograph.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.