Loading ...
Sorry, an error occurred while loading the content.
 

Filename completion on Windows with Exclamation Mark

Expand Messages
  • Jan.Stocker@t-online.de
    Hi, this bug really hurts me a long time.If you use VIM on a Windows system and using directories with an exclamation mark the filename completion does not
    Message 1 of 2 , Aug 20, 2013

      Hi,

      this bug really hurts me a long time.If you use VIM on a Windows system and using directories with an exclamation mark the filename completion does not work.

      If you want to load

      c:\folder!\file.txt
      you can write
      :e c:\fold<tab>
      Now the line will be expanded to
      :e c:\folder\!\
      The exclamation mark is escaped by a backslash. This escaped string cannot be expanded, so
      :e c:\folder\!\<TAB>
      leads to a beep. You have to remove the backslash before the exclamation mark
      :e c:\folder!\<TAB>
      and it works like this
      :e c:\folder\!\file.txt
      The expanding now works BUT the backslash is inserted again. This command will not execute correctly, you have to remove the backslash again to open the file.
      :e c:\folder!\file.txt
      So I think on windows the exclamation mark should not be escaped but Bram thinks for external command the ! must be escaped.
      Can anyone have a look at this, my company has a filename convention, so i can not change the directory names.
      Thank you all a lot.
      Jan

       

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Thomas
      ... Hello, I m facing the exact same bug. It still hasn t been fixed... -- -- You received this message from the vim_dev maillist. Do not top-post! Type your
      Message 2 of 2 , May 25, 2016
        Le mardi 20 août 2013 10:29:22 UTC+2, Jan.S...@... a écrit :
        > Hi,
        >
        >
        >
        > this bug really hurts me a long time.If you use VIM on a Windows system and using directories with an exclamation mark the filename completion does not work.
        >
        >
        >
        >
        > If you want to load
        >
        >
        >
        >
        > c:\folder!\file.txt
        >
        >
        >
        > you can write
        >
        >
        >
        > :e c:\fold<tab>
        >
        >
        >
        > Now the line will be expanded to
        >
        >
        >
        > :e c:\folder\!\
        >
        >
        >
        > The exclamation mark is escaped by a backslash. This escaped string cannot be expanded, so
        >
        >
        >
        >
        >
        > :e c:\folder\!\<TAB>
        >
        >
        >
        > leads to a beep. You have to remove the backslash before the exclamation mark
        >
        >
        >
        >
        >
        > :e c:\folder!\<TAB>
        >
        >
        >
        > and it works like this
        >
        >
        >
        > :e c:\folder\!\file.txt
        >
        >
        >
        > The expanding now works BUT the backslash is inserted again. This command will not execute correctly, you have to remove the backslash again to open the file.
        >
        >
        >
        >
        >
        > :e c:\folder!\file.txt
        >
        >
        >
        > So I think on windows the exclamation mark should not be escaped but Bram thinks for external command the ! must be escaped.
        >
        > Can anyone have a look at this, my company has a filename convention, so i can not change the directory names.
        >
        >
        >
        > Thank you all a lot.
        >
        >
        >
        > Jan
        >
        >
        >
        >
        >
        >  

        Hello, I'm facing the exact same bug. It still hasn't been fixed...

        --
        --
        You received this message from the "vim_dev" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_dev" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      Your message has been successfully submitted and would be delivered to recipients shortly.